Vista Fedora 10 Dual Boot Problem - Help Please

#1
All,

I am brand new to Linux and this forum. I have done some searching and read the sticky FAQ thread, but have not been able to put together a solution.

My machine is brand new (64-bit) and I have installed Fedora 10 using the following instructions:
Fedora - NeoSmart Technologies Wiki
I used the Fedora recommended partitioning for the hard drive. I had to shrink the Vista portion in order for that part to work. I followed step 5 and put Grub in the first sector of the boot partition so EasyBCD could get at it later.

I then moved on to the EasyBCD part, first using version 1.7.2. The 50GB partition I made for Linux had a bunch of "??????" after it, which was strange. I followed the instructions (above) and left the "Grub isn't installed to the MBR/bootsector" unchecked. When I tried to boot to NeoSmart Linux it gave me the following error:
"Loading new Partition
Bootsector from C.H. Hochstatter
Cannot load from Harddisk
Insert systemdisk and press any key"
Note: I also tried other drives, and checking the box, but none worked and gave me various errors.

So I did some searches and figured installing EasyBCD 2.0 might help. Now, the 50GB partition with Linux shows up as "Partition 5 (Type0x8E - 49GB)". I used this with the unchecked box and tried to boot Linux. Now it just goes to a black screen and brings me back to the dual boot start up (where you can choose Vista or Linux).

Now I'm stumped. Any suggestions out there?
PS - If this is something that has been beaten like a dead horse on these forums I apologize that I am not savvy enough to recognize the solution.

Thanks,
Steve

Addendum:

And also, the thread linked below pretty much explains my problem I had when I used EasyBCD 1.7.2
Now it doesn't give me the Hochstatter error with 2.0, just doesn't work

What is wrong when I use EasyBCD 1.6 to boot FC7? - LinuxQuestions.org

Thanks in advance for the help.
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Make sure you've got the latest build of EasyBCD and Fedora installed. Re-add the entry. Check "grub isn't installed..." if its still not working.
 
#3
Just tried that - no dice

It went to a screen that said "Hit esc to enter boot menu"
then went to a screen that says "BOOTMGR is missing, CTRL + ALT + DEL to restart"

I am using the latest build of EasyBCD. I am required to use Fedora 10 for the project I'm working on.

I think I'm really close, there just seems to be some problem with Grub installation or with Fedora finding it.

Steve

Addendum:

Here is a screenshot of my my Disk Management data. This may help with diagnosis. I am not experienced with partitioning so maybe something went wrong there (like I said I just went with the Fedora default) that can be seen in this shot.

http://3.bp.blogspot.com/_skdyyeTS1Wg/Sk0Dvu2dbHI/AAAAAAAAAD4/jB3tACaHIHg/s1600-h/DiskManagement.jpg

Any help is much appreciated as I've been bangin the head on whatever I can for a while.

Thanks!!!
 
Last edited:

JustinW

Super Moderator
Staff member
#4
Steve, if I may ask can you post your menu.lst file as well as the screenshot in an attachment? You can attach an image by hitting the "Go Advanced" button and than clicking paper clip icon in the toolbar.
 
#5
screenshot attachment

Thanks for getting back to me Justin. I'm going to try to get what I have working before I start from scratch. I really don't want to reformat and start clean if I can help it. Here is the screenshot as an attachment. I'll get you the menu.lst file as soon as I can figure out how to find it.

Thanks
Steve
 

Attachments

Terry60

Knows where his towel is.
Staff member
#6
Boot your Linux in live mode and look for the boot/grub/menu.lst on your Linux partition (don't be confused by the /boot of the Live distro).
 
#7
Hmmmm??

Not sure what you mean by live mode. Fedora won't boot normally (that's my problem), so the only way I know how to boot it is in the Rescue mode off the installation DVD. Looking at the dir, I don't see a /boot directory. I've been working on trying to figure this out, no luck yet. Suggestions?

Please excuse my newb-ness :|

Steve
 

Terry60

Knows where his towel is.
Staff member
#8
I don't have Fedora, so don't know what they call it, but in Ubuntu, when you boot the Installation CD, the 1st option is "don't change my system" mode, where LInux boots from the CD (live mode).
I guess that's your "rescue mode".
If you can't find a /boot on the partition where you installed Fedora, that would appear to be your problem.
You said earlier "I put grub in the .... boot partition". That's where you should find /boot/grub, and where you should be pointing the EasyBCD entry. Is that the same as your Fedora partition ?
 
#9
Good point

That would make sense why things don't work if there is no boot directory. The reason I think I put grub in the first sector of the Linux partition is because that is what I told it to do during step 5 of the install process, but I guess that didn't happen. That leads me back to the question of whether I (acutally Fedora, since I let it do the default option) partitioned things properly. How does my disk management screenshot look (is it correct)?

I guess I'll try to reload Fedora. Do I need to use a program to reformat that sector of the hard drive or is there some way to "uninstall" Linux? If not, I may as well just wipe it clean and install Fedora and Vista from scratch??? Is that what you'd recommend?

Thanks for the help.

Steve
 
#10
Ok, you guys are forgetting something...
In Fedora, there is no /boot directory, because there is a separate /boot partition. So boot from the Fedora install disk live, access the /boot partition, and you will find a /grub/menu.lst directory. So copy the contents of that menu.lst into your next post.

Steve, did you make sure to point the Linux entry in EasyBCD at the separate /boot partition (not the root partition)?
 
#11
Holy crap, somehow it just worked.

I did point to the Linux in EasyBCD. When I choose to boot to Linux and let it go it says "BOOTMGR is missing, CTRL + ALT + DEL to restart"

I tried something new though, before it got to the "BOOTMGR is missing" screen, it says hit anykey to...

So then it brings me to a blue screen that says "GNU GRUB version 0.97" at the top
It gives me two options
1. Fedora 10
2. other

So I hit enter on Fedora 10 and it acted like it booted it then said "entering powersave mode" and the cpu shut down.

I tried this again and it booted Fedora 10, I went through the intialization, and now I am on the Fedora 10 desktop!!!

I have NO IDEA why this happened all of a sudden. I just hope I can replicate it. Any reason why I had to back-door into it instead of it just booting as it should?

I'm just amazed (and thrilled) it stared working.

Thanks for the help guys.

Steve
 
#12
Ok, it sounds like put the CD drive first in the boot sequence in the BIOS, and inserted the Fedora disk, but did not (the first time) press a key to boot from the CD. Hence the "bootmgr is missing error". :wink: And then when you tried it again, and this time pressed a key, it started up into the program on the Fedora disk, and gave you the two options you mentioned. So when you selected Fedora 10, something went wrong, and you had to boot from the disk again. And now you have reached the Fedora desktop in the Live session (not your regular Fedora install on the HDD).
So please follow our earlier suggestions, and post the contents of your menu.lst, so we can resolve the real problem.
 
#13
Menu.lst file

All right, this took some work for me too.
Let me know what else I should post to help get at the problem.
Again, thanks.


Here is the contents of my menu.lst file

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,4)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda5
default=1
timeout=5
splashimage=(hd0,4)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.x86_64)
root (hd0,4)
kernel /vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=UUID=1414991f-a37b-42c8-a929-1b362ef4de40 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.x86_64.img
title Other
rootnoverify (hd0,1)
chainloader +1

Addendum:

Just a heads up that I am headed out of town, and away from my desktop for the weekend so I won't be able to try any more fixes until Tuesday morning. Thanks for everyone's help! Thought I had it, but hopefully I'm close.

Steve
 
Last edited:
#14
Back at it

Allright, I've tried some things I looked up but to no avail. Has anybody who can decipher them happened to check out my menu.lst file and screenshot?

I really want to have it set up dual-boot but need to press forward with my project so I might just wipe it and install Fedora.

Thanks,
Steve
 
#15
I might be considered to newbie to help, but I'll give it a try anyway, having installed several of exactly the same configurations as the one you're describing.

Can you boot anything (either windows of fedora) without inserting the live disk?

The menu.lst you attached looks fine to me, pointing to the appropriate partitions for both systems. Did you get it from /boot/grub/menu.lst on your linux partition? At least that's the one you need.

And in EasyBCD did you use the Linux tab or NeoGrub?
 
#16
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,4)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda5
default=1
timeout=5

splashimage=(hd0,4)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.x86_64)
root (hd0,4)
kernel /vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=UUID=1414991f-a37b-42c8-a929-1b362ef4de40 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.x86_64.img
title Other
rootnoverify (hd0,1)
chainloader +1
Ok, that's a messed-up menu.lst you got there. Basically, the way you have it setup now is to default to entry 1 (which is the second entry, called "Other", since the count begins at 0), which is pointing at (hd0,1). And though the timeout value is 5 (meaning you would have 5 seconds to choose the enrtry to boot into), the "hiddenmenu" line messes that up too, because it hides the menu. That means you will boot into entry "Other" by default everytime unless you happen to press Esc to get to the menu, and then select your Fedora entry.

And according to your Disk Management, (hd0,1), which is the first hard drive in the boot sequence in the BIOS, and the second partition in the MBR partition table of that hard drive, is your "RECOVERY (D)" partition, which doesn't contain BOOTMGR and BCD, which would explain why you were getting the message "BOOTMGR is missing" when you attempted to boot into Linux.

Since I'm not sure exactly where your Fedora partition is located on your system, you can try changing the "default" line in your menu.lst to 0 instead, so that way it will default to your Fedora entry instead of the "Other" entry. There's a chance (hd0,4) is correct and that's where your Fedora partition is on your system.

If it still doesn't boot after that, though, you will need to post a screenshot of what the "Device" menu under the Linux tab in EasyBCD 2.0 shows, as well as the output of the following command run from EasyBCD's Power Console on the "Useful Utilities" page:
Code:
bootpart
 
Last edited:

JustinW

Super Moderator
Staff member
#17
rootnoverify on its own doesnt define the root I believe. Here's a working entry for Vista. In your situation where you're having problems don't hard code the root, let grub set the root dynamically:

title Other
find --set-root /bootmgr
chainloader /bootmgr
You should do the same thing for the Fedora entry too, in case things change:

title Fedora
find --set-root /vmlinuz-2.6.27.5-117.fc10.x86_64
kernel /vmlinuz-2.6.27.5-117.fc10.x86_64 ro root=UUID=1414991f-a37b-42c8-a929-1b362ef4de40 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.x86_64.img
 
Last edited: