Vista/Fedora11 dual boot, No Plymouth

#1
Hi guys,
I installed Fedora 11 first, then a fresh install of Vista.
Booting using EasyBCD and NeoGrub to launch Fedora 11

I am keeping on top of updates, and have updated my menu.lst with new Fedora kernels as they came along, and reconfigured Neogrub to use the same kernels

Followed the advice here my-guides.net - Fedora 11 Installation and Post Installation Guide
for the Fedora 11 Plymouth graphical loader.

I have done this previously with Fedora 10 and XP and had it working, Fedora installed last and grub managing the dual boot for XP.

Problem - I still get the fedora loading bar at the bottom of the screen, no Plymouth.

Machine is Acer aspire 5920g, core 2 duo, sata II HD, NVidia 8600gs, 4gb ram.

I have installed graphics drivers for NVidia, but I dont believe this makes a difference for the Plymouth loader anyway. The NVidia logo pops up after the Fedora loading bar has finished, and before I log in.

My screen resolution is 1280x800, but vbetest as suggested on my-guides is an unknown command in the terminal on fedora. (SU enabled and password protected, so I can get admin rights).
So tried without success to add vga=code with various resolutions given, so either I am not getting the correct code for my setup,

or neogrub doesn't support this function in the configured menu.lst?
 
Last edited:
#2
Having a bit of success, I found out you can put vga=ask at the end of the kernal line. I then get offered detected resolutions. There are two that work for me, code 318 and 361 (for 1280x800 24) but after entering these in the menu.lst at the end of the kernal line for instance - vga=361 on reboot I get mode not supported choose a video mode. Strangely choosing 361 from the list then works, I get the plymouth bootloader screen. So I guess the 361 code has to be converted somehow?, to enter the correct code in menu.lst Does anyone know anything about this? P.S In my-guides link in first post, he suggests adding 512 to a vbetest result, i also tried that with 361... so that would result in vga=873.... again the result was mode not supported choose one....

Addendum:

Problem solved, found the answer quicker on a linux forum... For anyone else with this problem, use vga=ask choose a resolution you think will work, reboot if not successful and try different ones. When you are happy you have found the best one, 361 for me, use it as follows... vga=0x361
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#3
Glad you've resolved the issue. Sorry nobody here had any background experience to help you with that particular problem. Welcome to the forum anyway.
 
#4
:smile: Thanks Terry for the welcome. I got the feeling that was the case, seems I was a puzzling 1 post wonder lol, but at least its posted now for anyone else to find the solution to similar problems.

EasyBCD and NeoGrub are excellent by the way, I have used a few methods of dual booting, and with different OS's installed first, EasyBCD does what it says on the tin and very well. Its taken me a while to get my head around Vistas hidden recovery partition and losing its abilities after re-partitioning (wasn't too worried to be honest because will be replacing Vista with Windows 7, and thus will have actual disks then to recover from and not be dependant upon a partitition which may itself over time become corrupt), but managed to get that working aswell. Obviously it will be going when 7 comes along :grinning:.