Vista Hibernate not working after dual boot

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#21
Thanks for the info on the new isntall. It is much appreciated. :grinning:
 

mqudsi

Mostly Harmless
Staff member
#22
^ same here :smile:

Congrats on getting it working; but I agree, it would be nice to have a reproducible scenario so we can know what to do in the future :x

Stick around, we enjoyed this too :grinning:
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#23
Sadly i think this is just a quirk that is in Vista when you install XP after Vista is already installed. This isnt the first time i have heard of this but this is the first person who was willing to format and install Vista again to test this.

It would ahve been nice to get the results reproduced so we could report it to M$ and maybe get some action taken...:tongueout:

By all means stickk around and have some more fun with us. I know we like destroying PC's it is nice to see someone else who has the spirit also.
 
#24
Those comments just gave me the courage that I needed to try and reproduce the problem. I'm not giving up.

I already have so many backups that I'm not afraid to wreck my system. My backups are tested and working so I have nothing to lose right now :smile:

I managed to get the USB floppy drive again, so... here we go :grinning:

Wish me luck! I mean... Bad luck, I guess :grinning:
 

mqudsi

Mostly Harmless
Staff member
#25
That's the spirit :grinning:
 
#26
Hello!
I've also been looking for solutions to the hibernation problem (without any success) before I found this thread.
I'm experiencing the same problems as the first guy: standby,shutoff,restart works, hibernate doesn't.
But, to make this more interesting now, I have to say that I never installed a second OS.

I just received my Lenovo ThinkPad T61p this week. It came with Vista Ultimate on a 200GB HDD. First, I let Windows do all its updates and then let Lenovo do all its updates. I like to think that hibernation did not work after that either, but I'm not really sure...

Because there was only 1 partition I tried to shrink it with Vista's partitioning tool, but with no luck, since the page-file and some other files were located right in the middle of the partition, which caused Vista to only offer a shrink up to that location. So, like footswitch, I used Paragon Partition Manager 8.5 to do that task (without problems).

Now I'm in the same situation as you...

In addition to the volmgr event when trying to hibernate, I also receive VSS (volume shadow service) errors on startup telling me that a com service with the name "Coordinator" could not be started (ID 13 ,0x800401f0), along with a second "unknown error" coming from this (ID 12289, 0x800401f0).

Jo
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#27
Hello Jo2008! Welcome to NeoSmart Technologies. :smile:

There has been some known issue with the hibernation and the updates from Janurary 8th, 2008. From what i have seen in the Microsoft Newsgroups this has happened to quite a few people where Hibernation was disabled after the updates.

Sadly there is still no known silution for this. Microsoft has acknowledged that there is a bug somehwere but no fix has been released yet.

The VSS error is the shadow copy error. That is related to your restore points. I dont know of that second error at all. Just giving me a ID doesnt help. Sorry i cant be of any more assistance.
 
#28
Well just to make clear, hibernation is not disabled. When I click on it, the screen goes dark and shortly after the login screen appears again (because it is set that after standby/hibernation the user needs to enter password again).

Is that the issue described in the newsgroups? What newsgroup did you find that in?

Not sure if the VSS errors are related. Tried to disable / restart / enable the Restore points with no results.


Do you think that it is only a coincidence that Paragon's Partition Manager was used to create the partitions? Maybe it messed something up when moving the files overlapping with the space for the new partition.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#29
So if the screen goes dark and you get the logon screen then what is the hibernation issue you are faced with? It seems that it is working as it should.

It is the public Microsoft newsgroup that i have seen these responses in. It could be related to the Partition Manager. I know that when i used Partition Magic 8 to create some partitions that Vista had a real issue with them. It wasnt until i moved all the data then deleted all the partitions and recreated them with GParted that Vista didnt have this issue anymore.
 

mqudsi

Mostly Harmless
Staff member
#30
I think he means it doesn't actually hibernate, the screen goes dark but the system does not go to sleep and is back to normal almost immediately.

I think I had that behavior with one of my Vista installs a while back.... didn't bother to fix it.
 

Terry60

Knows where his towel is.
Staff member
#31
Mak,
My whole dual-boot set up with Vista, XP and 3 other partitions was pre-formatted with an old Paragon bootable floppy (windows ME vintage), before I even inserted the Vista DVD. It didn't cause me any problems so I don't think Vista has any issues with it.
Back to the main subject - I never use hibernate so I wouldn't know if my system(s) have problems with it.
I got my fingers burned with it years ago on legacy OSs and worked around it by setting all the options in the power policy to quiesce my system when idle - and I've used the same technique ever since. I like the XP power policy better than Vista's power plan. I have the system set to turn off the screen and the HDDs after a couple of minutes and XP lets me click on the notification area icon to quickly set "always on" if I'm monitoring a long Windows Update e.g. from a different room, but Vista has annoyingly greyed out the ability to turn on the icon.

The reason I've commented here is because of Guru's remark about problems since 8/1/08.
I've noticed that in the last week or two, Vista keeps resetting my power option from "power saver" to "high performance".
This has not been happening in the previous months, so I assume that Window's Update has put out a recent fix which has screwed around with Power Options (and not in a good way).
It's very weird, because it doesn't need a boot - you can set a power plan, wait a few minutes, look again and Vista has changed it !
Have any of you noticed this ? I imagine that being techie geeks you're all set to "high perf" anyway so you wouldn't have realized that Vista is messing with you.
(I've changed all the "high" settings to replicate "saver" so that I still get what I want, but something has definitely gone seriously awry with Power Options recently)

When I'd first installed Vista, before I'd had a chance to customize anything, I did notice then that the Vanilla system would sleep but instantly reawaken unbidden. I read somewhere in a MS forum that this could be fixed by turning on "USB selective suspend" in the advanced options. Don't know if that's of any relevance here .
 
Last edited:
#32
Yes, but in order for me to create the second partition from the preinstalled single Vista partition, Paragon had to move some existing files that were overlapping with the new partition dimensions. I think that might be a different case.

The hibernation feature is such a pain. It is pretty much the most important feature of a notebook for me, but is so error prone.. can't be that hard, can it? :wink:

Clicking on hibernate returns me directly to the login screen after some dark display seconds and flickering.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#33
Actually Hibernation is the most troublesome feature that i have tried to trouble shoot. Since it is damn near impossible to just fix with a hotfix or a patch. Most of the time a restore point is needed or to repair the OS itself. Since Vista doesnt have the repair option the only other real option is a restore point.

So the hibernation is just a few seconds that goes right back to the login screen. Well if you leave that screen for long enough the screen saver kicks on and then it goes into low power standby. Kinda the same thing right? :tongueout:

Search The Knowledge Base

Maybe check out the Support threads from the Microsoft site and see if they have something to offer which is close to what you are experiencing? That is about all i can think of right now.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#34
#35
Yes, I have also tried on another laptop to fix hibernation in XP, which just couldn't remember that it was hibernated and merely restarted the system after powering on. This was directly after a clean reinstall.

Who knows what idiots were responsible for the hibernation feature..


I must be the only person with 2 notebooks that can't hibernate.. shame.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#36
That isnt true. My laptop can do hibernate also. After it comes out of hibernate i have to restart cause the laptop is so slow. To solve my issue. I just set it to low power standby and not hibernate.
 
#37
here somebody had the same issue with VIsta and Linux dualboot. Problem was here that the Vista Partition wasn't marked as ACTIVE. In Windows' disk management tool right click on the partition and mark as active.
http://forum.thinkpads.com/viewtopic.php?t=49155&highlight=hibernate
Solved it for him.

In my case, the partition is active and I didn't install another OS, but only created another partition.


Edit:
Is it correct that the disk manager shows this volume order? :
1) lenovo recovery partition
2) my second partiton ( D: ) (primary partition)
3) system partition ( C: ) (system partition, start partition, page file, active, primary partition)

What irritates me is that D: is listed above C: although it is located after the system partition (at least visually).
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#38
Yes that would be how it is on your hard drive.
 
#39
Hibernation revisited

Hello all.

I know it's been a while, but I said I wouldn't let this thing pass by; that I'd try to reproduce the problem so we could report it to M$. Well, the fact is, I can't reproduce the problem. :S

BUT...

Could someone with this problem verify if the BitLocker displays that strange error mentioned before (maybe in the second page of this thread), and then test this update (I think it will be a mandatory update sometime soon):
http://support.microsoft.com/kb/935509/

And see how it works out...

It would be so great if this solved it :smile:


Best regards everyone :wink:
footswitch
 

Domino

New Member
#40
The system is entering Away Mode.

i had hibernation problems for a long time since i installed linux in dual boot on my computer (i suspect windows scandisk for ****ing all up), but i finally found how to make my vista hibernate. However, my event log did not show any bitlocker/disk management problems, it was just saying "The system is entering Away Mode." So for me, the problem was not a system related problem, or a file corruption, vista just refused to enter in sleep mode, even though i had the same symptoms than you, the screen went black, and than 2-3 seconds after it went back to the locked thingy. Actually, the solution was only to, in the advanced power options of your power plan, change to "Allow the computer to sleep" in "Multimedia settings/When sharing media", enable "USB Selective suspend setting" (to prevent wake-ups), and deactivate "Allow hybrid sleep" in "Sleep". If this doesnt work, try to run "CMD" and type "powercfg -hibernate off" and then "powercfg -hibernate on". If all this doesnt work, suspect a hardware or bios related problem or a usb or application preventing vista to go in hibernate procedure, if this is the case, i wish you good luck to find the problem.

Hope this will helps,
Dom