"Vista Hide 'n Seek has stopped working"

#1
Just wondering if anyone else has had this problem:

When trying to launch Vista HnS (build 61) by double-clicking UI.exe, I immediately get the windows popup: "Vista Hide 'n Seek has stopped working" with the problem details as follows:

Description:
Stopped working
Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: ui.exe
Problem Signature 02: 0.5.0.61
Problem Signature 03: 48ada1f9
Problem Signature 04: mscorlib
Problem Signature 05: 2.0.0.0
Problem Signature 06: 49cc5797
Problem Signature 07: 349d
Problem Signature 08: 9a
Problem Signature 09: System.IO.IOException
OS Version: 6.0.6002.2.2.0.256.1
Locale ID: 1033

I have 3 different versions of Vista and one version of XP on separate partitions and can boot into any of them without problem using Vista bootloader (configured with EasyBCD). I have tried running Vista Hide 'n Seek after booting into all three Vista OS's and get the same result.

Tried googling this error, CLR20r3; seems to be some sort of exception error with the .Net framework as best I can tell. After looking through several of the google hits, seems like one would need some serious programming skills to trace down the problem.

Maybe this is something peculiar to the installed components I have on my Vista systems causing a conflict, as I have been able to successfully use Vista Hide 'n Seek on a different machine (machine with simpler setup with only one version each of Vista and XP).

Any thoughts would be appreciated.
 

JustinW

Super Moderator
Staff member
#2
Hey radical,

I wish I had an answer for you, just wanted to let you know we're looking over your post. If the developer can find the problem it'll be fixed. In the meantime you can try re-installing .net framework.
 
#3
kairozamorro,

Thanks very much for your reply.

Yes, this is a baffling problem.

In order to try and further investigate this, I went so far as to create a new partition and install a fresh copy of Vista. Thinking that I must have some sort of software conflict on my original Vista installations, I left this new Vista install "bare" with no updates, service packs, driver updates, or additional 3rd party software. Sure enough, I get the same error immediately after trying to launch Vista H'nS. (UAC turned off, even tried running the UI.exe as an administrator)

After this, I ran a small different application that uses the .net framework just to see if there is some sort of corruption of my .net framework that installs automatically with Vista, and this application ran fine with no error.

Also tried using one build earlier of Vista H'nS, just to make sure I didn't have a corrupted download.

I was debating trying to run Vista H'nS from XP, but after reading through the various threads on this forum, it seems like this isn't a very good idea in case I were to need to try and uninstall Vista H'nS (since I wouldn't be able to run the program in Vista). If needed, could I rebuild the Vista bootloader with the Vista install disc if things don't go well and I need to wipe Vista H'nS? Or would the vista drives remain hidden even with this approach?

I've been wracking my brain trying to think of what could be behind this since the error occurs even after a fresh vista install with no extraneous software or service packs, etc. Could it be a hardware issue (e.g. something BIOS related with hard drive settings - all my hard drives are SATA, no IDE hard drives) or some problem with Vista H'nS not being able to map the drives or access/modify NTLDR (? hidden operating system file, etc) located on my XP partition (the XP partition is the first partition on Disk 0 with the "system" files/bootsector - according the disk management console) and subsequently crashes upon opening. Maybe I'll try "unhiding" the system folders - BTW where is NTLDR located in XP?).

Could having multiple Vista installs be the problem (instead of say one XP/one Vista/one W7/one Linux installation like many of the other people here)?

Anyway, thanks a lot for your help.
 

JustinW

Super Moderator
Staff member
#4
Hello again,

Yes, HnS should be "installed" and "uninstalled" within a copy of Vista on your system, and not from XP. As for your fresh install you should always get the latest updates/service packs. Try that and see if its working. A lot of users have ran HnS without problems, thanks to Terry putting it to the test beta build after beta build.

If its not working in the fresh install either with nothing but updates applied, I believe than this problem might end up tracing back to the install media you used to install Windows itself or your hard drive/partition layout. Did you get the disc with your computer, buy it from the store, borrow a copy from a friend, or download a copy off the net?

Alternitively, if HnS isnt working you can also try Microsoft's workaround for XP's registry which should be performed to make "offline" all drives belonging to Vista or Windows 7 installations on your computer.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#5
What exactly do you mean by the statement in your penultimate paragraph ?
"the XP partition ........ subsequently crashes upon opening."
Are you saying there's a hard error on your "system" partition ? or that running the UI stops XP booting ?

btw. "Maybe I'll try "unhiding" the system folders - BTW where is NTLDR located in XP?)".
NTLDR is C:\NTLDR and the boot files will only be visible with folder options set thus.
 
#6
Thanks for your replies guys,

Kairozamorro, I think you're right and the problem must be something specific to my rig such as partition layout, etc., especially if no one else has had this problem (also, as I said, I have HnS working fine on another simpler rig). When I get back in town later this week, I'll try your suggestions with installing all vista updates without any additional software. My gut feeling is that I'll probably have to end up going the xp registry modification route if this doesn't work. Thanks for pointing this registry tweak out to me - (BTW - in terms of my system, the various Windows installations are from retail full versions (DVD/CD) of Windows purchased from reputable dealer - Newegg - installed on a rig I built; no pirated or "borrowed" software)

Terry, with regard to your first question, sorry I wasn't very clear with my rambling ideas as to possible causes. No, there's no hard error on my system partition. My various XP and Vista installations boot and run fine (no BSOD's, system errors, etc.) using the Vista Bootloader. I was referring to Vista H'nS "crashing" when I try to launch it from the UI.exe - I immediately get the "Vista Hide and Seek has stopped working" notification popup, and that's as far as I get. I obviously don't know the nuts and bolts of how Vista H'nS launches after clicking the UI.exe and which folders/files are accessed, etc. I was just grasping at straws trying to think of reasons - such as maybe Vista H'nS couldn't locate necessary folders/components on my particular system and can't proceed any further (I know this is a long shot and likely has no significance).

Also, thanks for the info on NTLDR location.