Vista & Kubuntu Dual Boot Issue

#1
Hi

I have Vista installed on my laptop's internal hard drive, and Kubuntu 8.04 installed on my external hard drive (which is always connected to laptop via USB).

The problem I have is that EasyBCD doesn't see any of the partitions on my external drive (in fact it doesn't see the external drive at all).

I go to Add/Remove Entry > Linux. Select GRUB. Fill in description. But in the drop down location/partition field, it only lists my laptop's internal hard drive.

When I installed Kubuntu, I followed the same guide I used to install Ubuntu on my main pc. My main pc has 2 internal drives, and so can boot into Ubuntu from Vista's Boot Manager.

During Kubuntu install, I told the installer to install GRUB to /dev/sdb2 (Kubuntu's root partition). I will try SuperGRUB to see if I can boot into Kubuntu using that.

I have read on this forum that the issue with removable drives will hopefully be sorted in EasyBCD 2. How long before EasyBCD 2 is released ? or is there a temporary way round this ?

Hard Drive Partition Layout is...

Internal: 80Gb NTFS Windows Vista
External: 300Gb NTFS Misc/Data Drive
External: 165Gb ext3 Kubuntu (root)
External: 3Gb swap Kubuntu (swap partition)
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
This is a known issue with EasyBCD not being able to recognize USB Devices. It is being addressed in the new version which is not out for testing yet. If you contact Computer Guru via PM and give him your email address and yoru agreement not to distribute the builds he might send you the latest copy to test.

But for now there is no fixes for this issue.
 

mqudsi

Mostly Harmless
Staff member
#3
Try using the "GRUB is not installed to the bootsector" option?

btw - welcome to NST, you should drop by our [thread=7]introduction thread[/thread] and introduce yourself!
 
#4
Hi Computer Guru. Thanks for the welcome.

I'll give that a shot.

Addendum:

Try using the "GRUB is not installed to the bootsector" option?
I have tried that option and on selecting the linux boot entry on reboot, I get dumped to the grub> prompt.

Addendum:

OK. I have also now tried the SuperGRUB cd, and that only sees my laptop's internal drive.

Looks like the USB drive can't be seen by the laptop at boot up. In BIOS, I have also tried the removable media boot option, but that the same as setting it to boot from cd/dvd drive.

What I need to do is create a /boot partition on my internal harddrive that allows me to boot into GRUB from Vista's Boot Manger, then after loading the USB modules, continue booting the rest of Kubuntu from the usb hard disc.

Any suggestions on how I go about this ?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#5
Resize your main partition, leaving around 50MB minimum free space.

Boot into the Ubuntu CD, and manually partition the drive. Create an ext3fs partition in those 50MB, set the mount point to "/boot"

Format the other partition (on the external drive) as ext3fs and mount point "/"

Install GRUB to the /dev/sda* that points to the /boot partition. Point EasyBCD to there and you should be good to go.
 
#6
OK. Thanks. Guess it's time to reinstall Kubuntu.

Will doing that, automatically load the usb modules so that Kubuntu loads after selecting it in GRUB's menu ?
 

mqudsi

Mostly Harmless
Staff member
#7
It should...

I've previously booted entirely off the USB drive (loading GRUB off of a USB device directly from the BIOS and using it to boot a copy of Ubuntu on the same USB drive) without any problems so I'd say it's a safe bet.

Good luck.
 
#8
I'll give it a go and report back asap.

If this works, at least I will be able to still boot into Vista regardless of whether the external hard drive is plugged in or not :smile:

Wish me luck :grinning:

Addendum:

Back again.

The installer can't format the 500Mb partition I have at the end of my laptop's internal drive. Keeps saying failed (tried ext2, ext3, and fat32 (fat32 not allowed for /boot says installer)).

Any ideas ? Can I use gparted to format the /boot partition to ext3 before I use the installer to install the system ? Or do I quit whilst I'm ahead lol
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#9
"Fat32 not allowed" sounds like your not selecting the right filesystem type...

That's the error I get when I try to set a FAT32 or NTFS partition as / or /boot.
 
#10
I've tried ext2 & ext3 as well, but get 'Ext2 File System Creation in Partion #2 of SCSI1(0,0,0) (sda) Failed' or 'Ext3 File System Creation in Partion #2 of SCSI1(0,0,0) (sda) Failed'.
 

mqudsi

Mostly Harmless
Staff member
#11
OK, guess you should give GParted a shot then.
 
#12
OK. Will do. Any ideas why I got that error ?

Addendum:

Yay! The GParted Live CD managed to format sba2 partition as ext3.

BTW, I used Vista's own disk manager. Wasn't going to let GParted screw up my Vista installation! lol

I also reformatted the sdb2 (root) and sdb3 (swap) partitions as ext3 and linux-swap respectively.

One thing I noticed is that sda1 is flagged as 'boot', which is correct as it's where Vista (and it's Boot Manager) live.

My question is this... what happens to this boot flag when i mount sda2 as /boot and install GRUB to sda2 (I assume it should stay flagged as boot), as sdb2 was also flagged 'boot' (installed GRUB there when I lasted tried to get things working, but without a separate /boot partition) ?

Addendum:

OK. Tried to install Kubuntu again and it failed.

Something along the lines of can't write to /boot partition.

I then exit the installer, load konsole and typed 'sudo fdisk -l' and it onlys lists my sdb (external) drive, yet before install it showed both drives.

Any ideas ?
 
Last edited:

JustinW

Super Moderator
Staff member
#13
I don't know so much about Kubuntu, but if it is anything like Ubuntu (it should be) then you should be able to see all your disks :frowning:

If you have a live image that allows you to use GParted from it before you install and you haven't already tried that, I'd do the partitioning before setup.

I noticed your Linux swap was on the external drive. Perhaps Kubuntu needs one on the same drive where the /boot partition is located as well in order for it to work.
 
#14
Apparently it's to do with the SATA controller that is used in Sony VAIO laptops.

Did a google search for 'ubuntu + sata + problems + sony + vaio' and found that i have to use 'modprobe ata-piix'.

BTW, when I boot live CD, I have to press F6 and type irqpoll then press ENTER to get live cd to boot.

Anyone heard of this ?

Addendum:

The error I get is 'The installer needs to remove operating system files from install target, but was unable to do so. The install cannot continue'.

That's when I set sda2 as /boot don't format (as formatted by GPartEd), then GRB install to /dev/sda2.

I exitted the installer, and typed 'fdisk -l' in terminal and again sda has disappeared, and typing 'dmesg' shows I/O error messages for sda.
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#15
The LiveCD sounds corrupted to me. Did you download it via torrent? Did you check the MD5 Sum to make sure it was a complete ISO before you burned it?

You can not set the drives as anything. They should read just / when you select the mount point. You will have the option to select where to install GRUB later. This is why the install keeps failing.
 
#16
I downloaded the cd via normal download (non-torrent), and it MD5 matched.

When I get to the partition stage, I set it as follows...

sda1 NTFS - leave alone (as it's Vista)
sda2 ext3 - set as /boot (don't format, as already empty ext3)

sdb1 NTFS - leave alone (as it's Vista's data drive)
sdb2 ext3 - set as / (don't format, as already empty ext3)
sdb3 linux-swap 0 set as swap area

Then I go through the other pages, till the one with the Advanced button on it. I click it and set GRUB to be installed to /dev/sda2, then I click install button.

Then after some time (5-10 minutes), I get the 'The installer needs to remove operating system files from install target, but was unable to do so. The install cannot continue' error message.

Addendum:

I'm happy to report that I now have Kubuntu installed, after 6 hours (11pm til 5am!!!)

What fix it was booting the live CD with this at the end of the boot line after --

all_generic_ide floppy=off irqpoll

Which worked and allowed me to format sda2 as /boot (ext3), sdb2 as / (ext3), and sdb3 as swap.

I don't think the floppy=off was needed, but left it in as my laptop has no floppy drive, but the motherboard does have a FDC (weird??).

All that's left to do now is use EasyBCD to add Kubuntu to Vista's Boot Manager, and then test to see if I can actually get into Kubuntu (I know to readd the extra boot parameters at the GRUB menu). Once in Kubuntu, I'll edit menu.lst to permanently add those extra boot parameters.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#17
Mak, in his case he needs to set the mount point so that he can have a separate /boot partition (it's explained in the earlier posts).

Dave, congratulations on getting it working... Guess Ubuntu has some weird SATA issues?
Perhaps we should file a bug if there isn't one already.
 
#18
It booted successfully to Kubuntu.

Also, no need for me to edit menu.lst to add the extra boot parameters, as they were automatically added when the system was installed.

All 76 updates installed fine, including the new kernel (2.6.24-18).

The SATA issue I think is already known about, tho not sure. How do I report it ?