vista not booting

#1
i had recently installed opensuse 11.0, but i accidentally installed opensuse installer from within vista, which resulted in my vista bootloader being modified and now in vista bootloader if i click on Microsoft Windows Vista, it takes me to opensuse installer. I tried booting Vista from the Reinstallation DVD but still it takes me to Vista bootloader. What can be the problem here?
The Reinstallation DVD came with my Dell Laptop (which is the computer in the above query) 32BIT SP1.
 
#2
Hello, achu. Welcome to NST.
Boot from your reinstallation dvd, select "Repair My Computer", select "Startup Repair", and then run it 3 times (it takes more than once because it can only fix one thing per pass). And then add an entry to your Vista BCD for OpenSuse using [thread=642]EasyBCD 2.0 beta[/thread] (which has more features than the 1.7 release).
 
#3
when i try to boot from the DVD a blank screen comes with a blinking cursor after which it takes me to GRUB bootloader from where when i click on windows it takes me to vista bootloader where the problem is. what do i do now?
 
#4
Go into your BIOS (by pressing F2 or similar key at startup), and put CD before HDD. Save the changes, and exit the BIOS.
You should now see a message "Press any key to boot from cd or dvd". So press a key, and the install/repair program will start up, and you can follow my earlier instructions.
 
#5
i went into the BIOS where CD/DVD was already above HD. then i tried to boot but the "press any key to boot from CD screen never comes" its just a black screen with a blinking cursor for the last 25 minutes, and i can here whirring sounds from my DVD drive.
 
#6
Faulty CD-rom drive probably. You may need to replace it.
 
#7
could it be a problem with the disc? coz i did install opensuse only yesterday from the same drive.

Addendum:

i discovered it to be a problem with the disc coz when i insert it when i have booted opensuse, it doesnt read it though it reads other discs. so its not a problem of the drive.
i have another disc (its the hindi interface version) of Vista. But when I insert that and try to boot from CD, it simply goes straight to GRUB bootloader. should i boot opensuse, insert this disc and then run LVSetup.exe in it?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#8
#9
problem aggravated

i committed a mistake yesterday.
http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD
following instructions from this link, i downloaded the iso file, burnt it onto a CD and then booted from it. then step 2 didnt work for me (automated repair). so as instructed i went into command prompt, and typed the first command-
bootrec.exe /fixmbr
and then when i tried this-
x:\boot\bootsect.exe /nt60 all /force

it said path not found. then i realized that bootsect.exe is not present on the disc. i downloaded it (from EasyBCD). Then I copied the files from the recovery disc, and together i made an image of it which i burnt onto another disc. but now when i tried to boot from it, it directly takes me to vista bootloader, instead of taking me to the install/repair menu. i think this is because of the first command that i typed in command prompt. is there anyway is it because of that, and if yes, is there anyway i can correct or undo that.
btw i have installed opensuse and i can access the windows partition through it (if it helps).
 
#10
Bootsect can be found in the /bin directory in the EasyBCD program files folder. Just use this command to navigate to the directory from the Command Prompt on the recovery disk:
Code:
cd /d C:\Program Files\NeoSmart Technologies\EasyBCD\bin
and then you can run all the bootsect commands mentioned in the wiki.

You will need to use the original recovery disk which you burned correctly.
 
#11
now i cant boot opensuse either. it simply wont go to GRUB even when I ask it to boot from HardDisk. what does that first command that i typed do? coz its after that i cant access GRUB now.