Vista not turning on! Please Help!!!!!!!!!

#41
I've been using the sfc enough times after a few burns of GParted to disk with the free version of a cd/dvd burning program that works with iso disk images and suddenly seeing the program halt after 3 or 4 good burns. Once the sfc command ran the tool the problem would burn again for another 3 or 4 times in XP. I can recommend a better freeware for this however at another time.

As for typing out the command itself kairozamorro is simply pointing out the need to see "sfc space /scannow" leaving one character space between the sfc and /scannow. In Vista I haven't had any use for it to start with while XP prior to SP3 was plenty of fun at times! YSBird pointed that out in post #29 earlier.

The links there were a start before any need to see a full system restoration performed for the preinstalled copy of VIsta there. You may end deciding that will be the end result if something corrupted the present copy of Windows. At least that will see a fresh copy of Windows and all drivers.
 
#42
Like I said before, I found what I needed to put in for the sfc. It was sfc /scannow /offbootdir=c:\ /offwindir=c:\windows. sfc /scannow on its own didn't work. However, when I put it in, after a message that said "Beginning system scan. This process will take some time", an error appeared that said "There is a system repair pending which requires reboot to complete. Restart Windows and run sfc again. The problem is that I have rebooted windows and it still doesn't work.

When I tried to run chkdsk (I ran it using the line c:\windows\system32\chkdsk.exe /f
an error came up saying " The type of file system is NTFS. Cannot lock current drive. Windows cannot run disk checking on this volume because it is write protected."

Any ideas?

Addendum:

Clarification:

I think I have to specify offline because I don't select a windows installation where it asks me to. This is because when I select my installation and push next, it automatically goes to the startup repair, which doesn't work.
 
Last edited:

JustinW

Super Moderator
Staff member
#43
You haft to specify regardless, unless you are within Windows in which case the default refers to that install. You also can't use chkdsk on a partition from within the OS that is housed there. Do you see any files/folders from the command prompt if you do "dir c:\"? If you get an error on that a re-install/new hard drive is likely the solution here.
 
#44
If you are not able to run the check disk utility with the switch from a command line like "chkdsk /r" you can schedule it to run once the system is restarted seeing that done on the restart of Windows. The gui method is simply right clicking on the drive listing in any explorer windows and selecting properties at the bottom of that menu. From there you go to the tools tab and click the check now button in the error checking area.

If you see the Windows cannot check disk while in use popup you then schedule the hard drive to checked on the next startup by then pressing the schedule disk checking button. The Windows tool and downloading the drive diagnostics from the manufacturer are the two usual means of finding out if the drive is planning to go doa on you at some point soon.
 
#45
I can't get to windows explorer as windows won't boot.

Since the windows boot files seem to have been messed up, are there any backup files I can use to replace them with?
 

JustinW

Super Moderator
Staff member
#46
Can you see the content of the root of your Vista partition using dir like mentioned in my last post? If not, that hard drive needs to be replaced. You could try deleting c:\boot\bcd and than doing startup repair on Vista. Look at step four for manually re-building the BCD store in our wiki.
 
#47
Sorry, I forgot to try that earlier. Yes, dir C:\ does display my folders. Before it does, however, it gives the drive's serial number and says "Volume in Drive C has no label". I don't know if that's bad or not.

I'm going to try step 3 in the article you referred me to. Hopefully, it works.

Addendum:

I can't get step 3 to work. I don't know the drive letter, but I guessed all the letters through H and none worked. It said the exe is not recognized as a valid command or something. I'm now going to try step 4.

Addendum:

I just realized that the second part of steps 3 and 4 are the same. Also, I realized that my description of the error was probably unhelpful. The error either said "The device is not ready" (which I think was probably when the letter I guessed was that of a USB Port) or " '[drive letter]:\boot\bootsect.exe' is not recognized as an internal or external command, operable program, or batch file"

I don't know if I typed something in wrong, if Nero burned the CD incorrectly, or what. Any ideas?
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#49
We recommend ImgBurn to burn the ISO. Nero isnt the best to use.

Burning ISO Images with ImgBurn - NeoSmart Technologies Wiki

Other than that these steps listed in our Wiki are the only known steps we have come across to fix the boot short of a full re-install. If they dont work there is nothing more we can do to assist you. Sorry.
 

JustinW

Super Moderator
Staff member
#50
In XP simply go to the Run command line right off of the Start menu and type "sfc /scannow" with the XP disk in the drive to see the tool start up.
Apparently sfc is available in XP now without the need for the disc straight from the command prompt like Vista except that it is slightly different. You can't scan offline directories so instead you must set it up to scan when you reboot. You can even set it up to scan each time you start the computer (a feature i'm not sure that Vista's version has):