Vista on Acer Laptop Does Not Boot

#1
Good morning all,

It looks like I'm not alone with Vista laptops not supplying recovery disk as on my Acer laptop.

Because mine came with on half gig of memory (criminal I know when running Vista) I explored other options prior to considering purchasing more memory.

First, someone gave me a Fedora 7 disk which I installed as a dual boot. This worked fine until I got the bright idea for speedy Linux OS and found Puppy Linux. I did not install to the HD or any partition, I simply booted from a CD first then a flash drive. Everything worked fine at this point!

The problems started when I re-partitioned the HD adding a partition to make room for any files I might need space for when I run Puppy. To do this I shrank the Fedora partition.

This was my fatal mistake. I shrunk the Fedora partition too small and lost my Grub splash screen apparently damaging the MBR. I was able to fix this in Puppy, or so I thought.

To make a long story shorter, when I select windows from my Grub screen it just sits there after the "Chainloader +1" line.

I tried the System Restore in the WIKI, but it returned could be found. This sounds like a lesson learned for Vista users, create your system restore points.

I tried running the "Automated Repair" (step 2 in the WIKI)from the "Windows Vista Recovery Disk Download" software and it failed, saying it fixed the problem but it hadn't.

That would take me to step 3, but without a disk I don't know where to retrieve the bootsect.exe executable. Does this mean I have to go to step 4? Is this a correct thought?

Finally, I purchased recovery software a while back called Undelete Pro, version 5.5. This can recover partitions, folder, and files. I used this to recover my Windows folder, bootmgr, etc. and have them stored away safely. I haven't gotten around to comparing them with what is currently in the Windows folder.

PS: I can still boot into Puppy Linux off either CD or flashdrive
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi sfink, welcome to NST.
First thing. How many times did you boot and run the "startup repair" from the recovery disk ?
It takes 2 or 3 passes before it fixes everything in a Vista boot, and yours will have been well and truly broken by letting grub take over the MBR.
Download a copy of EasyBCD 2.0 Beta, and if the multi-pass "repair" works you can use it to set up your Linux multi-boot using the Vista BCD (with Easy) as the controlling boot manager.
If the auto-repair doesn't work for you, You'll find a copy of bootsect.exe in the EasyBCD bin folder, which you can use in the following manual repair steps.
 
Last edited:
#3
Thanks Terry!

I ran the recovery disk once and when it came up a second time I thought it was just repeating and would not find anything else, so I stopped it. Now I know otherwise. So replacing my bootmgr with the older one found using my other recovery tool (Undelete Pro) wouldn't work?

Etiher way, I attempt the EasyBCD tonight when I have time to do so. Thanks again!

Steve
 
#4
As a quick followup, I finished the first three steps unsuccessfully and am now down to the 4th step. I ran out of time last night and try tonight.

Addendum:

It looks like I've hit a dead end as I ran through the entire process (EasyBCD) without errors. However, a reboot into the Windows Vista left me a blank screen with a blinking cursor in the upper. Any suggtesions?
 
Last edited:

JustinW

Super Moderator
Staff member
#5
Well, I don't suppose its too late to rescue your files using xcopy, a linux live disc, or backup program.
 
#6
Sorry Justin, but I didn't see your reply. As for the files and data, I have nothing on the laptop tht I care about, all images have been transferred to my external backup drive.

I did use a Knoppix live disk, an Ubuntu live disk, and a Puppy Live disk and didn't get any closer to resolving the issues with them. I was told that fdsik /mbr might work but it didn't.

I even tried some otherr commands on the Recovery disk discussed on this forum such as chkdsk /f and that didn't fix anything either.

I can even get into regedit, which may be key, no pun intended.

Finally, I have contacted Acer via email to see if I can get a recovery disk from them. That was on Friday. I hope that they respond sometime this week.
 
Last edited: