Vista + OS X

#1
I want to add OS X to an existing Vista installation on my laptop. I tried that about a year ago but got tired of manually changing partition status to active, because OS X required an active partition in order to boot, and Vista was my primary installation. Eventually my BCD file was damaged, I ended up reformatting and said to hell with OS X.

Have these things gotten any easier with the new versions of EasyBCD and Neogrub? Do I need anything else besides EasyBCD and Neogrub to make it happen?

Also, I love the idea of iReboot, but it only works from Windows, right? What if you want to reboot from OS X into Vista?
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Mac OS X - NeoSmart Technologies Wiki

That will help you get OS X added to the BCD. It has gotten a bit easier yes but nothing is totally flawless with PC's.

iReboot is Widnos only. If you wanted to go from OS X to Windows you would haev to go thru the OS X shut down process and reboot your machine. iReboot is not compatible with OS X or Linux.
 
#3
Thanks! A couple of questions.

1) The steps described don't mention Neogrub at all. So I don't need it? Will the Vista bootloader do all the work?

2) Will my partitions be changed to "active" every time I switch between OS's? Or will this method leave the Mac partition active permanently and boot into Vista some other way?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
From what i read the Vista Boot Loader (BCD) will do it all now. No need for NeoGRUB.

Also from what i read it leaves both partitions active so that you can easily boot between them. Guru will have a more definate answer but from what i see you should have no problems at all just adding OS X to the BCD and just choosing one at the Selection Screen and being on your way.
 

mqudsi

Mostly Harmless
Staff member
#6
NeoGrub has a workaround that we use when the normal way fails.

The normal way leaves the *Vista* partition as active at all times.
 
#7
That's exactly what I was wondering about. So I do need NeoGrub after all? Do I still follow the installation instructions above?
 

mqudsi

Mostly Harmless
Staff member
#8
Here's how it goes: you try the instructions above, and see if they work for you.
If they don't, we'll walk you through the process of using NeoGrub to get OS X to boot on your PC :smile:
 
#9
I have installed both operating systems but can only boot into Vista right now. I only have one hard disk, and the partitions are as follows:

0 fat32 Dell Diagnostics
1 ntfs Vista
2 hfs+ OS X

After installing OS X, I was getting the b0 error, even though partition 2 was set as active (I checked by booting from an Acronis CD-ROM). I tried changing the active partition from 2 to 1 and back, but neither Vista nor OS X would boot anymore.

I used the Vista DVD to fix my MBR, and Vista boots fine now when partition 1 is active. Selecting the OS X entry (made with EasyBCD) from the Vista bootloader results in a HFS+ Partition error. Booting with an active partition 2 also results in the HFS+ partition error. I can probably get into OS X by using the OS X DVD, but that's not what I want.

Any ideas?
 

mqudsi

Mostly Harmless
Staff member
#10
This means that the installation media you used has a problem, and did not install hte bootloader correctly.

EasyBCD will function if OS X can/will boot if there is no HFS+ partition error, or with NeoGrub if by changing the active partition you can get OS X to boot.
 
#11
No luck, with or without NeoGrub. I reformatted the HFS partition and installed Ubuntu on it. Still, I'm unable to boot into any OS other than Vista. Running commands from Grub gives me "unrecognized partition table for drive 80." So I guess it wasn't a Darwin/Mac problem. I re-installed the Vista bootloader too, same result.
 
Last edited:
#13
Those instructions don't work with me. I have re-installed Ubuntu twice and still cannot boot into it. It refuses to install Grub to the partition, the error is "Executing grub-install (hd0,3) failed. This is a fatal error." The same thing was happening with darwin, and I can't figure out what's wrong.

Edit: It looks like the small Dell recovery partition is the reason darwin and grub can't install succesfully on partition 3. The only solution I have found is to Dban the hard drive, which isn't an option for me. I guess I'm stuck with Vista for now.
 
Last edited: