Vista problems and rec cd problems, with a twist

F21916621

New Member
I too am one of those, who apparently are pc illiterate. I have an hp pavilion, desk top, running vista 32 bit. It hangs st the MS loading screen, safe mode does not load (hangs at crcdick.sys). So I DL'd the iso for the vista rec cd, burnt the image untouched to a cd. After hitting any key to boot from cd drive, windows loads files and then cuts back to Microsoft loading screen. Shorty after it becomes black screen of death. The keyboard I beleive is also locked out (num lock shuts off). On a side note Linux loads through same bios without a hitch
 

F21916621

New Member
Hey would just like to thank you for your time, but before I do what you suggested I would just like to know what It will do, because Again I plan on staying on vista. Do you know why my vista recovery cd won't boot though?
 

Terry60

Knows where his towel is.
Staff member
It's an unfortunate design flaw of the MS repair disk that it checks the HDD during boot. That means a HDD problem which prevents the OS from booting can affect the repair disk in the same way.
Linux bootable distros don't care about the state of a Windows HDD, so they'll boot up regardless.
The Linux fsck, is the equivalent of Windows chkdsk, which we'd advise you to run if you could get the Vista CD as far as a command prompt.
 

dsa44

New Member
Check your hard drive

I am no expert here, but had this exact problem on my laptop, Vista would not load. After much angst, I discovered it was a hard drive error.
Do you know who made your hard drive? Get their utility to create a boot disk and run the manufacturer's diagnostics on the drive.
In my case, windows chkdsk and scandisk both showed no errors, however the Western Digital lifeguard showed many non-recoverable errors and I was forced to replace the drive and clean install. Part of the Vista boot files must have been on bad sectors.
See my woes at Vista won't boot anymore in a dual boot with XP - The NeoSmart Forums

Hope this helps....good luck, I am still bringing my system back to life.
 

F21916621

New Member
Well I hate to accept defeat, however after reading the help etc, I'm still not exactly sure how to fsck my hdd. Let's say the harddrive in question is call hp,
What would the code look like for the terminal entry?
 

JustinW

Super Moderator
Staff member
First off, are you able to mount the partition and get access to your files? You'll need to resuce your files just in case things don't work out.

In a single hard drive, single partition system it would be:
sudo fsck /dev/sda1

Where sda is disk 1 and the 1 represents first partition. You can see the various options for fsck with man fsck.

If the partition has been mounted you can find out the right identifier simply by typing mount, or by running fdisk -l.
 

Terry60

Knows where his towel is.
Staff member
Ubuntu contains a GUI in the system link which will do this.
Just click on the drive in question and click on the check button.
Can't remember what it's called, but I found it in seconds when trying to diagnose a mysterious disk failure on my Vista partition while it wasn't even in use !
 

JustinW

Super Moderator
Staff member
Probably an option in the Disk Utility. Don't know if gparted provides that option.
 

Terry60

Knows where his towel is.
Staff member
You're right.
(It's not gparted)
 

F21916621

New Member
So when I "sudo fsck /dev/sda1", output =

fsck 1.41.4 (27-Jan-2009)
fsck: fsck.ntfs: not found
fsck: Error 2 while executing fsck.ntfs for /dev/sda1

It also comes back in like a ms.
Could it be that /dev/sda1 is not what I need to write? I ended up finding mount point, UUID etc by mounting the drive, and looking at properties under volume. My mount point was /media/HP. That resulted in "the superblock could not be read or does not describe a correct ext2 filesystem" etc.

What do u guys think?
 

Terry60

Knows where his towel is.
Staff member
Have you tried the GUI ?
 

F21916621

New Member
Sorry Terry, I'm not quite sure what you mean by checking GUI, I'm very new to Linux, and the explanations on te Internet are somewhat technical
 

Terry60

Knows where his towel is.
Staff member
Boot Ubuntu, select system, then disk utility (or somesuch), then pick the drive you want checked.
(GUI = graphical user interface. e.g. EasyBCD is a GUI for MS command line utility BCDedit, a user-friendly way of issuing complex commands with a point and click interface)
 
Last edited:

F21916621

New Member
Sorry this doesn't seem to be a quick fix, but I suppose otherwise I wouldn't be here lol. So after confirming my device name (through system, admin, system monitor) I still only get this as an output:

Sudo fsck /dev/sda1
fsck 1.41.4 (27-Jan-2009)
fsck: fsck.ntfs: not found
fsck: Error 2 while executing fsck.ntfs for /dev/sda1

So what can I do now?
 

JustinW

Super Moderator
Staff member
Disk Utility is located at System > Administration > Disk Utility I believe on the latest livecd. The problem is fsck is just the general tool. All it does is see what type of filesystem it is and determines the correct fsck utility to run. Your system appears to be missing the ntfs fsck. Which version of Ubuntu is this and is it from the live cd? You can go to System > Administration > Synaptic Package Manager and search for anything with fsck in its name to make sure you have the latest installed. You should also be using the latest livecd, which is 10.04.
 

F21916621

New Member
Progress!!. Thank you Kairozamorro (and Terry). No wonder things didn't match up with what you guys were saying, I was running on a v.9 of Ubuntu.

Now that I'm up and running on 10.04 Ubuntu livecd, I have been able to find a lot of stuff out and find what I think to be useful info:

-disk utility "check filesystem" came back clean
-SMART data, green but disk has a few bad sectors (I'm assuming with boot files on it)
more detail: *RED Id # 197, current pending sector count. Assesment : Warning.
Normalized:200, Worst 200, Threshold 0, Value: 3 sectors
also, upon SMART self-test, fail in ms's due to (read)

-After updates, still can't run FSCK

additional remarks: I noticed in my BIOS, that I have a RAID-0 HDD, coupled with 3 bad sectors, does this mean my 1.5 year HD is almost dead/hardwear problem, or is it still salvageable?
 

JustinW

Super Moderator
Staff member
If fsck won't run and you have your data and Windows disc ready you can see if the drive is still salvageable by going into disk utility/gparted and deleting all the partitions on the drive. Boot from your Windows disc (not our recovery disc), which should be working now, to re-install.
 

F21916621

New Member
SOLVED!! I didn't need to delete all partitions, I left my recovery partition in case it would still work, and it did :grinning:. So thanks to everyone who helped me.
Cheers
 
Top