Vista quandary


Distinguished Member
I'm sorry to post another Vista problem, but mine is a bit different from those I've seen here.

I'm trying to get a Dell Vista box to boot. The boot error is "C:\windows\system32\winload.exe not found."

I've run Dell's utilities, and everything passed without problem.

So I've been following the instructions on the wiki for recovering the bootloader from the Vista RE, which I'm working from a USB drive ("X").

All the bootrec commands perform fine. Fixmbr and fixboot are fine. Scanos works, but finds no Vista installation.

So I turn to bootsect.exe, but it is not found. I've tried it in the X drive and the C drive.

So I'm stuck. I don’t know where to turn next. I would do a repair installation, but I don’t have the installation disk.

Don't use letters to identify your drives or you will get in trouble. Letters can and do change since they are assigned on every boot by the booting OS and are not intrinsic to the partitions.

How did this all start?

Do you have a recovery partition on that hard drive, or has it been destroyed? There may be 2 extra partitions making up the recovery, and that may be part of your location problem. C: would be assigned to the first partition seen by the OS and that would not necessarily be the same C: as your Windows is on.

Using bootrec will also most likely destroy your abilty to access recovery. The hidden partition is the reason you have no DVD - it is the substitute for it. So don't make any changes whatever to the partitions if you want to still be able to use recovery.

Have you saved all the files you need so that you can go back to factory settings?
Last edited:
The C drive, as seen by the RE, is the primary Windows partition. But I don't know what's on the disk beyond that, as this machine was given to me as-is. I know the Dell utilities are on there, of course.

I've already used bootrec, so I'm past the point of no return.

I just hit F12, and no recovery options appear.

My guess is that I need to access bootsect.exe, but I don’t know where it is. Is it on the system partition? Because I don’t know how to address that. It probably doesn’t have a drive letter.

In RE, I tried system restore and restore from backup, but no points or backups have been made. So unless I can fire up bootsect, I don’t know how to proceed, except to find a Vista (Business edition) installation disk somewhere.
Even if you found a disk, you would need to buy a new license. Installations licensed to Dell won't use the same product keys as retail versions.

Can you see the parttions on that drive? I'd suggest that for this and later problems, since it is a very useful tool, that you make a bootable CD or USB stick of Parted Mgic and then take a look at the drive with its partition editor (on the desktop after booting it up). That would tell you what is there to work with. The CD also has an option to use the PLoP boot loader which can boot partitions directly without using the MBR. You may even be abe to boot the recovery partition from it.

Parted Magic | Download Parted Magic software for free at

Bootsec.exe is in the system32 directory on both the hard drive and the recovery CD.
Thanks, that's a good point about the licensing, one that I hadn't thought of. There's currently no optical drive here, but I think I can boot to a partition editor via usb. I'll see what I can find.


I took the drive out and tethered it to my Win7 laptop, and used Easy's Deployment feature. Great job, team, on making Easy's verbals more clear than before. I installed a new BCD, and verified that, counter to the error message I was getting, winload.exe was present in system32.

But when I tried it, there was an unspecified error reading the BCD. And for some reason, I'm getting "Disk Error" whenever I try to boot to the USB stick. Makes me wonder if there's a MB problem.

The other alternative, which I've just pursued, is to request a restore disk from Dell. It would wipe the system clean, but at least I would have a system, if the MB is not toast.


I have no idea how I did it, but I'm in. I thought the Disk Error on the Win RE USB stick was the machine's fault, but it did the same thing on another machine, so I rewrote the stick. Once I did that, I simply ran through automatic boot repair one time, and I was in!

Miraculous, indeed!

Now, to back that drive up!! :smile:

Last edited: