Vista sometimes doesn't boot?

#1
Not sure exactly what the problem is but occasionly when I turn on my laptop, no display or anything shows up on the screen and the "hard disk is being used" flashy green LED light doesn't blink at all, I can't seem to understand whats going wrong here? The blackscreen occurs before the vista loading bars appear so its very strange

To fix this problem, I have to hold the power button and then let the laptop turn off and then turn it on again and this time the display will come, strange heh?

This also happens when I restart my laptop, not always but sometimes, its really random, any ideas on whats wrong?

Thanks
 
Last edited:

JustinW

Super Moderator
Staff member
#2
When it happened to me I had the computer go into sleep mode when I close the lid, so when I brought it back up it ended up fixing itself without me having to do a cold boot again. If its happening frequently you may be having problems with the RPC service running under the wrong account. My thread [thread=2631]here[/thread] addresses this.
 

JustinW

Super Moderator
Staff member
#4
You should be able to use our disc or a vista disc if you got one, since you only need access to the command prompt and regedit in the recovery options.
 
#6
Sorry about the bump, basically this isn't the issue, what i mean is when i turn on my laptop, theres no display at all, the vista green bars don't appear, the curser doesn't and the "acer bios options" screen doesn't appear, sometimes it does, othertimes it doesn't, is there a solution???
 

JustinW

Super Moderator
Staff member
#7
If you don't see the "splash screen" when you turn your computer on for Acer you may need to reflash the BIOS or replace the lcd panel, which is far too expensive and time consuming to do from what I've heard that you might as well get a new system if thats the case.
 
#8
If you don't see the "splash screen" when you turn your computer on for Acer you may need to reflash the BIOS or replace the lcd panel, which is far too expensive and time consuming to do from what I've heard that you might as well get a new system if thats the case.
But the thing is, sometimes it does turn on, and sometimes it doesn't, If no screen appears, I usually hold the power button, switch off, and then switch it on again, usually after 2-3 times, the screen appears again, could it be a loose component inside my laptop or anything
 

Terry60

Knows where his towel is.
Staff member
#10
Sounds like you could have bad connections. Try unplugging/reseating everthing accessible.
 

mqudsi

Mostly Harmless
Staff member
#12
Check the power and HD cables.