Vista will not boot

#1
I misguidedly tried to resize the C and D partitions to free up some space.

Following that, VIsta would not boot. I downloaded the Startup repair disc as I do not have a windows instal disc (having inherited the laptop).

System reapir initially couldnt see vista. It asked for drivers which I did not have. I ran the repair anyway. That led to "startup repair cuold not automatically repair". Vista would not boot. I ran the startup repair disc again. This time it can see "microsoft windows vista" in hte list of OS (it is the only one). Trying to run startup repair again seems to work in that it finishes saying "if you have instaled a device, reomve it"; also the report log shows the "root cause" as being that "the OS booted succesfully". However, on removing the repair disc and rebooting, nothign happens - left with a flashing curfsor in the top left corner.

Have tried running the startup reapir several more times, but to same effect.

I am sure that Vista is there and waiting to be woken up from a boot, but there must be a problem with bootmgr or something. I have trawled many sites and forums but cannot find an answer. I am sure someone there knows how to fix this!

All comments welcome

Addendum:


Recovering the Vista Bootloader from the DVD - NeoSmart Technologies Wiki

OK - I found these instructions on how to rebuild the Vista Bootloader. Even after completing step 4 "Nuclear Holocaust" Vista will still not boot, though all elements of stage 4 seem to have worked fine. What on earth is wrong?
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#2
If the partitions were originally set up by Vista, using the latest alignment standards, and you've redefined the bounds with a non-Vista compatible partition manager, you'll have made the system unbootable.
Look here for more detail, following the "quirks" and "cloning" links
 

Terry60

Knows where his towel is.
Staff member
#3
Did you see my previous post ?
Something strange has occurred to the thread, in that I appear to have replied before you asked the question. (it's merged your OP with your latest, instead of creating a post #3 !?)
 
#4
Terry

Thanks for that - I did inded use Partition Manager. To be honest, the technical content of the articles you point to is rather beyond me as a mere lawyer - the real question - from a "client perspective" is - is it something that can (a) be fixed without losing all my files (and if so, how); or (b) if not, can it be fixed by re-installing vista (which involves obtaining an install disc from somewhere) or (c) if not, and I just get a new machine, will it be possible to transfer the data from the broken laptop to the new machine?

I appreciate your comments and am kicking myself for trying to use PM to save having to get a new machine with more space!
 

JustinW

Super Moderator
Staff member
#5
Something strange has occurred to the thread, in that I appear to have replied before you asked the question. (it's merged your OP with your latest, instead of creating a post #3 !?)
Terry, an unfortunate feature of vB is if you merge posts into a thread it puts them in order according to thier timestamps (when they were posted). I'll go ahead and put these posts back in his old thread so his post appears at the top.

Addendum:

As for the partition problem which partition manager did you use? Vista's own disk management should be able to resize partitions for you. Perhaps re-sizing again with Partition Wizard well fix the offset so it'll boot? It appears to be Vista/W7 friendly.

Addendum:

Moved to Windows Support being a Windows related issue.
 
Last edited:
#6
Kairomazorro

The program I used was Partition Manager which I see from Terry's links was a bad idea. I will have a go with Partition Wizard. Presumably the first thing to do would be to try to rebuild the MBR and then see what happens before trying to fiddle with the trelative sizes of the partitions?
 
#8
Hmm.
I ran partition Wizard and removed the overlapping duplicated partitions it could see. Then re-sized teh remaininng partitions. That didnt do the job. So I ran Startup Repair a few times. Initially, on trying to boot outside of system repair, the machine said there was no OS. After another go with Startup Repair, SR can see Vista but attmpts to repair it do not work "SR Cannot repair this computer automatically". The error log from SR says

Repair action: File repair
Result: Failed. Error Code -0x2

repair action:Boot configuration data store repair
Result: failed. Error code = 0x490

And when I try (optimistically) to boot the machine, it comes up with an error saying it cannot boot because winload.exe is missing or corrupt. Winload.exe is there in c:\windows\system32 where, presumably, it ought to be - all the other system files are there too.

Any other thoughts? I am grateful for anything at this point!
 

JustinW

Super Moderator
Staff member
#9
Run chkdsk from the command prompt:

chkdsk c: /r

Followed by a check of the system's files:

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows

Now run startup repair again and see if you can boot.
 
#10
Thanks - am trying that now. Chkdsk is causing a whole lot of action :smile:

Addendum:

chkdsk finished after about an hour.
scannow started but stopped almost immediately saying "Windows resources protection could not perform the requested operation". I am guessing that is bad?!

Addendum:

And when I try booting the machine after running startup repair the same error message re winload.exe pops up. arghhh!
 
Last edited:

JustinW

Super Moderator
Staff member
#11
Did chkdsk report any problems? Run it until it finds nothing to fix. You'll need to verify the drive letter where Windows is stored, than replace c: in my examples with the right paths.
 
#12
Hi
Chkdsk found plenty of things to fix, but it seems to find the same or at least a similar number of things to fix or repair no matter how often I run it. It reports that it canot write its activity to the system log - error code 50. That happens over and over again. sfc will not run, even using the /VERIFYONLY switch.

I am beginning to think that this is a seriously unhappy machine!
 

mqudsi

Mostly Harmless
Staff member
#13
This could indicate a bad disk.

Are you running it with the /r flag?
 
#14
HI

Yes - I was running chkdsk wtih the /r flag. I think that is why it took so long to run. I tried to xcopy the contents of the c:\users directories to an external harddrive in a belated attempt to backup some data before makign things any worse and there were some very strange file names coming up, of the form C:\users\<username>\appdata\data\appdata\data\appdata\data etc etc for several lines. This even after running chkdks. THis also does nothing to fill me with confidence.

The error report on trying to run teh Windows Restore system repair disc is now to the effect of "cannot load OS" even though the relevant edition of Vista is detected by the program. This is despite having run both bootsect (mentioned above) and used bcdedit to rebuild the bootloader a few days ago to try and restore (apparently successfully) the boot sector.

Not feeling encouraged :frowning:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#15
I'd say the drive is cooked.
 
#16
Thanks - you are/were right.
Still, the drive is now re-formatted and a lovely new copy of Windows 7 Professional is running happily on it wiht the machine buzzing along much more happily than it was under Vista. Small mercies.
Thanks for all the help and suggestions though - much appreciated