Vista won't boot after bootloader restore

lucaspewkas

New Member
OK, I've searched everywhere I promise, but to no avail...

I have installed XP onto a hard drive which had Vista on it already (on a different partition obviously).
Then I booted into XP (which it did automatically).
Then I ran EasyBCD and reinstalled the Vista Bootloader (I also added the XP option to it).
Now when I choose to boot from Vista, the computer reboots straight away and goes back to the bootloader. When I choose XP, it runs XP fine.

I've even tried restoring the bootloader using good ol'
Code:
Bootsect.exe –NT60 All
but same problem (this time with no XP option, the computer just repeatedly reboots until I fixmbr/fixboot it in XP recovery)

Any ideas...?

It's 2am, I should go to bed...

-Luke
 

mqudsi

Mostly Harmless
Staff member
Hi Luke, welcome to NeoSmart Technologies.

Sounds like the Vista bootloader is installed and running at boot, but has an improperly configured Vista entry.

Can you please do EasyBCD | Diagnostics | Copy Debug Data and post it here (as-is) in a reply?

Thanks.
 

lucaspewkas

New Member
Yeah that sounds likely. I've pasted the debug data below, the device: unknown entry for vista is a little worrying I think? When I click 'View Settings', it lists 'drive: deleted partition', also worrying...

Thanks for your help
-Luke

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  unknown
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {f784a0e4-839b-11dc-876c-d2c2bf148418}
resumeobject            {269549de-8305-11dc-8bbf-806e6f6e6963}
displayorder            {f784a0e4-839b-11dc-876c-d2c2bf148418}
                        {f784a0e5-839b-11dc-876c-d2c2bf148418}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 30
Windows Boot Loader
-------------------
identifier              {f784a0e4-839b-11dc-876c-d2c2bf148418}
device                  unknown
path                    \Windows\system32\winload.exe
description             Windows Vista (TM) Home Basic
recoverysequence        {572bcd55-ffa7-11d9-aae0-0007e994107d}
recoveryenabled         Yes
osdevice                unknown
systemroot              \Windows
resumeobject            {269549de-8305-11dc-8bbf-806e6f6e6963}
Real-mode Boot Sector
---------------------
identifier              {f784a0e5-839b-11dc-876c-d2c2bf148418}
device                  partition=D:
path                    \NTLDR
description             Microsoft Windows

Addendum:

Ooh just thought I'd add:
Vista is installed on C:
XP on D:
(both same hard drive, diff partitions)

When I start EasyBCD, I've been saying boot drive is C: since it asks me (although I've tried saying D: too, but it's no different)

Thanks
-Luke
 
Last edited:

mqudsi

Mostly Harmless
Staff member
As you can probably see for yourself, the BCD data is damaged and says "device unknown" for the Vista entry.

You need to do EasyBCD | Diagnostics | Reset BCD Data
 

lucaspewkas

New Member
Yep, I did reset BCD storage and it said "operation completed successfully"
Vista was then listed as C:\ so I rebooted, and it did the same thing, would reboot every time I chose Vista, and XP was understandably peeved and wouldn't boot into that either, so had to fixmbr/fixboot again and as soon as I ran easybcd from XP again, vista was on a "deleted partition" again.

Hmmm...

-Luke

Addendum:

Woot!
I think the Restore of BCD Storage was the key. After that I changed the vista settings to C:\ (It was on D:\ even though I'd previously changed it to C:\) and reinstalled the vista bootloader and walla!

Hope this helps some people, let me know if I should post anything else to help out
 
Last edited:

mqudsi

Mostly Harmless
Staff member
I don't know why it would be on D:, unless in the Reset BCD Storage procedure when it asked you what drive Vista is on you told it D: instead of C:

Anyway, glad it's working.
 

lucaspewkas

New Member
Yeah it was on C:\ before reboot, then afterwards, it listed "drive: deleted partition" and was back on D:\ under "change settings". It's quite possible I may have manually changed it under "change settings" to D:\ for some unexplainable reason and it was trying to boot from there every time...

Ah well, I guess it was 90% user error once again :smile:

Thanks for all the help, much appreciated!

-Luke
 

mqudsi

Mostly Harmless
Staff member
It's also possible that the Vista decided for itself that it "needed correction" and did that - I've seen it happen before :frowning:

No matter - it's working now and that's what counts :smile:

(and you're welcome :grinning:)
 
Top