Vista won't boot and restore is lost!

#1
I have a Acer laptop with Vista Home Premium that installed a Windows Update and now won't boot up!

It won't boot in safe mode so I made the Vista Recovery x86 Disk and now on Startup Repair it runs and states it can't fix; then when I run the System Restore it states there are no restore points of which I know there were!

When I try to boot it up in the safe mode I get to Loaded: \Windows\system32\drivers\AtiPcie.sys then the screen goes blank and the WIndows Error Recovery screen pops back up asking what option I want to try to start with!

Please help!!!
 

JustinW

Super Moderator
Staff member
#2
Hi, welcome to NeoSmart Technologies.

Try deleting that driver using command prompt from the DVD.

To do this: Get to the recovery options menu when booted from the recovery disc and select "Command Prompt". Then use the following commands:

Code:
cd /d c:\windows\system32\drivers\
del atipcie.sys
shutdown -r -t 0
Does that fix it?
 
Last edited:
#3
I earlier found that it was set up to boot and changed it to manual and the same thing happend other than it stopped at a differnent driver!

I'm afraid if I remove it I will have bigger problems!
 

JustinW

Super Moderator
Staff member
#4
Looks like its your graphics driver which is corrupt. This can easily happen with the constant upgrades. Deleting the driver shouldn't muck up the system too badly if at all. Granted you'll need to re-install the driver when the system is booting normally again. Short of being in front of your computer, I would say it is this or a re-install of the OS in order to resolve the problem since system restore isn't an option. Have you tried startup repair?

I am a bit confused by your previous post. What do you mean set up to boot? Changed it to manual? What driver is freezing now?
 
Last edited:
#5
If I use Winternals ERD for XP I can get into the drivers and chage the status of them!
When it is disabled it stops at the driver that was just above it crcdisk.sys

Why can't I get the System Restore to work and just go back and fix the machine??

Thanks again,
Dave
 

JustinW

Super Moderator
Staff member
#6
Disabling the driver in XP wouldn't work as it is its own system with different drivers, etc.

Have you tried startup repair? If you have more then one drive in the system, have you tried disconnecting the others to see if it'll work?
 
#7
Its not in XP I only have Vista on the machine but the Winternals was made for XP and allows me to get into the drivers and disable them!

Startup Repair states there is a problem it can't repair then the system repair states there are no points of which there were until this happened! Seems there is a problem with Root cause found: A patch is preventing the system from starting

Can you give some idea of what the graphics driver maybe named to shut down!

There is a sticker on the machine that says the graphics by ATI Radeon XpressIII with up to 256MB Radeon Xpress 1100 HyperMemory?

Thanks again,
Dave
 
#9
I don't understand and am afraid to do the boot change!

Why won't the System Restore work and how can I get it too?

Addendum:

I gave it a shot and I still am getting the same thing!

The only thing that I have to comment on is that when I did del C:\boot\bcd
it asked it I was sure, I hit Y, and if failed to delete it, this happend not matter how many times I tried; so I continued on!

Everything else stated it was successful.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10
Well, an inability to remove c:\boot\bcd would mean that future steps may not have any effect.

It looks like there is some corruption on your drive (getting stuck on crcdisk means corrupt disk, incorrect disk drivers, or other disk-related trouble).

Try running
Code:
chkdsk c: /f
from the recovery console - does that find any problems?
 

JustinW

Super Moderator
Staff member
#12
In the command prompt, use:

dir c:\boot\

Does the bcd file appear in the list?

If it does, try:

cd /d c:\boot\
del bcd /f
 
Last edited:

JustinW

Super Moderator
Staff member
#14
Okay, use bootrec /rebuildbcd or follow the rest of the directions in the wiki after it telling you to delete c:\boot\bcd since it is no longer there.
 
#15
I did exactly as it read and still don't have a bcd when I check the dir c:\boot\ !!

The machine still will not boot vista either!!

Any other ideas?

I would just reinstall vista but I didn't back up the system and don't want to loose all of my files and programs!

It I can't transfer them now since the drive is being used to run the restore disk!

Thanks again,
Dave