Vista won't boot

#1
As i say in the title My Vista Home Premium 32-bit won't boot.
More specifically the system goes until the screen where the clasical windows bar appears and with Microsoft logo below it. The system stucks there unless i pull the plug and repower the PC.
As a recovery tool i am using the ISO recovery disk i found here in Neosmart.
The startup repair option did not do anything and neither the restore point option.
And we come now to the Command prompt option for manual fixing the boot sector.
As a guide i use this http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD
I am in step3.
Firts this command-bootrec.exe /fixmbr- is carried out succesfully
But in this command -x:\boot\bootsect.exe /nt60 all /force i get the following message:
The system cannot find the file specified.
Despite this i complete the step 3 but without fixing the PC.
The PC won't boot still.
Before proceeding to step4 i want you to help me explain in step 3 why x:\boot\bootsect.exe /nt60 all /force won't work.
Why the message The system cannot find the file specified appears?
 

Terry60

Knows where his towel is.
Staff member
#2
Hi jimace, welcome to NST.
My understanding is that the green progress bar is displayed as the kernel loads, ie you don't have a boot problem to fix, it's failing later on.
Try hitting F8 as you boot to go into the winload option screen, and try safe mode or "last known good..."

The "system cannot find ...." message is either because you're looking in the wrong place (you did change "x" to one of your drive letters ? ) or because some later distributions don't appear to have included it.
Remember the recovery console has its own lettering system (not the same as your Vista) so you might need to "hunt the file" by running through the alphabet to find the true value of "x". (But as I said - I don't think you need to repair the boot process)

If you get into safe (or last known) try running chkdsk to see if a HDD problem is hanging the startup.
 
Last edited:
#3
I must add 2 important details. The safe mode option does not work and while attempting to fix the problem through the NEOSMART recovery disk i and by executing i this command:
del C:\boot\bcd.
I what it happens now is that i dont see the green bar at all. Instead the following meassge appears:
status 0xc000000f
file:\boot\bcd

More specifically it states that this file is missing and the PC asks me the Windows CD to repair the problem.
It looks like that by typing the above command i deleted the file. The strange is that when i tried with the createstore command to rebuild the boot sector(and in accordance with the NEOSMART guide)a message appeared saying that the bcd file already axists and consequently a new one cannot be created.
I now iam confusing you but i we can find a solution to this.
Thank you
 

Terry60

Knows where his towel is.
Staff member
#4
Yes, you've deleted the Vista BCD, so obviously the boot is going to fail now.
Boot the recovery DVD again and chose "repair my computer" / "repair startup".
Do it 2 or 3 times (it only seems capable of fixing one thing at a time) until the boot is back to the state you first described, then try the F8 boot again.
 
#5
I managed to bring the computer to the earlier boot stage i mentioned in the beginning-green bar appearing and this bar seems to remain on screen" idefinitely".

Then as you said i press F8 and from there to safe mode.
Again similar problem appears. The loading of the windows files stops and it allways stop to the same file \windows\system32\drivers\crcdidk.sys.\

And it stays there unless i pull the plug again.

Same routine as the green bar.
I need to make the following clarification though.
In the previous days a memory card had stuck in the memory slot.
I managed to pull it out,but now i am thinking there is a chance the memory slot was damaged and that is the root of the whole problem.
Maybe the PC cannot start because it cannot load the memory slot drivers.
I do not know for sure though. The problem appeared after the unstucking of the Mcard.
What is your oppinion for all these?
I really would appreciate some assistance.
 

Terry60

Knows where his towel is.
Staff member
#6
Googling around seems to suggest a HDD problem, specifically SATA. Any chance you moved your HDD to a different channel ?.
Or can you plug your HDD on another system and chkdsk it to see if you can get past the disk error that appears to be hanging Vista.
Or are you a user of Daemon Tools ? google crcdisk daemon to find a solution if so.
Or, since you mention memory sticks, you haven't just upgraded to more than 3.6 Gb on a 32 bit system by any chance ? If so remove some memory to get below the 32bit addressing limit.
 
Last edited:

Sinth

New Member
#7
Hi there, sorry to jump in on this thread but my friends Vista laptop is in the pretty much the same boat.
It will only boot to
status 0xc000000f
file:\boot\bcd
I download and burned the iso, booted from it and said there were problems but couldn`t fix, couldn`t find file etc and I tried several console commands but to no avail.

Interesting post Terry,
Yes, you've deleted the Vista BCD, so obviously the boot is going to fail now.
Boot the recovery DVD again and chose "repair my computer" / "repair startup".
Do it 2 or 3 times (it only seems capable of fixing one thing at a time) until the boot is back to the state you first described, then try the F8 boot again.

How many times would I have to do this to create the bcd again or is the above problem a different kettle of fish?

Stu

Edit, it doesn`t find the operating system to repair, hitting next and repair just says cannot fix.
Click here to load drivers.... hmm what do you chose here to find the OS?
 
Last edited:

Billw

New Member
#9
Try booting with just the C Drive enabled at boot, this sorts the bootmgr missing problem and may work here too. I think this is to do with a drive conflict, somthing to do with maybe running sata drives and a normal ata try it and see. This is a page I posted after spending hours fixing a similar error. I realised the problem was being suffered by many so publish a fix page.
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#10
Bill, It's no good posting a "one fix cures all" in every thread. We try to ascertain why the bootmgr is missing if that's what the user reports (not very often), and give appropriate advice to fix whatever has caused the problem. You'll find plenty of advice to disconnect IDE drives to remove conflict with SATA in other threads, if it's relevant to the problem described.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#12
Sorry for the tetchy nature of my last post Bill.
Because of the post count > 1, I failed to identify you as a new visitor and be appropriately welcoming, so forgive my rudeness, and welcome to NST forums
Hope you'll continue to visit and pass on anything useful you find.