Vista - XP Help

AndyA

New Member
#1
I've got windows XP on one hard disc which I installed first and Vista on the other.I installed EasyBCD on vista and rebooted menu came up with choice of 2 then message when I select XP =
Windows Boot Manager has experienced a problem.File: \ntldrStatus: 0xc000000fInfo: The selected entry couldn't be loaded because the application is missing or corrupt
This turn out to be the wrong drive letter so I changed it to D from C
message gone but it just reboots now back to menu and loops.
If I F8or force the xp hard disc it will start ok
I 'm sure this is something simple
Please help
Andy
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Hello Andy,

Make sure XP's boot files (ntdetect.com, boot.ini, ntldr) are on the root of your Vista drive. If they're not copy them over from XPs. You'll need to enable viewing of hidden and protected operating system files in folder options in order to see them. Get the latest version of EasyBCD 2.0 Beta, available [thread=642]here[/thread]. Re-add XP's entry. Now when it asks you whether or not to auto-configure boot.ini click yes.
 

AndyA

New Member
#3
Thanks

Thanks Justin

Sorted your reply was perfect . Alot of the HOW TO's asume you are splitting a drive which is strange as they are so cheep, and there is not much docs on two drives with different operating systems your answer that told me to put the files on the vista drive was the first one I had seen
Thanks again

Andy {UK}
 

Terry60

Knows where his towel is.
Staff member
#4
The files need to be in the root of the "system" partition Andy. It doesn't make any difference if your OSs are on one HDD or several, the same rule applies. (see point 3 in the sticky thread)
 
#6
Hi Tommy.
You can't have multiple entries in your Vista BCD for OSes that use the ntldr. Rather, what you can do is add another entry to your boot.ini, making sure to point it at the correct drive and partition Win 2k is installed to, and you should be able to boot it just fine in addition to XP. :wink:

Cheers,

Jake
 
Last edited:

JustinW

Super Moderator
Staff member
#7
Tommy,

Add an entry for Win 2000 in your boot.ini under [operating systems] like this, adjusting the rdisk() and partition() values so they're pointing to the right place:

multi(0)disk(0)rdisk(0)partition(1)\WINNT\="Microsoft Windows 2000" /noexec=optin /fastdetect

Basically its the same thing as your XP entry, except you need to point it at the right partition for Windows 2000 and Windows 2000's windows directory is called WINNT instead of Windows like it is for XP.
 
#8
ntldr and ntdetect are in the root directory of my Win XP disk (I'm running BCD from Vista). However, all I get from bcdedit is exactly the same as the boot information screen in EasyBCD! Also, when I try to dual-boot, and I select Windows XP, I get Windows Xp on F: and Windows XP on f: (!) and then it restarts the machine again! What am I doing wrong?
 
#9
ntldr and ntdetect are in the root directory of my Win XP disk (I'm running BCD from Vista). However, all I get from bcdedit is exactly the same as the boot information screen in EasyBCD! Also, when I try to dual-boot, and I select Windows XP, I get Windows Xp on F: and Windows XP on f: (!) and then it restarts the machine again! What am I doing wrong?
Get [thread=642]2.0 Beta[/thread] version (the latest) of EasyBCD, install, and go to the Tools menu in there. You should see an option called "Auto-configure" boot.ini. Select that option, and then reboot and test. You will most likely not be able to get into both XP and Win 2k at this point, because I don't think the auto-config can add multiple entries to the boot.ini at this point, much less for an OS that uses a WINNT directory instead of WINDOWS, but there's a chance it might. If you still can't boot into both at this point, then post your current boot.ini, along with a screenshot of Disk Management, and the output of the following command run from EasyBCD's Power Console on the "Useful Utilities" page:
Code:
bootpart
That should enable us to accurately determine the rdisk and partition values your Win 2k partition is located at, in regards to the BIOS, and you will soon have the problem fixed.

EDIT: Your "ntldr" and "ntdetect.com" also need to be in the root of the partition marked as "system" in Disk Management. If that's not your XP partition, then XP will not able to boot.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#12
Tommy, please read the sticky thread point 3.
You do not point the BCD to the NT OSs , but to the boot files in the "system" partition (that's why EasyBCD "greys" them to try to stop you getting yourself into this problem)
You don't have multiple entries for NT systems in the BCD, just 1 entry, and then NTLDR makes the choice between the NT systems using entries in boot.ini.
You need to copy the XP boot files to C:\ (your "system" partition),
Delete the 2 entries from the BCD,
Add one entry (call it something like "XP or 2000") to the BCD with Easy 2.0 (let it default to C:\)
Accept the offer to create boot.ini for you.
 
#13
You need to label your partitions in Disk Management, and post a fresh screenshot of it, so we can tell which partition is which. Terry is right. Your C: partition is "system" so that means you need to copy over into the root of that partition, the "boot.ini", "ntldr", and "ntdetect.com" files (you'll probably have to go into the Folder Options in the control panel, and under the View tab, select Show Hidden File and Folders, and uncheck the hide protected system files option before you will be able to see these files). Then follow my other advice in [post=36375]post #9[/post], and you should soon have a working boot of 2000 in addition to XP and Vista.
 
Last edited: