Vista - XP - Ubuntu

#1
Okay, here is my problem.
I have a dual core (Intel) 1 Gig Ram(Yeah, I need to update the ram)
I have three hard drives - 2 SATA Drives, 1 IDE Drive and 1 IDE CD/DVD Burner.
The SATA drive is the one I am using for all this.
I have installed Vista and XP on the drive and got them to boot right (Using the EasyBCD)

I then install Ubuntu (7.10) so the same drive (three partitions so far).
I created the saw file (1 gig) and then started the install -
When I got to the spot with the Advance, per EasyBCD (Ubuntu - NeoSmart Technologies Wiki) it stated make it the partition that I had the install for Ubuntu on (SDA,4 - SDA,3 was my swap).

I got an error while doing that. I did change the 70gig area (which is what is being used for Ubunut) to the ReiserFS (/) as instructed.

But - I also tried without changing the Advanced area - leaving it alone.

I tried EasyBCD to create the boot up list but nothing. I really need some help here
But before that - I never changed anything. I left the
 

mqudsi

Mostly Harmless
Staff member
#2
Hi techgeek, welcome to NeoSmart Technologies.

I'm afraid your post isn't complete, can you try editing it again?
 
#3
Vista - Xp - Ubunut

Basically my issue is this.
I have a SATA drive that I have partitioned into three drives.
Vista is (C) with XP as (J)drive -
The third partition I have left alone - using that for Ubuntu (70 gigs)

I am having a VERY hard time getting Ubuntu to show up in my boot options (vista or xp)
I get those two (using the EasyBCD) but when I try Ubuntu it doesn't list.

Following the directions in the wiki (Ubuntu - NeoSmart Technologies Wiki) I did exactly as stated - got a fatal error (no info on why - just a fatal error)

I need a way to make sure that I can install Vista/XP/Ubuntu on one drive (3 partitions) with a SATA drive (Ubuntu would be on SDA-4 (Ubuntu) and the swap file on SDA-3

Just to make clear: I have 2 SATA drives - IDE Drive (80 gigs) and one IDE CD/DVD Burner)
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
You can install the three on one drive - no problem.

But if you're getting a problem partitioning your drive - there is no way that EasyBCD will work for you.

Try grabbing a copy of Partition Magic or Disk Director and partitioning your drive with one of those, then installing Ubuntu and seeing what happens.
 
#5
UBunut

I did partition the drives just fine - no problems
When I install Ubuntu I see the sda1 (which is my Vista) sda2 (which is my XP)
I then use Ubuntu's partition on the "third" partition to make a swap file - that goes fine.
Then I use the remaining partition (listed as free in Ubuntu) to install the O/S

It goes through the install fine - IF i don't change to the ReiserFS (/) and keep it as ext3

If I use the ReiserFS and on "7 of 7" use the Grub on (sda,4) that is when I get the error

BUT - if I use the ext3 (/) then I would like a way for EasyBCD to set up so I can see all three (Vista/XP/UBuntu) during boot up and select from there -

Here is the screen I get for Step 7 of 7
Language: English
Keyboard layout: U.S. English
Name: techgeek
Login name: techgeek
Location: America/New_York
Migration Assistant:



If you continue, the changes listed below will be written to the disks.
Otherwise, you will be able to make further changes manually.

WARNING: This will destroy all data on any partitions you have removed as
well as on the partitions that are going to be formatted.

The following partitions are going to be formatted:
partition #3 of SCSI1 (0,0,0) (sda) as swap
partition #4 of SCSI1 (0,0,0) (sda) as ext3

That's where I am running into a problem.

Addendum:

Okay,
Here is how I have things laid out

DEVICE TYPE MOUNT POINT FORMAT? SIZE USED
/dev/hda
/dev/hda1 ntfs /media/hda1 (76720 MB) 7600 MB
/dev/hda2 ntfs /media/hda2 (5241 MB) 1100 MB
/dev/hdc
dev/hdc1 ntfs /media/hdc1 (80023 MB) UNKNOWN
/dev/sda
/dev/sda1 ntfs /media/sda1 (59290 MB) 17800 MB
/dev/sda5 ntfs /media/sda5 (24594 MB) 6000 MB
/dev/sda3 swap (1998 MB) 0 MB
/dev/sda4 ext3 / (74150 MB) 3500 MB
/dev/sdb
/dev/sdb1 ntfs /media/sdb1 (80077 MB) 24800 MB
/dev/sdb2 ntfs /media/sdb2 (79961 MB) 63500


As you can see I am using sda4 for the Ubuntu install - so my question is how do I get EasyBCD to see that and us it?

Addendum:

This is the error I get when I install

This is what I am getting when it gets to the end
Unable to install GRUB in (sda4)
Executing 'grub-install (sda4)' failed.
This is a fatal error
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
You have to change sda4 to (hd0,3). Then it should work.
 

mqudsi

Mostly Harmless
Staff member
#8
Counting of partitions starts at 0 not 1 in GRUB.
 
#9
Failed - Again

Okay, did the (hd0,3) and still getting the grub installer failed.

One thing I am confused about (yeah, I am that way right now)

If I am installing on sda (which I assume to mean sata drive a) why am I using hd?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
That is because hd stands for Hard Drive.
 
#11
Trying - Lord Knows I'm trying

Okay, so if I put (hd0,3) in the advance part of the install
----- Problem: Looking at the dev part I don't see anything with hd0
I do see hd and sd - but no hd0

I know I'm being a pain - but trying to get my mind around this
I know the hd stands for hard drive - but how do the 0,3 come into play
I know the three is for 3 hard drive - but why the 0 and how does that come into play

Maybe I'm not understanding this right but wouldn't I do (hd2,3) since the sda is seen (using the 0 to start the count) since sda3 is the third hard drive in the list?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#12
Well, here's the thing: in Ubuntu 7.04+, sd* refers to both sata and ata drives - so I have no idea what order they're actually in.

You can see this page for info about drive names and numbers, it's a very interesting (and easy) read: Drive Letters and Numbers - NeoSmart Technologies Wiki

So perhaps it is (hd0,3) or (hd2,3) - I have no idea, you'll have to try and see.
 
#13
So I would not use (sda,3 or sda,4) it would always be hd0 (even though the device is the third device in the list -
I don't remember if I tried hd2,3 yet - I may have done (hd2,4)
Or even hd3,4)

Addendum:

Let me post it this way; because I may be leaving something out.


I started this whole thing in this order:


  1. Installed Vista (/dev/sda1) rebooted several times – all worked.
  2. Installed XP (/dev/sda5) rebooted several times – all worked.
  3. Put in the Vista CD – fixed MBR
  4. Back in Vista, installed the EasyBCD and set up the Dual boot fuction. That worked fine and I was able to boot into either Vista or XP
  5. Shut down, rebooted with the Ubuntu Live CD and got in just fine. Started installation process. At step 7 of 7, I did NOT change the (hd0) leaving that alone. Everything went fine, no errors.
  6. Went back into Vista, started up EasyBCD and selected the Linux tab, selected Grub (now, the foggy part is I don't remember all of the options I may have choosen.)
  7. Rebooted, did see the “Ubunut” boot and selected, but got some errors and wasn't able to even load Ubuntu – I had to shut down and go back into Vista. That is where I went into Computer Management and deleted the two partitions to try over.
That is when I started trying to use hd0,2 or hd0,3 and that is when I would ge the errors:
Unable to install GRUB in (sda4)
Executing 'grub-install (sda4)' failed.
This is a fatal error


Below is my full drive layout. (More below that)


DEVICE TYPE MOUNT POINT FORMAT? SIZE USED
/dev/hda
/dev/hda1 ntfs /media/hda1 (76720 MB) 7600 MB
/dev/hda2 ntfs /media/hda2 (5241 MB) 1100 MB
/dev/hdc
dev/hdc1 ntfs /media/hdc1 (80023 MB) UNKNOWN
/dev/sda
/dev/sda1 ntfs /media/sda1 (59290 MB) 17800 MB (Vista)
/dev/sda5 ntfs /media/sda5 (24594 MB) 6000 MB (XP)
/dev/sda3 swap (1998 MB) 0 MB (Swap – obvious)
/dev/sda4 ext3 / (74150 MB) 3500 MB (Ubuntu)
/dev/sdb
/dev/sdb1 ntfs /media/sdb1 (80077 MB) 24800 MB
/dev/sdb2 ntfs /media/sdb2 (79961 MB) 63500


Now, I did check NeoSmarts forums and did what was suggested, even using the step by step guide, nada.

So, there it is – in a nutshell. I have looked all over the web and it seems there are those that are doing triple boot and making it sound easy, but yet no details of how they are doing it.


That's it in a nutshell



Now, on the Ubuntu forums I got this:

For EasyBCD to boot Linux, grub has to be installed to the root partition, which in your case appears to be /dev/sda4...rather than using something like installing grub to (hd2,3), it is best to use "/dev/sda4", again without quotes. I think there is an "Advanced" button at step7 that you need to click on, which will give you the ability to type in /dev/sda4, in place of the default (hd0)
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#14
I had no idea you could type "/dev/sda*" in the advanced box and get it to work - have you tried it?
 

mqudsi

Mostly Harmless
Staff member
#16
lol, good luck with that.

Wish I could say I feel the same though - I tried staying at home doing nothing, it's torture!

Work > No work :smile:
 
#17
It Worked - Somewhat

Well, I used the /dev/sda4
No errors
Went to Vista and EasyBCD and under the linux option choose GRUB and all the happy stuff (Type Grub - Name Neosmart Linux - Drive Partition 3 (linux native)

But here is the error I get:
LOADING NEW PARTITION
BOOTSECTOR FROM C.H. HOCHSTATTER

CANNOT LOAD FROM HARDDISK
INSERT SYSTEMDISK AND PRESS ANY KEY

(I press enter - no other boot disk and I get)
BOOT FROM CD (I hit enter)
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER


Addendum:

I had no idea you could type "/dev/sda*" in the advanced box and get it to work - have you tried it?
OKay, I am using ubuntu
BUT -----

Is there a way to make a "text" file so that it will record all boot loading processes

I get the boot options - but I have to choose Windows - and then cycles through - gets back to the boot options - and then I can get into Ubuntu - if I do it any other way it just cycles through.

Just curious if there is a way to make a log of everything going on to "boot" and then post that
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#18
I'm not sure what you mean.

1) What did you do to get it to "work"
2) What is the exact sequence of bootloaders/boot-menus that you get when you reboot?
 
#19
Booting

In the 7 of 7 setup screen for Ubuntu I went into advance and put /dev/sda4
No errors - that worked just fine.
Restarted computer
Went into Vista and set the EasyBCD (Linux) To Grub - and selected the partition

That's all fine - restarted - and it's there (Ubuntu)
Now, if I select Ubuntu to start - it gets to a screen asking me which one (the regular one and safe mode - I'll have to get the exact wording)

If I make the first choose - it goes through the process of 'loading' but then I get the errors I posted earlier
 

mqudsi

Mostly Harmless
Staff member
#20
And the second option, does it work?