Vista64 & Ubuntu64 dual boot woes

#1
Hi guys,

I've trawled through the posts here and unfortunately not been able to figure out what the problem is with my setup so I'm hoping someone can give me some pointers.

Basically, I have Vista x64 business installed on a 500GB SATA drive, which is partioned into 2 equal sized chunks. Vista is installed on the first partition.

I also have another 250GB drive on which I wanted to install Ubuntu. So, I followed the guide here on dual booting Ubuntu, to the letter.

I made a roughly 100GB, primary ext3 partition, with a "/" mount point, along with a 4GB swap file (I formatted the rest of the disk as NTFS for windows backup)

The drive was "sda" so installed grub on "/dev/sda1" (the 100GB ext partition was #1).

I rebooted into Vista added a linux entry, as per the guide and pointed it towards the linux partition and it doesn't work. On the Vista boot screen, when I select the option I added for Ubuntu a screen flashes up for a split second (it mentions something about bootsect IIRC) before returning to the VIsta boot screen again.

Any ideas where I'm going wrong?
 
#2
Could it be an issue isolated to the 64bit version of Ubuntu?

I don't see how, as I'd imagine that they both use the same version of grub but I'm really at a loss here.
 

mqudsi

Mostly Harmless
Staff member
#3
Hi WhiskeyAlpha, welcome to NST.

When adding a Linux entry in EasyBCD, try selecting "GRUB isn't installed to the bootsector" and see how that goes.
 
#4
Hi ComputerGuru, thanks for the welcome :smile:

I managed to sort this actually but it was very odd. After doing what the guide recommended 3 times in a row (convinced that I was doing something wrong each time) I tried using the "GRUB is not installed to the bootsector" option that you mentioned. Unfortunately, that failed to sort the problem.

Just as an experiment really, I physically swapped the SATA cables between the two drives and performed the process again, exactly as I had done the previous 3 times. The only difference this time was the linux drive was now "sdb" instead of "sda". I installed GRUB to "/dev/sdb1", booted into Vista, added the entry in EasyBCD and it worked like a charm, right off the bat.

Care to hazard a guess as to what might have caused this? I like to learn from my mistakes but this just left me a little :wtf:.

Cheers,

WhiskeyAlpha
 

mqudsi

Mostly Harmless
Staff member
#5
There's a known problem with other Linux distributions (not Ubuntu though) where GRUB will fail to install to the bootsector of a partition not on the boot drive (i.e. not /dev/sda) - it looks like you've run into the same issue for some odd reason.

Having reinstalled GRUB, you may be able to switch the cables back and still get it to work; but I don't think there's a need to do that (if it's not broke...)

Anyway, glad it's sorted out now.