W7+F11: Fedora doesn't boot

kdl

New Member
#1
Hi, I have followed the manual to install Fedora 11 to a notebook with a single HDD and Windows 7 x64 previously installed. I had to use custom partitioning where /boot is at /dev/sda3 and the rest of Fedora partitions are within an LVM block.

I made sure Grub installs not to the MBR. I used latest EasyBCD 2.0 release to add the Fedora entry (pointing to the partition with /boot). Now I can boot to W7 ok, but when I choose Fedora, all I see is a black screen and a blinking '_' cursor at the top.

I also tried adding an entry pointing to the other Fedora partition - same result.

What am I doing wrong?

Addendum:

If it can help, here is the bootpart output:

Boot Partition 2.60 for WinNT/2K/XP (c)1995-2005 G. Vollant (info@winimage.com)
WEB : Gilles Vollant software and BootPart
Add partition in the Windows NT/2000/XP Multi-boot loader
Run "bootpart /?" for more information

Physical number of disk 0 : a4dbed6c
0 : C:* type=7 (HPFS/NTFS), size= 102400 KB, Lba Pos=2048
1 : C: type=7 (HPFS/NTFS), size= 52428800 KB, Lba Pos=206848
2 : C: type=6 (BIGDOS Fat16), size= 204800 KB, Lba Pos=105064448
3 : C: type=f (Win95 XInt 13 extended), size= 259832832 KB, Lba Pos=105474048

4 : C: type=7 (HPFS/NTFS), size= 209715200 KB, Lba Pos=105476096
5 : C: type=5 (Extended), size= 2098176 KB, Lba Pos=524906496
6 : C: type=6 (BIGDOS Fat16), size= 2097152 KB, Lba Pos=524908544
7 : C: type=5 (Extended), size= 48017408 KB, Lba Pos=529102848
8 : C: type=8e , size= 48017407 KB, Lba Pos=529102849
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Welcome to NST kdl,

You should be using [thread=642]EasyBCD 2.0 Beta[/thread]. Re-add the entry for Fedora, pointing it to your /boot partition if you have one or your linux partition where Fedora's system is stored if you don't.
 

Terry60

Knows where his towel is.
Staff member
#3
Did you tick the "grub isn't installed......." box ?
It should not be ticked for Linux on the same HDD as W7, only if they're on different HDDs.
 

kdl

New Member
#4
kairozamorro
That's what I wrote in my post: I used latest EasyBCD 2.0 release to add the Fedora entry (pointing to the partition with /boot). Sorry, I did not mention it was EasyBCD 2.0 beta since I thought it only exists in beta. I deleted and re-added Fedora entry several times to no avail.

Terry60
No, I did not tick that checkbox

Addendum:

Viewing settings in EasyBCD, I get this:

There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 30 seconds.
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Fedora
BCD ID: {fd949582-68f1-11de-a8d6-d6cd00eaf5b0}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr

The last line is what seems to be confusing for me: although the file C:\NST\nst_linux.mbr does exist, shouldn't that line be pointing to somewhere else?
 
Last edited:

JustinW

Super Moderator
Staff member
#5
No, thats correct. That's how its possible to load grub from Vista's bootloader. Uninstall NeoGrub on NeoGrub tab, remove entry, and try again. Which build are you using? Build 63 should be used (current build at this time).
 

kdl

New Member
#6
I do use build 63.

I did not install NeoGrub, and I could only see the Install and dimmed Configure buttons in the NeoGrub tab. Now I installed and uninstalled it, removed and re-added the Fedora entry - all the same.

Also I re-read the guide and remembered that I did not remove that 'Other' item at the Step 4, but Fedora was ticked as the default in the list. Could this be a problem?

Another thing is that although I created LVM within an extended partition, now in disk management I see it as a primary partition. All together it counts to 4 primary partitions plus an extended one. AFAIK it can be max 4 primary or 3 primary and 1 extended... Could this be a problem?

Also here is my /boot/grub/menu.lst file:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,2)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_nb-LogVol02
# initrd /initrd-version.img
#boot=/dev/sda3
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.4-167.fc11.i686.PAE)
root (hd0,2)
kernel /vmlinuz-2.6.29.4-167.fc11.i686.PAE ro root=/dev/mapper/vg_nb-LogVol02 rhgb quiet
initrd /initrd-2.6.29.4-167.fc11.i686.PAE.img
title Other
rootnoverify (hd0,0)
chainloader +1

I tried uncommenting #boot=/dev/sda3 line, it did not help.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
Try adding an entry with the checkbox ticked.
 

kdl

New Member
#9
And yes - it worked! Ticking the box which everyone said shouldn't be ticked did the trick. Thank you, thank you, thank you!
 

Terry60

Knows where his towel is.
Staff member
#10
Looks like Fedora, unlike Ubuntu, can't boot natively with grub even when it shares the Vista HDD, and needs to go the Neogrub route in all circumstances. (ticking the box causes Neogrub to be installed and used as a bridge to grub)
 

mqudsi

Mostly Harmless
Staff member
#11
You're welcome :smile:

Terry, it looks like GRUB wasn't correctly installed to the bootsector - so he needed to bridge it via neogrub.
 

Terry60

Knows where his towel is.
Staff member
#12
I've only used Ubuntu, so have no Fedora experience, but his first post description sounds like the install correctly placed grub in the /boot partition boot sector. In Ubuntu that would have been a "no tick".
I wouldn't bet my life on it, but I think I can remember at least one other past occasion where Fedora was reported doing the same thing.
Is the latest Fedora install doing something wrong ?
 

mqudsi

Mostly Harmless
Staff member
#13
I don't think so..... It, too, should be the same as Ubunutu; but I figured if it's not working clearly the bootsector hasn't been written.... and that's what it turned out to be.