W7 & F11: Grub doesn't initiate boot automatically


I have 2 SATA drives. On the first one, W7 (MSFT's MBR) and on the second one Fedora 11 (With grub installed on the volume). I've been using EasyBCD beta.

When starting the PC, W7 bootloader properly shows the two entries: W7 and Fedora. W7 starts normally but if I select Fedora, I end up on a screen similar to the one somebody posted previously:

Consequently, while it properly loads the program, it simply hangs there, not doing anything. However, I have a proper menu.lst located in /NST/ and if I type "configfile /NST/menu.lst" then my grub starts and I can start Linux with no problem.

Why is that? Why isn't the menu.lst file sourced automatically?



There are a total of 3 entries listed in the bootloader.

Default: Windows 7
Timeout: 30 seconds.
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Fedora
BCD ID: {72d1328b-d14c-11de-901e-96664118dc5b}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Entry #3
Name: NeoGrub Bootloader
BCD ID: {72d1328e-d14c-11de-901e-96664118dc5b}
Drive: C:\
Bootloader Path: \NST\NeoGrub.mbr


Knows where his towel is.
Staff member
Does Fedora 11 use Grub2 like Ubuntu 9.10 ?
If so pick Grub2 instead of legacy grub when adding the Linux entry.
(sorry not a Fedora user)
Have you altered the /NST/menu.lst at all?
If so, then uninstall NeoGrub from the NeoGrub tab in Add/Remove Entries of EasyBCD, delete the current Grub2 entry, and create a new one.
Yes, it was altered so as to contain proper entries. Anyway, I am not sure that was the problem. Fedora 11 is not using Grub 2, so what I did was to use Grub-Legacy. But Grub-Legacy would fail with a blank screen and blinking cursor unless I check the box saying that grub wasn't installed on the volume. Once checked, it works and loads my menu.lst (not the one on /NST, but the "real" on my linux partition), and it all works.
So its working now?
Congratulations, and enjoy your multiboot. :smile:

(Checking the "Grub is not installed to the MBR/bootsector" option will install a version of NeoGrub that searches all partitions for the Grub menu.lst, and loads it, so technically the NST menu.lst is read from, then it hands control over to normal Grub)


Knows where his towel is.
Staff member
Guys, thanks a lot for your help, that was indeed in the FAQ, shame on me.

To be totally accurate, this is really the menu.lst which was on my linux partion which has been read, not the one under /NST. I had fixed some issues to the one under /NST and the one which was loaded was the "buggy" file i.e. the one in the linux partition to be booted. This is good as this is the behavior I am looking for anyway.