Want to remove spurious "EasyBCD Boot Device" which points to Drive K:

x509

Member
At one point, I had two boot entries. Drive C:, my "production" Windows (called APOLLO), and Drive K: my "experiments" Windows. Both are Win 10 Pro 64. Even though I removed Experiments from my boot menu, I ended up with this weird EasyBCD Boot Device pointing to Drive K:

1604872479633.png

To recover disk space, I want to remove Drive K: for now, but I'm worried that if I do that now, my APOLLO partition won't boot the system.

So my question is, how do I change the Boot Device back to C:?
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
In the "view settings" overview mode, EasyBCD lets you know that there are EasyBCD boot files containing boot chain info on K.
"Detailed (debug)" mode will show you the Windows drive containing its boot files.
Also you can verify the actual boot drive via the "system" flag in Disk Management.

Disk Management flags have the following meanings

"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"
 

x509

Member
Terry60,

Thanks a bunch for the quick reply. Here is the debug mode. I honestly don't know how to interpret the results.

1604900506740.png

Out of curiosity (for now), what would happen if I deleted the partition for Drive K: ? Or, is there some easy way to modify the Boot Manager so that the Boot Device is C: instead of K: ?
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
You're on a UEFI PC, so the boot files will be in the EFI System Partition (sorry! should have notice that in your OP - "winload.efi").
There's no "active" flag in UEFI, that's a concept from the legacy BIOS/MBR days. A UEFI PC will always boot from the above mentioned partition.
You can remove any partition as long as it doesn't have any any of the flags system, boot or page.
It won't be "system" (thats EFI System Partition). It will only be "boot" if you're actually running it, and it will only be "page" if at some point you moved the virtual memory there for performance reasons (in which case, move it off again), so you should be able to remove it with no problems.
In any case, if you try to format a partition which does contain active system files, Windows won't let you.
 
Last edited:

x509

Member
Terry60,

I now realize that my issues have nothing to do with the actual BCDSTORE, only with the EasyBCD Boot Device. I want to be doubly sure here, so I don't trash my Windows installation. :anguished: There is an EFI folder right now in both C: and K:.

IF I simply delete the K: drive, which is the current EasyBCD Boot Device, what happens? Can I still boot my system? Will C: now become the EasyBCD Boot Device? Or do I have to do something else so that C: becomes th3e EasyBCD Boot Device.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
I refer you to the last sentence of my previous post.
If you try getting rid of K and that's actually what you're booting through, Windows won't let you do it.
Should it refuse to co-operate bacause K is the live boot device, then you'll need to get into the BIOS editor and change which device tops the priority list.
Post a screenshot of your Disk Management for me,
 

x509

Member
Terry,

Here is the Disk Management display for the drive in question. I just want to say that I really appreciate the help here.

1604981922925.png
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
I misunderstood you.
I thought you had two separate drives with an EFI System partition on each and you weren't sure which was booting.
Your actual situation is much more simple. They're just two partitions on the same drive with a single EFI SP so no problem,
K is just listed as data, you can format the hell out of it without affecting your boot.
 

x509

Member
Terry, I just want to thank you. I deleted (after backing up ...) drive K: Now my BCD Boot Device is indeed C:, which is what I wanted.

Thanks again.
 
Top