Weird dual boot issue

#1
I discovered this while trying to set up an Ubuntu Linux install within my windows installation using Wubi (it's available on the standard Ubuntu 8.04 iso.)

I'm able to boot just fine to my grub bootloader, and I can select my four Ubuntu kernels and my Vista partition. Once I select the Vista entry in grub, it chainloads to the vista bootloader on my first partition on disk0, and everything runs just fine.

However, when installing Ubuntu, the wubi installer kept telling me that it could not find/write to the bcd file as it did not exist. This seemed odd, as I'm able to boot with no problem. I start poking around to see if I can manually put in the entry for ubuntu, and I realize that my system is acting as if there is no C:\Boot\BCD file in existence--no OS entries in MSConfig or the advanced system settings dialog under Startup and Recovery.

So, I pulled out my trusty installation disk, and booted it, tried a startup repair, and it says nothing is wrong. so I open a console, and sure enough, running bcdedit.exe shows everything as it should.

So, reboot again, without the disk in the drive, and, of course, no OS entries, and no bcdedit results--as if BCD does not exist.

So, reboot again, WITH the disk in the drive, but allowing the "press any key" dialog to time out, and, voila, BCD is a real file again, hallelujah.

So, one final time, reboot w/o the benefit of the DVD bootloader, and i'm in Vista, once again, no known partitions. So I install your software, and try to start it, and it tells me the same thing bcdedit is telling me over and over again: "The store import operation has failed. The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted." Bollox! :smile:

So, as a last resort, I boot into the recovery disk, delete C:\Boot\BCD after changing all the attributes, and try to reboot. As expected, boot is impossible. So, I reboot one more time into the recovery disk, and click repair--it can't find any partitions, but the vista installer says it can fix it (all by itself, how neat), and, lo and behold, it does just fine. However, same symptoms--bypass grub, BCD lives. Use grub to chainload, no BCD. What gives?

Any ideas on how to rectify this?
 
#3
Meh.

Followed the directions in the "holocaust" section, as I'd done everything else. I am still unable to recognize the BCD entries. EasyBCD is just giving me a feedback loop, telling me that it's not recognizing the filesystem.

I didn't get any errors at all, and I used the right-click functionality within the cmd.exe to paste the GUIDs, so that's not it. Not sure what I'm doing wrong, besides using grub--and, for some reason, Windows doesn't want to kill grub!!! I'm thinking it must reside on another drive or something, but I'm not certain. wouldn't it be a trip if I was dealing with three different MBRs on three different drives? hmmmm....

I cannot wipe them, however, as I would be mortified to lose all my data.

Any suggestions?
 

mqudsi

Mostly Harmless
Staff member
#4
That's the only other suggestion I can think of.

It seems like Vista thinks the boot drive is one thing and the motherboard/BIOS thinks of another.

Solution:
EasyBCD | Useful Utilities | Power Console
Code:
MbrFix /drive <num> fixmbr /vista
EasyBCD will normally use 0 as <num> which means "do it to the drive that Vista thinks is the boot drive"
In your case, run this command 3 (four, five, whatever) times - once for each drive.

Code:
MbrFix /drive 0 fixmbr /vista
MbrFix /drive 1 fixmbr /vista
MbrFix /drive 2 fixmbr /vista
.....
It'll only update the MBR with the Vista bootloader, will not touch the data or the partition table.
 
#5
Boot order, that was it. boot order changes completely when I'm doing a dvd boot as opposed to a hard drive boot. I blasted all the mbrs, and I still had a boot record on a partition (as opposed to the drive mbr), so i made that drive the first boot, and boom, we're good. Before changing, I had a "missing operating system" message from my bios hanging out.

Thanks for pointing me in the right direction.
 

mqudsi

Mostly Harmless
Staff member
#6
No problem, glad it worked.

I think I saw that issue before on my old PC... On my current PC though changing the boot order doesn't stop Vista from knowing the right boot drive. (this issue gave me hell w/ our other program, Vista HnS)