Weirdest thing ever... Please help!

#1
Need to discover my REAL "boot" drive...

Hi I hope you can help me. I desperately need to discover my REAL boot drive but, as it explained below, I'm having trouble figuring out which one it is.

I'll try and explain the situation as clearly as I can...

I originally had three harddisks...

C: was (and still is) Windows Vista
E: was a clean install of Windows XP
G: was (and still is) a Spare HD.

I set up a dual boot during my installation of Windows Vista, without any problems.

My Windows XP drive and my old Spare drive started playing up, so I decided I didn't really need XP and should replace my problematic HDs with a new one.

I removed the Windows XP dual boot entry using EasyBCD. All good!

BUT! Now my computer refuses to boot up without my old Spare HD still connected. It just hangs after the BIOS has completed its stuff... so I have to keep this old knackered HD connected :frowning:

Since I can't boot up without my old HD connected, but the old HD causes problems in Vista (moments of stutters), I disabled it in Device Manager. This way it boots fine, but doesn't cause me problems in Vista as it doesn't appear... (This is only a temporary solution though, I need to remove this old HD.)

The weird thing is that when I try and go into Easy BCD with the old drive disabled, EasyBCD throws up and error about the MBR not being there and it can try and fix it (which it can't). If I re-enable the old HD in Device Manager and then try EasyBCD again -- it works fine...?!

AFAIK Windows Vista should only be talking to the C: drive -- I have no idea why my old HD is involved!

I've tried: "Reinstalling the Vista Boot Loader" and "Reset BCD Storage". Neither of them worked, so I was about to try "Recreate missing/deleted boot files", but it says that I need to be sure, beyond a shadow of a doubt, what my REAL boot drive is.

Here's where the confusion begins: C: does indeed have a directory called "Boot" and a file called "BootMgr" BUT! when I ask BCD to "Check boot drive for corruption" it scans my OLD HD. What's going on? Which is my REAL boot drive? How can I fix this?

Could the problem be something to do with the fact that I "Upgraded" to Windows Vista and now Windows XP has gone?

Please help in any way you can, I'm pulling my hair out!

Thanks alot!

- Johnny
 
Last edited:
#3
Here's the Debug output from EasyBCD...

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=G:
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {e8709fb6-fa5f-11db-be4d-e219ece5282e}
displayorder            {e8709fb6-fa5f-11db-be4d-e219ece5282e}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 5

Windows Boot Loader
-------------------
identifier              {e8709fb6-fa5f-11db-be4d-e219ece5282e}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows Vista
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice                partition=C:
systemroot              \Windows
resumeobject            {e8709fb7-fa5f-11db-be4d-e219ece5282e}
nx                      OptOut
 

Terry60

Knows where his towel is.
Staff member
#4
Hi Johnny, welcome to NST.
Disconnect your E and G drives, boot from your Vista DVD, select "repair my computer" / "repair startup" and let Vista reinstall its boot process on the Vista drive. (you will probably need to do this 2 or 3 times before it finally fixes everything - it's a pretty dumb process)
Eventually the Vista system will boot without the aid of the DVD and you can remove the other disks permanently if you want to, or format them and use it as spares (a full format should remove any dodgy sectors from use and give you back a useful drive)
It's not unusual for Vista to install its boot files on another patition (my dual boot Vista /XP for example has XP as the "system active" partition, and it's no problem until of course you try to get rid of it, as you've found)
 
Last edited:
#5
Ah, wonderful! Thanks for your advice. The thing is that E: is actually a brand new HD with nothing on it (indicated by its "RAW" status). I cannot format it or write to it or even open it. It's just a raw hunk of unformatted disk... Why Vista sees it as "System" is an entirely other issue which is also driving me up the wall. (I'm so frustrated! All I wanted was a new HD *sob!*)

I'll remove E: and reboot and see what Disk Manager shows then?
 

Terry60

Knows where his towel is.
Staff member
#6
I edited my reply, but you obviously read it in its unedited state.
After posting, I realized the logical status of E, which means it can't be marked "active" which means the MBR won't point to it, so I changed the advice to removing both the other drives till you've repaired the boot.
I must confess to being puzzled by the flags on your drives, What's the order of the HDDs in your BIOS boot sequence ? Which one are you going to first ? The only "active" flag is on your 3rd HDD, but it has no "system" flag, and the 2nd HDD has the "system" (ie boot files) but is not "active" (what the MBR looks for).
Nevertheless, the Vista auto repair should still fix everything for you.
 
#7
Ok, I'll certainly give that a try... but I have attempted this once before and when it asked me to select an instance of Windows to repair, it couldn't find any. I clicked "Next" regardless and asked it to fix "Unknown on unknown" which it claimed it did.

Very confusing :frowning:

Could this (ignoring my bizarre HD problems for a moment) be related to the fact that I "upgraded" my Windows XP installation to Vista... on a new disk. And now I don't have the Windows XP installation anymore?

Will post back with my results. Thanks!
 

Terry60

Knows where his towel is.
Staff member
#8
The "no system to repair" symptom is probably because you have a SATA /IDE mix ? and it shouldn't occur if the other disks are not connected.
 
#9
It didn't detect my installation once again, and once again I asked it to repair it anyway... but guess what! IT WORKED!!!!!!! Thank you so much!!!!!

Check this out!

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=C:
default                 {5b43264e-6b08-11dd-a2e1-ae354112768e}
displayorder            {5b43264e-6b08-11dd-a2e1-ae354112768e}
timeout                 30

Windows Boot Loader
-------------------
identifier              {5b43264e-6b08-11dd-a2e1-ae354112768e}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows Vista (TM) Home Premium (recovered) 
osdevice                partition=C:
systemroot              \Windows
resumeobject            {17f600c6-6abd-11dd-8f62-806e6f6e6963}
I'm going to reconnect my other HDs now and see how it responds. Thanks again!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#10
When you did an "upgrade" to a clean disk, I assume you mean you did a full install with an "upgrade" DVD (which would have required you to produce proof of ownership of a qualifying upgradable system, or would have looked for one somewhere on your system)
If it found your old XP, the upgrade conditions were met and the install completed successfully, but Vista probably installed it's boot on top of the XP boot to take control.
Your subsequent attempts to fix things with EasyBCD have probably resulted in the strange case of the "system" on an otherwise blank disk.
I too have had an "invisible" Vista which couldn't be repaired (SATA/IDE conflict for me- possibly just the weird state of your flags for you), but temporarily removing the source of conflict allowed Vista to heal itself.
 

Terry60

Knows where his towel is.
Staff member
#12
Are you trying to format it through Vista disk management ? The "system" flag on there will prevent it. (It won't format or change the letter on anything marked system, boot or page).
Get yourself a 3rd party partition manager from somewhere (magazine freebe or Gparted download), and that will do it.
 

Terry60

Knows where his towel is.
Staff member
#15
A full format does take some considerable time on a big disk, but what do you mean by it's disappeared ?
 
#16
It's back again now, thankfully. But basically I used G-Part to partition the HD... but it didn't show me any progress, it just sort of hung. I left it for a while to see what would happen, and when I came back G-Part was sitting there very happily, but the HD I'd asked it to format was gone from its listings.

I'm been having this problem in Vista as well. I'm not sure if it's the HD or my HDD controller now :frowning:
 

Terry60

Knows where his towel is.
Staff member
#17
Check that all the HDD connections are secure (give them a bit of a joggle)
 

mqudsi

Mostly Harmless
Staff member
#18
Have you attempted to restart GParted and see if it'll show up once more? It's very possible that the procedure failed and as a result GParted experienced a glitchy moment wherein the drive was no longer listed.