Win 7 Installed XP - Hangs after XP Copies Files - 1 HDD

#1
So i have windows 7 installed, on one hard drive, and I'm trying to dual boot XP underneath, on the same hard drive. I go through the starting process of the XP install and it copies files after I quick format my 60 gig partition. Once it copies the files it attempts to reboot the PC. Once the PC reboots, it comes up to the DMI section (where the boot partitions/managers usually kick in) and it just hangs up there.

I've repaired with bootsect a couple times now, and have gotten back into Win7 to mess with EasyBCD but to no avail. I've made a default XP boot a couple times underneath the Win7 but ever time I try to use it, it yells at me there is no NTLDR...which i'm not sure if that has anything to do with XP has never finished/started installing since all it done was copied the install files over the the partition I want it to install on.


I'm currently fixing my bootsect again right now...about to go to sleep. The WIKI is down so I couldn't look for small guides to help me out so I came here to ask with hope of answers when i awake!

Thanks!
Hoooo

Addendum:

Woooh, Easy2.0 fixed it. I repaired my bootmanager with "bootsect /nt60 all /mbr", rebooted, ran Easy2.0 and just went to add/remove and added the XP one without changing any settings besides clicking the ADD button. Saved. Rebooted...and now i'm installing the rest of XP.....(I read this explanation in another post, but wanted to clarify what I did for proper problem solving for others)

Addendum:

Oh, and last note. It popped up a suggestion asking me if It wanted to install the NTLDR for legacy versions of windows. I clicked yes...that seemed to help out since the 1.7 didn't ask that option and gave me a ntldr error.
 
Last edited:
#2
Hi Hoooo, welcome to NST.
Yes, 2.0 auto-configures, while 1.7 doesn't (that feature was only add recently, when Guru started pushing out the 2.0 Beta builds).
The auto-configure feature of EasyBCD 2.0 Beta creates NTLDR, NTDETECT.COM and BOOT.INI in the root of the "system" partition (exactly where they should go), and configures boot.ini automatically, so you wont have to.

Glad you solved your problem without our/my help. :smile: