Win 7 on VHD, Vista on HD, No Dual Boot

#1
I have installed Win 7 RC on a VHD on a computer running Vista. When I boot normally, I get no Dual Boot Choice. It boots to Vista. However, if I have the Win 7 installation disk in the computer when booting, I am given a triple boot choice, Windows 7. Windows 7, and Vista Ultimate (recovered).

Someone suggested Easy BCD and I have downloaded 2.0 Beta. It seems to see only Vista and there doesn't seem to be an option to add Win 7.

Any ideas?
 

JustinW

Super Moderator
Staff member
#2
Hi coover, welcome to NST.

You cant manage .vhd entries just yet, but if the timeout is the only thing stopping you, go to change settings to adjust timeout, say to something 5 seconds are greater to give you the chance to choose an entry before the default is automatically selected.

2.0 final well support adding .vhd entries, but not with the current build.
 
#3
Thank you for the welcome.

I wish it was only the time-out. I simply get no dual boot menu (which is set for 3 seconds) at all. Unless I insert the Win 7 installation disk into the computer prior to boot, the computer boots automatically to Vista.
 
#4
Run this command from the Power Console on the Useful Utilities page of EasyBCD:

Code:
bcdedit /set {bootmgr} displaybootmenu yes
and see if you get any menu.
 
#5
Interesting!

When I run it and reboot, i do get a boot menu with only one entry, Vista.

Addendum:

I decided to delete the VHD file and reinstall in the normal manner. After reinstallation, i did not have a dual boot available. Using Easy BCD, i added a second Vista Boot and pointed it to the hard drive where Windows 7 was installed.

I now have dual boot. The first choice is for Vista, and the second choice shows Vista, too. However, if i choose the 2nd choice, i boot to Win 7.

So I am now going to end this topic, and start another on how to edit the name of the boot choice.

Thanks guys, for your help on this one. It isn't exactly solved, but an answer is no longer necessary.
 
Last edited:
#6
So I am now going to end this topic, and start another on how to edit the name of the boot choice.

Thanks guys, for your help on this one. It isn't exactly solved, but an answer is no longer necessary.
No need to start a new topic on this problem. You can change the name of the entry that works for Win 7 in the "Change Settings" section of EasyBCD. Just select the entry in the drop-down menu, and give it a more appropriate name, such as "Win 7", and click "Save Settings". :wink:

Jake
 
Last edited: