Win 7 Ubuntu 12.10 upgrade doesnt boot Ubuntu

#1
I have been running Win7 and Ubuntu 10.4 for some time with Windows boot loader handling the job. Windows is on the bootable disk in volume /dev/sdb1 and Ubuntu resides on a non-bootable disk in volume /dev/sda1. Easy BCD set me up to do this and all was well. I recently upgraded the Ubuntu to 12.4 then 12.10 and it booted fine as before but I wanted to change the label on the options page to match the current version of Ubuntu. I used Easy BCD to delete the old Linux "Ubuntu 10.4" option and just added a new Ubuntu option with the Grub2 setting that I renamed to "Ubuntu 12.10". When I clicked the Windows option on boot up, everything was fine. When I clicked the Ubuntu option, I got the grub> prompt. Knowing this was not correct, I just selected reboot and selected Windors 7 and it booted there with no problem I fired up Easy BCD again and here are the settings shown:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume1
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {871f11f6-4ca5-11de-bfbb-d0ac7ae7be4a}
resumeobject {871f11f5-4ca5-11de-bfbb-d0ac7ae7be4a}
displayorder {871f11f6-4ca5-11de-bfbb-d0ac7ae7be4a}
{03779197-5b8a-11e2-a4a9-00218561dd41}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10

Windows Boot Loader
-------------------
identifier {871f11f6-4ca5-11de-bfbb-d0ac7ae7be4a}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {871f11f7-4ca5-11de-bfbb-d0ac7ae7be4a}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {871f11f5-4ca5-11de-bfbb-d0ac7ae7be4a}
nx OptIn

Real-mode Boot Sector
---------------------
identifier {03779197-5b8a-11e2-a4a9-00218561dd41}
device partition=C:
path \NST\AutoNeoGrub0.mbr
description NeoSmart Linux

I checked in the \NST\ directory and Autoneogrub0.mbr resides there.

How do I get the Ubuntu option to send me to the normal startup?