Win XP + Win 7 Dual boot - No Boot directory?

#1
So, I've been running on Win7 for quite some time. I had it running fluently, without any problems. Today I decided to make a multi boot. Since I already had multiple partitions, I figured I'd install Win XP to one of my existing partitions (C) and just make it a multi boot after that.

Now I can only boot in Win XP though. I tried EasyBCD, but it can't seem to find the Boot directory. Not on my C drive (Marked as system) nor anywhere. I do have all file types set to show, and the same with system files, so I'm really puzzled over why I can't find the boot folder.

The only thing that I can think of is that in some way the folder got deleted.
I'm going to recover my win7 installation now, and see if that can produce some results.
 

mqudsi

Mostly Harmless
Staff member
#2
No, don't do that! Everything might be fine.

Just press cancel on the EasyBCD dialog, then go to Bootloader Setup and write the MBR.
That'll get you into 7, from where you can easily add the XP entry.
 
#3
No, don't do that! Everything might be fine.

Just press cancel on the EasyBCD dialog, then go to Bootloader Setup and write the MBR.
That'll get you into 7, from where you can easily add the XP entry.
Tried that, didn't work.

I used a special recovery only image (also from NeoSmart) to recover the win7 Entry.
Turned out it found a boot error which could be restored. So I restored that, restarted, got into win XP, started EasyBCD, et voila! No error anymore :grinning:

This is how it looks now, after setting it all up. Woot!

There are a total of 2 entries listed in the bootloader.

Default: Windows 7 Ultimate (recovered)
Timeout: 30 seconds
Boot Drive: C:\

Entry #1
Name: Windows 7 Ultimate (recovered)
BCD ID: {default}
Drive: E:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Microsoft Windows XP
BCD ID: {2451947d-9165-11e0-ba27-b24455b03352}
Drive: C:\
Bootloader Path: \NST\ntldr
However, I can't seem to be able to dual boot. After rebooting, my win XP just pops up -_-

Maybe something with boot priority in BIOS... not sure though.

Addendum:

Okay, just an update:
I still can't get into my win7 installation..

Whenever I boot, I get my BIOS.. then a flashing underscore, then BIOS again and then my xp boots. Is there any way to fix this?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
Probably as simple as deleting (in EasyBCD) that entry that says "Recovered" and adding a new Windows 7 entry in its place.
 

mqudsi

Mostly Harmless
Staff member
#6
Good luck.
 
#7
Ok, so that didn't work either.
What I did was once again use the recovery CD. This time I let it reboot again into the recovery thing. Then I set it to fix the boot section. After a restart I set up EasyBCD again and got the boot selection screen. Working like a charm now :smile: