win2k problem - add to existing dual boot

#1
I used EasyBCD to add XP Home to my existing VISTA system. Works great, thanks for the great loader.

I used EASEUS Partition Manager to resize and format the 2 SATA drives as follows:

Partition Type Size Used Unused Ststus Pri/Log
Disk1
C: HP NTFS 194.64 GB 96.35 GB 98.29 GB System Primary
D: XP2009 NTFS 103.44 GB 18.29 GB 85.15 GB None Logical
* Unallocated 10.34 GB 0 bytes 10.34 GB None Logical

Disk2
F: Win2kSrv NTFS 113.67 GB 98.94 MB 113.57 GB None Primary
K: MirrorVsta NTFS 113.67 GB 26.73 GB 86.94 GB None Primary
* Unallocated 238.42 GB 0 bytes 238.42 GB None Logical

F: is just a partiton with nothing on it. K: drive does contain data and I hope to use the remaining space on Disk2 to add Ubuntu later on.

Now I am trying to add Win2k Professional or Win2k Server and here is where the problem arises. When I boot off the Windows2k CD it sees the existing partitions except that it views C: as unrecognizable. When I attempt to format F: it says that it must format C: first.
Writing a boot area to C: is one thing BUT formatting all of C: is not acceptable.

What do you recommend??

Thought about disconnecting Disk1, install Win2k on Disk2, then recoonect Disk1 and repair, then install EasyBCD. Not sure on this....please advise......

Nuttnbutnet
 
#2
Hello nutt, welcome to NST.
I would suggest using a 3rd party partitioning tool (Gparted, for example, which is free) to format the F: partition. I would also suggest disconnecting disk 1 before installing Win 2k so you can be sure the boot files and the boot code get written to its own drive.
And then if you choose to boot from the drive by putting it first in the boot sequence in the BIOS, you will be able to boot Win2k without the need of another bootloader, should you need to.
Once you have down that, then just reconnect disk 1 again, make sure disk 1 is first in the boot sequence in the BIOS, boot into Vista (or XP - either one should work fine). Next, get [thread=642]EasyBCD 2.0 Beta[/thread], re-add the XP entry (you'll see why in a minute), and you'll get a message asking you if you want to let it auto-configure boot.ini for you. Click Yes.
And then you will be able to boot into either XP or Win 2k from the second menu at startup (initiated by selecting the XP entry in the first menu). Just FYI, this is done through the same boot.ini file which will be located in your "system" "active" partition (as seen from Disk Management).

Cheers.

Jake
 
Last edited:
#3
Thanks alot! The only mistake I made was not removing the current XP entry first. I used the beta2.0
It hung when I tried to add the second XP but I still had the Vista boot and was able to correct the situation. Next time I'll interpret "re-add" correctly. Thanks again.

One other thing...... When I select the second option (XP Win2k) off the primary boot menu the new submenu reads:
Windows XP on D:\
Windows XP on F:\

The fist entry is XP and the second entry is Win2kSrv. Can something be edited so the second entry reads ...... Windows 2k Server on F:\ or something close?? It would make the submenu easier to read.

nuttnbutnet
 

Terry60

Knows where his towel is.
Staff member
#4
Edit the boot.ini file on your "system" partition with Wordpad (or similar text editor) (You might need to remove the "read only" flag in properties, and open Wordpad "as administrator" or use theTools/edit legacy entries feature of EasyBCD).
You'll see the 2 lines with the descriptions you posted. Just change the description(s) and leave everything else alone)
You should also be able to use msconfig (boot tab) from one of the NT systems.