WIN7 and UBUNTU 11.04 beta

#1
Hi. I've searched in the forums and can't find a solution.

I am unable to boot into ubuntu. I've followed instructions in the documentation. My Ubuntu 11.04 was installed today under the same hard drive with 3 partitions set: '/' set to (something)4 not 3 with primary selected, '/home' set to (something)4 as well, and swap. I didn't specify anything between grub lilo or grub2 so I'm assuming grub or grub2 is the way to go in EasyBCD.
I've added a Linux entry under grub and selected the partition with root '/' and wrote to MBR with 7 bootloader. When I restart and select Ubuntu (what I named the linux entry), I get a black screen with flashing cursor at the top (assuming a problem in booting). I've tried GRUB 2, but when I boot linux I only get GRUB4DOS with the prompt 'GRUB >'.

I can't figure out what to do. Do you think it's a problem with my Linux install? Should I try NeoGrub (can't figure out what to write into the boot file in notepad)?

Thanks in advance. You guys are great for supplying this program and its support.
 

mqudsi

Mostly Harmless
Staff member
#2
Sounds like GRUB wasn't even installed by Ubuntu. You may have run into a bug in Ubuntu 11 beta. Are you by any chance using a non-standard linux filesystem (to Ubuntu, anything other than extfs is non-standard)?
 
#3
EXT4. Is that the filesystem? Anyway, I assumed a bug with 11.04 beta, as upon reinstalling I noticed a recurring error every time I attempted to install Ubuntu.

I downloaded Ubuntu 10.10, installed, and everything ran smoothly from start to finish.

Conclusion: Possibly a bug in 11.04 installation, will avoid it until non-beta release. Thank you for your concern.
 

mqudsi

Mostly Harmless
Staff member
#4
Glad to hear you sorted things out. Ubuntu's been notoriously buggy when it comes to bootloader issues.
 

Pree

New Member
#5
Issue occurring in Fedora 14 too

I have an install of Fedora 14 running along with win7. MBR is win7 specific, and I have one entry for linux configured using EasyBCD. When I attempt to boot into Fedora using easyBCD, all I get is a blank screen with a cursor blinking on the top. I have tried to create a separate NeoGrub bootloader with entries from the grub menu.lst that I retrieved using the Fedora live cd. This returned with an error stating that it could not mount the specific volume. I have edited the entry and tried multiple partitions ((hd0,0) (hd0,1) etc) to ensure that I am not trying to boot the wrong partition.

Bootpart on the console returns the following:

Physical number of disk 0 : ec73648
0 : C:* type=7 (HPFS/NTFS), size= 102400 KB, Lba Pos=2048
1 : C: type=7 (HPFS/NTFS), size= 283482112 KB, Lba Pos=206848
2 : C: type=83 (Linux native), size= 199681024 KB, Lba Pos=567171072
3 : C: type=5 (Extended), size= 5120000 KB, Lba Pos=966533120
4 : C: type=82 (Linux swap), size= 5118976 KB, Lba Pos=966535168

Any help would be greatly appreciated!

Thank you!
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#6
Is Fedora 14 GRUB or GRUB2?