Win7: BOOTMGR is missing, and can't detect OS when selecting OS to repair



I en
countered this problem after I attempted to change my partition's free space to unallocated space, using Partition Magic. I realised only now that it is not working anymore, but it's too late. :rage:

I am using a HP Pavilion dv4. The Factory OS is Windows Vista, but I upgraded it to Windows 7 about 1.5 years ago, and it's been working fine. After the darned incident above, my laptop had missing drives. I tried rebooting to see if it would restore the drives, but apparently, I started receiving the message "BOOTMGR is missing".

I've searched online trying to resolve this problem, and it seems that the Windows 7 Installation CD was highly recommended to solve this issue. I used the CD to try and repair, but apparently there was no OS listed. I tried clicking Next anyway, and attempted to Auto Repair. Unfortunately for me, it didn't work.

I read up on this page:, and tried working on the 3 methods. It all didn't work for me.

For option 2, while attempting to bootrec /rebuildbcd, it prompts an Add installation to boot list? Yes(Y)/No(N)/All(A): message. Whichever choice I entered, it ended up with The system cannot find the path specified.

For option 3, nuclear holocaust, I got stuck at
bcdedit.exe /import c:\boot\bcd.temp which resulted The store import operation has failed. The system cannot find the path specified.

I am really confused now on what I should do. Anyone has any idea how to resolve this?!?! Help is very much appreciated!! Thanks in advance!!
Last edited:
If you have multiple HDDs, disconnect the others and try the "startup repair" again.
I disconnected all my USBs, except for my mouse.

while using Startup Repair, I got this: Startup Repair cannot repair this computer automatically and recommends that I send information about this problem.
Upon showing the problem, the Problem Event Name is StartupRepairOffline (not sure if this helps).

After sending, another window shows it's loading for a bit, and then it disappears without any other feedback. I then Viewed diagnostics and repair details and saw this:

Root cause found:
System volume on disk is corrupt.

Repair action: File system repair (chkdsk)
Result: Failed. Error code = 0x3
Time taken = 0 ms


I then click on Finish and restarted my laptop, but the problem still exists :x

*Note: My OS was still not detected, and I clicked on Next without selecting any OS.
That error message is saying that the partitions are messed up. You need to either do a factory reset on the laptop or reinstall Windows yourself. A startup repair will not fix this issue for you.
I can't boot up my laptop at all because the BOOTMGR is missing - does that mean there's no other way I can reinstall my Windows?

I still wish to try and save my 2 of my drives that can't be detected or accessed. I heard a software TestDisk is able to restore it. I need the files inside.
will loading the right driver list my OS? maybe the nuclear holocaust method will be able to save it then. if so, how do I know which driver to load?

this is ridiculous; Partition Magic screwed up my whole laptop! :rage:
Check which partition is marked "active"
Maybe the flag got moved or deleted when you were doing things with Partition Magic.
Either W7 (or a small partition named "System Reserved" depending on how you installed W7) should be active for the repair to locate it.
You should be able to access factory reset with F11 at power-up on HP (iirc), which will take you back to Vista most likely, and then re-upgrade to W7 (if the HDD is truly borked).
Rescue user data first
Use Ubuntu Live CD to Backup Files from Your Dead Windows Computer - How-To Geek
how do I check if it's marked active? I can't get to the desktop, so there's very limited stuff I can do.

I tried creating a Windows 7 System Repair Disc from my brother's laptop, and booted it on my laptop. currently, I am able to select a restore point, but it does not allow me to select the C: Drive. It reads You must enable System Protection on this drive. Is there any way to enable it using only command prompt? because I can't access the desktop at all.

Thank you guys for your answers, by the way, I really appreciate them.


just an update:
I followed the steps listed here -

after modifying the registry it's still not working. I see many people's problem was solved using that method but mine wasn't. I hope I wasn't doing something wrong there... is the .bak files supposed to be recent in date (24th Feb 2012 on mine)? and those without extension to be pretty old (year 2010 on mine)?

also, I tried using GParted Live. not really sure how to use it, but when it started up, it shows an unallocated space of 298 GB (which is pretty much my whole hard disk's space, I believe), and nothing else. it's as if there isn't any drive that's allocated at all.

I'm now hoping I can do a system restore to before I installed Partition Magic, but I need to resolve the "Enable System Protection on this drive" issue first. any solutions??
Last edited:
I've had problems in the past with GParted not seeing Windows partitions that were visible with other software.
Try the free
Partition Wizard Bootable CD allows user to boot computer directly to manage partition..
That will show you the active partition, and let you reset it if necessary.
If it doesn't find your Windows partition either, then Mak's assessment that your HDD is screwed and you need to factory reset looks pretty much on the money.
You can try
TestDisk Download - CGSecurity
to find and "undelete" partitions.
If that doesn't help, then it's time to factory reset the PC.
once again, thank you for your answers. I can imagine how hard it is to try to help us when you can't physically see the thing.

I tried the TestDisk; it seems to have recovered my lost drives, and the "BOOTMGR is missing" message no longer shows up. However, after the "Starting Windows" screen, it auto-restarts before it could reach the desktop. it keeps repeating, so right now I still can't boot up properly.

got this message now while performing Startup Repair:

Root cause found:
Failure while setup is in progress.


any idea what's causing this? in the meantime, I'll still be trying to recover. thanks again for the support!
Last edited:
Tap F8 repeatedly after the BIOS splash screen to access the extended boot menu, and then select the "no automatic restart" option.
The BSOD should then wait with the stop code visible instead of looping continuously.
Keep trying. If you are back in contact with the boot manager, it has an extended boot menu, but reaching it is a matter of interrupting the program at precisely the correct moment. Keep tapping.
alright, did what you told me to, here's the BSOD message:

STOP: c000021a {Fatal System Error}
The initial session process or system process terminated unexpectedly with a status of 0x00000000 (0xc0000001 0x00100848).
The system has been shut down.
Yet more evidence that your HDD is fatally compromised.
You're in the situation that I had last year with Vista, when it failed on a 100% good HDD when it wasn't even booted. I went down the chkdsk -Testdisk- repair route and identified various corrupt modules that prevented the kernel from loading (as yours won't).
I did it, over a period of weeks, (Vista is unimportant to me, so it was just an academic exercise in attempted rescue in spare moments between using W7) but every time I fixed one problem, it led inevitably to a new failure further down the long long chain of events which are ultimately supposed to result in a usable desktop.
Time to cut your losses, rescue your user files from the partition Testdisk restored for you, and start the factory reset.
I ended up reinstalling Windows 7 after I managed to recover the disk using TestDisk. Had to reinstall my programs, so it was kinda like a reformat.

it's up and running now. thank you so much for your support! :grinning:
Best of luck.
Sorry I wasn't much help, but sometimes things are just too messed up for anything short of a complete reinstall.
Hey everyone, not trying to zombify the thread (or am I?) :smile: I've ran in to this problem recently, as well have many others from other forums though no one has posted up a proper fix for it - so I figured that I would, in hopes that it'll help others in the future. :smile:


Root cause of Problem :

Partition magic v8.0.5 (?) 'found errors' on a HDD (which was from my laptop Win 7 32-bit) that I put into my desktop (Win 7 64-bit), which I allowed partition magic to 'fix' the errors. I was testing this software, and had allowed for Windows 7 to report itself as XP SP3 for 'compatibility' - it was my monkeying that caused this.

Symptoms :

Both computers would no longer boot up properly.
The Win 7 64-bit desktop had an error in regards to the boot configuration.
The Win 7 32-bit lappy would fail all boots stating that 'bootmgr' cannot be found.

Understanding :

Partition magic, as well as some other older partition utilities, feel that perfectly working Windows 7 / Vista partitions have various errors, when in-fact these dated softwares are basing this finding on older architecture. It's more maledictive than benedictive to try to use these older, though well designed [for their generation] utilities. But regardless, myself and others will time-to-time get stupid and do something that we shouldn't.

The Fixes :

Win 7 64-bit was quite simple, it only required the default 'repair start-up' functionality which replaced the boot manger.

Win 7 32-bit, on the other hand, was a bit more painful. :/ Various partition utilities would either report that it had no partition, or that there was a corrupted partition; either way, I could never mount the volume to attempt to run Chkdsk, bootrec nor start-up repair.

I tested out Partition Wizard, my first time hearing of this software and I cannot say enough praise for it. Where Ghost, Partition Magic, Easeus, Win 7 repair and install, and diskpart failed in their ability to grant me any access to to either the partition or volume, Partition Magic [bootable .iso, which has its own Linux kernel] allowed me to move forward.

I was able to run a Partition Recovery Wizard, which scanned the 'unallocated partition' of the disc and it found multiple partition records to recover. I selected one, and it prompted me twice to tell me that recovering the partition would delete all of the data. Data loss was no concern for me, as this was more to solve this problem which many others have had. I then also resized the partition - which forces the partition data to be re-written with fresh data. I did that just-in-case a bad sector was hanging there, or somehow the data had gotten corrupted there.

I applied the changes [4 operations to do], and with in 10 seconds it was done. I tossed a name on the volume, set it to active and rebooted the machine.

Windows 7 still didn't boot up properly, and complained about the bootmgr missing.

I ran the start-up recovery CD and it came back with a response that 'windows has found errors on the drive, and has attempted a fix.. rebooting'. Good news, as NOTHING had seen neither the partition nor volume before. Progress.

I rebooted the machine again, windows attempted to start then went straight to a BSOD. Great, more progress!

I went into the startup recovery tool for the third time and told it to automatically fix startup errors. It found one, and the resulting error was BCD. It fixed it, rebooted and then windows mostly loaded before it bombed out - again. This is good though, as each step is getting it closer and closer.

The fourth time in start-up recovery would prove to be the last. I dropped to the command prompt and had a proper C: mounted to the proper boot volume - something that I had not had up until the last step. I ran Chkdsk /r and it found and recovered a LOT of orphaned files, corrected errors in 'index $I30' and deleted a lot of index entries.

Whatever partition magic 'fixed' had nearly fubar'd everything. If I hadn't had done this process, then the volume would have not been accessible and data recovery wouldn't have been feasible. So deleting all of the partitions with fdisk and then placing a fresh install or image of Windows 7 would have otherwise been the only way to 'fix' it; not good enough for me. :smile:

I realize that this thread is old, as are all of the other easily found ones on the Interwebs which bring up this issue. I do hope that others can find this useful and are able to follow my progress and also be able to recover their Windows 7 back to working order.

P.s., if you need to download a StartUp Repair image, make sure you get it for either 32-bit or 64-bit - which ever your O/S is. The command prompt utilities will mostly work back-and-forth; however, other components which are necessary for booting are specific to their respective kernel.
Last edited:

I've encountered the same issue.
After using successfully EASYBCD on my laptop in order to create a dual boot, I decided to return to the original situation by using the function "Restore" offered within EASYBCD.
Big mistake ! After that, I was unable to boot my Windows 7 again.
I've been heavily surfing on the net hoping to find some useful tutorials that could be helpful.
I found Recovering the Windows Bootloader from the DVD - EasyBCD - NeoSmart Technologies Wiki.
I tried all of the 3 options exposed on this page. Options 1 and 2 didn't help at all.
I then tried option 3 (Nuclear Holocaust), but when I entered <bcdedit.exe /import c:\boot\bcd.temp>, I've got the message "The store import operation has failed. The system cannot find the path specified", which is extremely frustrating.
I am sure that the solution is at hand. But I don't know how to reach it.

In the mean time, I'm using my laptop with Linux based on a USB pen drive. So, I can access all my data. That's not the issue.
The point is that some important software only works with Windows. So, I really need to boot Windows 7 again.


"Restore" ??
Are you referring to the backup/restore of the BCD contents ?
That won't help you remove a dual boot, just refresh the BCD if you've managed to bork it (and had the presence of mind to back it up before you started playing).
Stage one of the "repair from DVD", is normally all you need (3 times), but it may have problems if you have multiple HDDs (disconnect the others temporarily while you repair) or if you've somehow managed to reset the "active" flag to the wrong place on the W7 HDD.
It's telling the MBR where the boot files are, so check where it's pointing. (linux gparted will call the "active" partition "boot", don't get the terms confused)
Windows uses the expressions quite differently"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"