Win7 doesn't start after upgrading Ubuntu 10.4


I have a laptop with Windows 7 starter preinstalled. I installed Ubuntu 9.10 and all worked fine. Windows 7 and Ubuntu in dual boot. When I upgrade to Ubuntu 10.4 LTS. I can't start with windows 7. I have tried fixmbr, etc, and nothing. After rebuilding mbr the screen is black with only a cursor in it. So I reinstalled GRUB and can use Ubuntu without problem, but cannot get Windows 7 to start again. I have downloaded your NeoSmart Win7 recovery disk, but nothing.

In your instructions to rebuild you use the command
\boot\bootsect.exe /nt60 all /force
but when I use the Win7 restore disks from toshiba, i don't get bootsec.exe, also not get the boot directory but I can see the file Wbootseq.exe. Is this the file insteda of bootsect.exe.

I have also found that wbootseq.exe is a malware, but it comes from a new CD from Toshiba. So I don't think is virus or so.

I really need to reboot from windows 7 and don't want to loose the software installed there so please help me around.

Yes I have tried with this CD Win7 recovery disk, but after i have done all the steps, still I get the black screen with blinking cursor and that is all. Here is what I have done:

Load with the recovery CD
Go to comand prompt
x:\windows\system32>bootrec.exe /fixmbr
The operation completed successfully
X:\windows\system32>bootsect.exe /nt60 C: /mbr
Target volumes will be updated with BOOTMGR compatible bootcode
C: <\\?\Volume{bcecbb4a-613b-11df-8f39-806e6f6e6963}>
Successfully updated NTFS filesystem bootcode.
Successfully updated disk bootcode.
Bootcode was successfully updated on all targeted volumes.
Then I try to rebuild the BCD in the guide stets del c:\boot\bcd
but there is no bcd file in c:\boot so i thought has no importance this command. I went to the next command bootrec.exe /rebuildbcd
x:\windows\system32>bootrec.exe /rebuildbcd
Scanning all disks for Windows installations
Please wait, since this may take a while...
Successfully scanned windows installations
Total identified Windows installations: 0
The operation completed successfully
The problem is that the Windows installations were not found
But I can see the windows directory in C:
Well What can i do to rebuild my Windows?

Thank you