Windows 7 64 bit wont start

Hi all

Acer Aspire 4820T running Win 7 64 bit.

Started running very slow and after a restart it failed to load the operating system. Just sits on Starting Windows for ever.

Unable to launch Safe Mode as the timer just spins once selected.

Unable to recover from Acer Recovery partition or from Windows 7 DVD - again timer just spins forever.

Purchased Windows 7 Recovery CD and when selecting Auto Fix and continue the timer span all night with no advance.

I have managed to navigate file structure via the File Manager tool and copy data off onto USB.

Have been looking at Test Disk which is finding all partitions and providing no obvious errors, but when rebooted afterwards, the same occurs - hangs trying to load Windows then auto restarts and loads the Windows Recovery which sits on a blank Windows 7 screen.

Unfortunately the licence key is worn on the underside and i never took a photo of it.

My first goal is to get laptop booted as it seems all data is viable.

If not, the second goal is to recover my licence key from the registry so that i can attempt a full rebuild.

Any help/advice appreciated.



Knows where his towel is.
Staff member
Have you used F8 Extended boot menu and selected "No automatic restart" ?
Try that to prevent the reboot on whatever the problem is, and it should stop with an error code which can be investigated to determine the root of the problem.
Hi Terry

Thanks for the advice - ill try tonight when i get home.

Michael sent me the link to the 32 bit recovery disk last night which i left on auto repair all night. This morning it was still spinning. The log shows "No operating system found".

As the data files are on the drive, I assume this is a boot file issue.

Any other ideas?


I have disabled the auto restart and after sitting on "Starting Windows" for about 5 mins, I get a BSOD, with UNMOUNTABLE_BOOT_VOLUME with a STOP code of 0x000000ED (0xFFFFFA80030CECD0, 0xFFFFFFFFC0000185, 0x0000000000000000, 0x0000000000000000)

Thanks for your help



Knows where his towel is.
Staff member
That indicates HDD problems.
Use the command line option from the recovery disc to run chkdsk /r against your W7 partition, and/or the OEM recovery partition if that is set as the "active" partition.
(chkdsk syntax)
Hi Terry

Chkdsk /r = "Chkdsk cannot run because the volume is in use by another process. Chkdsk may run if this volume is dismounted first. ALL OPEN HANDLES TO THIS VOLUME WOULD THEN BE INVALID. Would you like to force a dismount on this volume? (Y/N)"

"Y" = Chkdsk completing in a few seconds with primarily 0 files processed = "Windows has checked the file system and found no problems".

I then done "bootrec /fixboot"

I then also set to check memory on reboot = no problems found.

Launching the OS sat on "Starting windows" for 5 minutes then automatically started trying a "Repair". It has now been on the basic windows 7 plue screen with an enlarged pointer for 5 hours with no HDD activity.

Can anything think of anything else to try?

Is there a DOS based app for extracting my license key from the Registry?

thanks all



Knows where his towel is.
Staff member
Are you sure you were pointing chkdsk at your W7 partition(s) and not at the repair disc.
Use command dir x:\ from the command prompt (x= A-Z) to see what's on each disk letter (as seen from the repair environment) to identify where Windows is
(dir x:\ /a:s) will show the superhidden boot folder)
then when you know exactly which letter to use insert it in the chkdsk command using the syntax in the previous link.
Hi Terry

There are 4 partitions: C 100MB RESERVED, D 12GB PQSERVICE, E 110GB ACER, F 110GB DATA.

I have run CHKDSK /r E:

..... verifying files (stage 1 of 5)

File record segments unreadable intermittently throughout the 13xxxxx to 16xxxx range

.... verifying indexes (stage 2 of 5)

Corrected 4 errors for file 4089 then "An unspecified error occurred"




Each time i run the above CHKDSK command, it seems to be getting further. Now sitting on Stage 4 of 5.

Last edited:

Mak 2.0

Staff member
If you have to repair that many clusters on the drive, then the drive is on its way out and needs to be replaced ASAP. This situation will only get worse until the drive is completely dead and you cant get any of your data off of it. Stop using it right now, buy a new hard drive for the machine and copy the data off of that one before it is too late.
Hi Alex

Thanks for the info

As i stated in my original post, i have already got my data off and am wanting to try and access my licence key as it is rubbed off the silly belly label.

The only way i can see of doing that is to get the thing bootable.


Mak 2.0

Staff member
You mean you didnt copy it down and store it someplace else? Like backing up your personal data? Well good luck. But I wouldnt hold my breath. If it has been 24 hours and it is still repairing clusters, the chances the thing will boot long enough to do anything is a long shot.


Knows where his towel is.
Staff member
The HDD OEM probably has a free diagnostic tool available to download on their website.
Check the HDD with that before you bin it.
I had a copy of Vista on a partition that failed when it hadn't even been in use for several weeks, and I tried every trick known to recover it without reinstalling. At one point chkdsk repaired just about every block. (Don't remember the number but it was huge)
Eventually I had to give up and reinstall, but Vista is still on the same patch of HDD and it checks out as 100% good, no physical problems, and I still have no clue as to what could have gone so wrong with an unused, unaccessed OS, but it wasn't a hardware problem.