Windows 7 and OSX86 Dual Boot w/ EasyBCD 2.0 RC61

#1
I am currently dual booting Windows 7 and OSX86 (the PC version of Mac OS X). My system has two drives installed: one drive is a 160GB dedicated to Windows 7 and the second drive (500GB) is dedicated to Mac OSX86. My goal is to obtain a boot menu that allows me to select between Win7 and OSX86.

Here is the System Profile information for the 500GB disk (which houses Mac OSX86):

WDC WD5000AAKS-22A7B0:

Capacity: 465.76 GB
Model: WDC WD5000AAKS-22A7B0
Revision: 01.03B01
Serial Number: WD-WMASY4517388
Native Command Queuing: Yes
Queue Depth: 32
Removable Media: No
Detachable Drive: No
BSD Name: disk0
Mac OS 9 Drivers: No
Partition Map Type: GPT (GUID Partition Table)
S.M.A.R.T. status: Verified
Volumes:
Mac OSX86:
Capacity: 465.44 GB
Available: 454.02 GB
Writable: Yes
File System: Journaled HFS+
BSD Name: disk0s2
Mount Point: /

Here is the System Profile information for the 160GB Disk (which houses Windows 7):

WDC WD1600JB-00REA0:

Capacity: 149.05 GB
Model: WDC WD1600JB-00REA0
Revision: 20.00K20
Serial Number: WD-WMANM2588780
Removable Media: No
Detachable Drive: No
BSD Name: disk1
Protocol: ATA
Unit Number: 0
Socket Type: Internal
Low Power Polling: No
Mac OS 9 Drivers: No
Partition Map Type: MBR (Master Boot Record)
S.M.A.R.T. status: Verified

I have successfully configured EasyBCD 2.0 RC61 to generate a menu at start-up. The Windows 7 menu selection successfully boots into Windows 7. HOWEVER, when selecting Mac OSX86 from the boot menu, I receive the following response:
Starting cmain() ... (hd0,0)
(hd0,0)
[Multiboot-kludge, loadaddr=0x120200, text-and-data=0xef00, bs=0x0, entry=0x120288]
Multiboot info@0x5ff58
Boot device 0x80
Press any key within 2 seconds to change boot device
Typical boot devices are 80 (First HD), 81 (Second HD)
Enter two-digit hexadecimal boot device:
At this point, if I enter 80, I am cycled back to this screen. If I leave it blank (i.e. default), I am cycled back to this screen. If I enter 81, Mac OSX86 proceeds to boot up. How can I configure EasyBCD to use the hard disk referenced at 81, not 80?
 
Last edited:
#2
I have successfully configured EasyBCD 2.0 RC61 to generate a menu at start-up. The Windows 7 menu selection successfully boots into Windows 7. HOWEVER, when selecting Mac OSX86 from the boot menu, I receive the following response:
At this point, if I enter 80, I am cycled back to this screen. If I leave it blank (i.e. default), I am cycled back to this screen. If I enter 81, Mac OSX86 proceeds to boot up. How can I configure EasyBCD to use the hard disk referenced at 81, not 80?
Hi rbuchmann, welcome to NST.
Unfortunately that is a design feature of the Mac bootloader. Since EasyBCD is only for editing the Vista or Win 7 BCD, which is a part of that bootloader, it can't control what Apple's bootloader does, or alter its behavior. And so consequently, there is no way at this time to change what it does if you're using EFI mode under the Mac tab in EasyBCD's Add/Remove Entries section. You can try using MBR mode, but you'll likely experience the same results.
What happens is when Win 7's bootloader chains to the NeoGrub bootloader, which in turns locates Darwin, and hands over the boot process, Darwin is unable to find itself until you tell it which hard drive its on. Don't know why Apple designed their bootloader that way, but apparently they wanted to add a few extra seconds to the boot when multibooting, using a non-Darwin bootloader as primary. :brows: I guess they want you to have OS X's bootloader take over the boot, instead of Win 7's.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#3
We're working on a possible workaround.. keep your eyes open for new beta builds that may address this issue.
 
#5
Me too,

Installed in this order. xp, server 2008 (aka vista), windows 7, wubi / ubuntu (from windows 7), and now just installed OSX mac.

Now the darwin mac osx boot loader has taken over.

If we press anykey during boot (5 second window) we can boot up into windows 7 or xp or server 2008, but it seems that my ubuntu / wubi is missing from the darwin boot list.

I would like to use the beta version of easy bcd, and restore the windows easybcd boot menu, as it does show the ubuntu wubi boot option.

Will this work with mac osx, and what option should i use MBR or EFI for the osx selection?

does it work corectly ?
 
#6
Me too,

Installed in this order. xp, server 2008 (aka vista), windows 7, wubi / ubuntu (from windows 7), and now just installed OSX mac.

Now the darwin mac osx boot loader has taken over.

If we press anykey during boot (5 second window) we can boot up into windows 7 or xp or server 2008, but it seems that my ubuntu / wubi is missing from the darwin boot list.

I would like to use the beta version of easy bcd, and restore the windows easybcd boot menu, as it does show the ubuntu wubi boot option.

Will this work with mac osx, and what option should i use MBR or EFI for the osx selection?

does it work corectly ?
Hello fnakfhe, welcome to NST.
Yes, you can use [thread=642]EasyBCD 2.0 beta[/thread] to restore the Win 7 MBR, and put the bootmgr/BCD back in control of the boot. Just open up EasyBCD, go to the Manage Bootloader page, make sure the "Reinstall the Vista bootloader" option is selected, and then click on Write MBR. This will put Win 7 back in charge of the boot, and you can use it to add a Ubuntu entry, and also one for OS X, to your BCD. You should use EFI mode.
 
#7
Thank you for the warm welcome,

Its great to be here at NST.

for the ubuntu entry, it is NOT on a partion on its owne, wubi uses a folder on your os hard disk drive to save some kind of image format of the ubuntu disk, so its relly a 'iso' if you will of ubuntu. it shows up fine with the windows boot menu, but darwin does not show it at all.

I just installed osx (but darwin has taken over). so we do not see the windows 7 boot loader, we see darwin.

so, darwin gives me 5 sedconds to press anykey or elese osx will boot up, BUT if i do press any key i see the darwin options of xp server 2008 and windows 7 (no ubuntu, wubui) i dont know why but darwin does not show me ubuntu (useing wubi)

when i select windows 7 from the darwin boot menu,the boot sequence gets handed off to my windows boot menu with my windows xp 7 and 2008 and ubuntu,


so i am in windows 7 now and when i load easybcd i get,

EasyBCD is unable to access the BCD store.

Problem Details:
The boot configuration data store could not be opened.


My first guess is this is happening cuz my vista boot loader is not in charge anymore, and darwin is not suported by easybcd that is why it does not access the bcd store..

So, i will need to use the windows 7 dvd installation disk to repair my boot loader right?

and after i repair my windows 7 boot loader to take bac control then i will not have the darwin boot menu any more right?

i am woried i will lose the osx boot.

any idea ??

also, why do you say i should use efi and not the other option?

I am useing a netbook 1000HE for all this from Asus.

thank you kindly for the help.
 
Last edited:
#8
Ok, I don't know why EasyBCD is doing that, but yes, you should be able to put Win 7's bootloader back in charge of the boot by running Startup Repair from the DVD 2-3 times (since it can only fix one thing per pass). And no, don't worry about losing the ability to boot into OS X afterwards. EasyBCD will probably open after you restore the Win 7 MBR, and you can use it to add an OS X entry to the Win 7 BCD, and it should work. :wink:

Cheers.

Jake

Addendum:

for the ubuntu entry, it is NOT on a partion on its owne, wubi uses a folder on your os hard disk drive to save some kind of image format of the ubuntu disk, so its relly a 'iso' if you will of ubuntu. it shows up fine with the windows boot menu, but darwin does not show it at all.
Yeah, don't worry about that. Your Wubi entry no doubt still exists in the Win 7 BCD, and even if it doesn't, EasyBCD supports Wubi too. :smile:
And the Wubi image file (which functions as a real ext3 partition) is called a "root.disk".
 
Last edited:
#9
Ok, so let me try to understand you. :smile:

I will put in my windows 7 boot disk and have it repair my boot menu, and i will do this pass about 2-3 times to fully restore my boot menu ?

then when my boot menu is restored fully i will use easybcd 2.0 beta 6? to add osx?


BUG WITH BETA: i used easybcd 1.7.2 in windows xp and it asked me Yes or No, to restore my boot record. somthing about it not haveing a valid boot record, i did this in windows xp while darwin was in control of boot. this is good that easybcd 1.7.2 is able to attempt to fix my boot.

However, with the beta version, it does not have any such YES or NO quetsion, it just says can not open your BCD store, then OK to exit. see file attached.

see the attached piture for both.
 

Attachments

Last edited:
#10
Ok, so let me try to understand you. :smile:

I will put in my windows 7 boot disk and have it repair my boot menu, and i will do this pass about 2-3 times to fully restore my boot menu ?
Yes, you need to do that to put Win 7 back in charge of the boot.
then when my boot menu is restored fully i will use easybcd 2.0 beta 6? to add osx?
Correct.
BUG WITH BETA: i used easybcd 1.7.2 in windows xp and it asked me Yes or No, to restore my boot record. somthing about it not haveing a valid boot record, i did this in windows xp while darwin was in control of boot. this is good that easybcd 1.7.2 is able to attempt to fix my boot.

However, with the beta version, it does not have any such YES or NO quetsion, it just says can not open your BCD store, then OK to exit. see file attached.

see the attached piture for both.
I believe that problem will be fixed after running Startup Repair 2-3 times from Win 7 dvd...
 
#11
I just tryed to use windows 7 dvd to repair the boot record, and it gave me an error saying the system disk is not working somthing about chkdsk.

So i restarted the computer and when the darwin boot loader showed i pressed any key, then i selected windows 7 to boot up, then i ran chkdsk on windows 7 partition, and it was fine. nothing is wrong.

I am thinking that the windows 7 repair dvd is checking the partition of the boot loader which is darwin on the osx drive, and it is partition that is Journeled as osx requires, so maybe that is why it thinks the windows 7 partition is curopted, when it is not. it is just reading the osx journeled partition and thing its windows 7 but its relly the osx. i think, i dont know.


Humm... i would like to use the beta version of easybcd to restore the bootloader for windows 7, but i dont want to lose my osx boot, and only the easybcd v 1.7.2 is allowing me to restore my windows boot menu.

last time what i did to fix the stupid windows 7 dvd not being able to fix my boot record was to just reinstall windows 7 all together.

what do you think?
 
Last edited:
#12
Ahh...I have an idea what is wrong. Boot into Win 7 from the OS X bootloader, open up Disk Management, and find out which partition is marked as "active". I have a hunch it will be the OS X partition...
So select the partition that is marked as "system" (probably your Win 7 partition, but not necessarily), right-click on it, and hit "Mark partition as active".
This should fix the problem, and allow you to both open up EasyBCD, and also put Win 7 back in charge of the boot by running Startup Repair.
 
#13
Ok,

heheh, i think you are right on this one.

I am now going to do this, give me a few min, about 10 - 15. its a slow 1000he netboot from asus. i will brb going to do this now.

thank you.
 
#14
Is your OS X on the same physical HDD as Win 7, or are they on separate drives?
If they're on separate HDDs, then nevermind my earlier advice. You will need to put your Win 7 drive first in the boot sequence of the BIOS instead of the OS X drive.
 
#15
They are on the same drive,

I have 4 partitions, xp, server 2008, windows 7, osx.

and the ubuntu wubi installer is on the windows 7 partition.


Ok, i did what you said, i went into windows 7 disk manager and marked the windows 7 partition as active. (osx was active)

now, when i reboot i get only the windows 7 boot menu.

so i loaded windows 7 and used easybcd beta and added osx with the default setting of efi, and it worked!

cool, now im useing the windows 7 boot menu to load osx.

however, why do i see:

boot: ??? i forget what it says
boot: 0


why does that show?? it looks like its NOT windows 7 boot menu but somthing from the darwin menu.

any idea?

BTW: thank you for all the help man.
 
#16
Glad you got it working. :smile:
As for the screen you mentioned, does it say something like the following?

Starting cmain() ... (hd0,0)
(hd0,0)
[Multiboot-kludge, loadaddr=0x120200, text-and-data=0xef00, bs=0x0, entry=0x120288]
Multiboot info@0x5ff58
Boot device 0x80
Press any key within 2 seconds to change boot device
Typical boot devices are 80 (First HD), 81 (Second HD)
Enter two-digit hexadecimal boot device:
If so, that is the behavior of the OS X bootloader, and there is no way currently to change it, though as CG mentioned in the third post of this thread, he's working on a workaround for this issue. And anyway, since your OS X is on the boot drive (i.e drive 80), then that shouldn't be very much of an annoyance for you, since the default is drive 80, and so you will not have to select a different hard drive. :wink:

Cheers!

Jake
 
#17
I have the same problem as rbuchmann,
as he mentioned, if he enters 81, he's OSX boots up but when I enter 81 its saying "Calling chainboot.. (or chainbootloader, I forgot)", and PC freezes.

any tips?
 
#18
I have the same problem as rbuchmann,
as he mentioned, if he enters 81, he's OSX boots up but when I enter 81 its saying "Calling chainboot.. (or chainbootloader, I forgot)", and PC freezes.

any tips?
Hello GmbH, welcome to NST.
I'm assuming your OS X is located on the second HDD in your BIOS boot sequence? If not, then it wouldn't be 81...
 
#19
jah, it was my fault! OSX is located on the first(MAIN) hdd and that is 80, so entering 80 digits it leads me to this:

and when i choose disk0s3 (MACOSX partition) it goes here:

and

and all over and over.
 
Last edited:
#20
Please use the Insert Image feature in the new post area, instead of linking to external sites, because images are easier to view that way.