Windows 7 and Ubuntu 9.10

#1
Hi guys, I have tried to sort this out myself by reading the Forum but I am still struggling.

I have Windows 7 and Ubuntu 9.10
, I get the option to boot into either 3 or 4 versions of Ubuntu then Windows Vista at the bottom (even though its Windows 7) when the Laptop is booting up.

When I load up Easy BCD it only seem to see Windows 7 in the add/remove entries?

How can I remove the other versions of Ubuntu for the Boot.ini so I just have the 9.10 version and how do I change the Windows name to 7 from Vista?

Is this something to do with the GRUB?
 

mqudsi

Mostly Harmless
Staff member
#2
I think you're referring to the GRUB boot menu and not the EasyBCD one.

In Ubuntu, open the grub config file, and remove the Windows-related entries.
 
#3
Yeah, it sounds like you're talking about the /boot/grub/menu.lst file on your Ubuntu partition. You will need to modify as root user:

sudo gedit /boot/grub/menu.lst
(type password)
 

mqudsi

Mostly Harmless
Staff member
#4
Jake, do you know for sure that Ubuntu KK w/ GRUB2 also uses that same file?

I wasn't sure, so I abstained from mentioning it.
 
#5
Jake, do you know for sure that Ubuntu KK w/ GRUB2 also uses that same file?

I wasn't sure, so I abstained from mentioning it.
Oh, sorry. I guess not.
I assumed it did, but it turns out it uses a grub.cfg file instead of the menu.lst which is automatically generated from scripts, so if you edit it, it gets overwritten frequently.

My bad...
 

mqudsi

Mostly Harmless
Staff member
#6
No, you can ignore the warning about it being overwritten. That only takes place when GRUB is upgraded.

Can you post the full path to the config file so that baldtechie can edit it?
 
#7
Ok, according to this link, the grub.cfg is not actually a configuration file. Its instead a bash-like script executed by the grub2 bootloader. The various instructions are either built-in, or implemented as external modules, which has to be loaded before use. It says you should not modify grub.cfg directly.

The file path seems to be boot/grub/grub.cfg.

It seems you can use the utility grub-mkconfig to create a grub.cfg for you. It is unclear at this point what you're supposed to use to edit it...I don't think you can use a regular text editor on it, since its a bash-like script, and will be in machine code, I believe.

I will continue reading up on it.
 
#8
Morning guys, :smile:

OK, sounds to me like its getting quite complex?

So why hassent my Laptop recognised in the boot list on startup that its Windows 7 and not Vista, but Easy BCD can see its windows 7?

There must be a Boot list somewhere because it gives me x4 options for Ubuntu and x1 for Windows, how come Easy BCD cannot see that Boot list?

Addendum:

My Boot up options - Its says vista as the last option when its Windows 7 Installed? Do I have to change the Boot up options in Ubuntu to get rid of the other x4 options avaiable to leave me with x1 Ubuntu selection?



 
Last edited:

Terry60

Knows where his towel is.
Staff member
#9
EasyBCD is looking at the W7 BCD.
That menu is nothing to do with W7 - It's grub's menu from Linux
Linux is controlling your boot, not W7
If you want W7 to control the boot -

Choose W7 from the grub menu
Run EasyBCD 2.0 latest build
Manage Bootloader - Reinstall Windows Vista/7 bootloader - Write MBR
Add remove entries - Linux Tab - select grub2 from the dropdown - "add entry"
 
#10
Timeout = 0

"Do I have to change the Boot up options in Ubuntu to get rid of the other x4 options avaiable to leave me with x1 Ubuntu selection?"


just edit timeout option - set it to 0 and it gives you "invisible" Grub.



Kari
 

mqudsi

Mostly Harmless
Staff member
#11
Terry, even if he did that, EasyBCD would call upon the GRUB2 bootloader which would then show its own menu with its 3 Ubuntu entries... The only solution is to either use EasyBCD + NeoGrub (and no GRUB or GRUB2 in the mix) or to edit the GRUB2 menu to either remove the 3 extra entries or to set the timeout to 0 thus skipping the selection screen and booting into Ubuntu directly.
 
#12
Maybe he could downgrade to Grub 1. Then, at least he could edit the menu.lst. Would that work with Ubuntu 9.10, or is it essential to use Grub2?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#13
Jake, you can edit the grub.cfg file directly. I just did it on my Ubuntu in a VM.
 
#14
Really? Hmm...interesting.
That site I linked to earlier said not to.

What did you use to edit it?
 
#16
Ok, then. :smile:
@baldtechie: Open the Applications>Accessories>Terminal from Ubuntu, type:

sudo gedit /boot/grub/grub.cfg

Press Enter. This will open the grub.cfg file. Next, simply find the entries you want to remove, select them, and press Delete. Next, save the file, and you're done.

(Funny how information you find on the Internet isn't always correct...)
 

mqudsi

Mostly Harmless
Staff member
#17
You'll need to run
Code:
sudo chmod 777 /boot/grub/grub.cfg
gksudo gedit /boot/grub/grub.cfg
actually because the file is read-only by default.

I changed the menu to
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
load_env
set default="0"
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,5)
search --no-floppy --fs-uuid --set c34ecc74-ea03-4a00-8949-cc6278a77b2e
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=0
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-11-generic" {
recordfail=1
save_env recordfail
set quiet=1
insmod ext2
set root=(hd0,5)
search --no-floppy --fs-uuid --set c34ecc74-ea03-4a00-8949-cc6278a77b2e
linux /boot/vmlinuz-2.6.31-11-generic root=UUID=c34ecc74-ea03-4a00-8949-cc6278a77b2e ro quiet splash
initrd /boot/initrd.img-2.6.31-11-generic
}
menuentry "Ubuntu, Linux 2.6.31-11-generic (recovery mode)" {
recordfail=1
save_env recordfail
insmod ext2
set root=(hd0,5)
search --no-floppy --fs-uuid --set c34ecc74-ea03-4a00-8949-cc6278a77b2e
linux /boot/vmlinuz-2.6.31-11-generic root=UUID=c34ecc74-ea03-4a00-8949-cc6278a77b2e ro single
initrd /boot/initrd.img-2.6.31-11-generic
}
### END /etc/grub.d/10_linux ###
And everything worked as expected thereafter.
 

mqudsi

Mostly Harmless
Staff member
#19
Thanks for that info, Gemnoc.

Do as the man says :smile:
 
#20
Disclaimer: I am a relative newbie at this. I struggled through Grub2 config last week. I just repeated what I found on the Ubuntu wiki link. :??