Windows 7 Boot Manager Recovery Problem

#1
Hi, I had Windows 7 Professional 64-bit and OS X 10.6.2 (Vanilla Install using a boot cd) dual boot running on my laptop just fine for the last 2 weeks or so using the Windows Boot Manager which would load Chameleon when OS X was selected. Its important to note that the install method I used made me format my laptop using Disk Utility in OS X dvd to format the drive to GPT then create the partitions within that same utility.

Today I decided to install Ubuntu onto a blank partition on my hard drive using the method found in your Wikipedia (basically tell it to install grub onto its linux partition and not MBR) I've used this method many times in the past and it has worked great for Windows 7 and Linux dual boot. But when I finished the install and went to reboot, expecting to see the Windows boot loader, I got Chameleon, I selected Windows from here and it told me :

File: /boot/bcd

Code: 0xc000000e

And to recover using the Windows DVD. So I put the DVD in (The exact same DVD I used to install Windows 7 in the first place) and it told me that the repair utility was not compatible with this version of windows. So I tried this guide on your wiki: http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD
I tried both manual methods, I had to end up pressing Shift + F10 to open the command line from the Windows DVD. The third errors here: bootrec.exe /rebuildbcd
Saying:

[1] C:\Windows
Add the installation to boot list? Y/N/A Y
The requested system device cannot be found.

The result of bcdedit /enum is:

The boot configuration data store could not be opened.
The requested system device cannot be found.

It does not allow me to set any partition as active because it is a GPT partition table not a MBR table.
The partition table looks like this according to gparted livecd:
/dev/sda1 fat32 EFI 200 MB Boot
/dev/sda2 NTFS (Windows 7)
/dev/sda3 hfs+ (Snow Leopard)
/dev/sda4 ext4 (Ubuntu)
/dev/sda5 linux-swap

I can still use the OS X Live CD to boot into OS X and reinstall Chameleon at any time. I Only ever installed Chameleon to the Snow Leopard partition and let EasyBCD do the rest of the Windows work for me (Which it does a fantastic job)

Any ideas on how to fix this?

Edit: The laptop is a Dell XPS M1530
 
Last edited:
#2
I fixed it myself, after days of googling I found the issue was with the installation of grub writing to the MBR that Windows uses.

To fix it I just used a Ubuntu LiveCD, enabled universe for software sources, then in terminal:
sudo apt-get install gptsync

Once thats done find which hard drive you boot off of using Gparted (Mine was /dev/sda as its the only hard drive I have). In terminal type:
sudo gptsync /dev/sda

and say y (yes). Reboot, and Windows would boot again! (After using Windows DVD to recover the boot loader)

Hope this helps someone
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#3
Thanks for sharing what worked for you, dusty.
 
#4
dusty550: THANK YOU A BILLION TIMES!... You just saved me a complete reinstall! ;-D
I had the exact same problem as you (same OS-setup, too), only after installing the new Ubuntu 11.10 on my Lenovo G560 (pretty much the perfect Hackbook btw!)... your solution worked beautifully, thank you so very much, i just registered on this forum to give you my gratitude! 8)