Windows 7 bootloader issue

nyiss

New Member
#1
Hi,

Ok so I have a Toshiba satellite c660 here which was running windows 7.
When I boot it up now I get the error message 0xc000000f "Windows failed to load because the system registry file is missing or corrupt".

So I made a recovery disk from here and burnt it using imgburn at max speed. I read somewhere that burning it at 4x or under made a difference but I don't know how true that is since its a problem with the bootloader not the disc.

So I changed the BIOS settings to boot from dvd first and tried an automated recovery 3 or 4 times but each one told me that it was a problem that can't be fixed automatically and to remove any USB or media devices attached to the laptop. Since there is none attached I gave up with that and followed the instructions given here.

Starting from option 2 I tried doing a manual repair. It returned as "operation successful" but I still can't boot into windows.

So I tried option 3 and followed everything the the letter and It said all the right things "operation successful" but unfortunatley I still can't get past the error.

Any ideas? any help would be very much appreciated!
 

Terry60

Knows where his towel is.
Staff member
#2
It's not the boot files that need fixing. Your registry is corrupt.
Boot the CD, but instead of using "startup repair", use system restore to take you back to a point in time before the registry failure.
I take it you've already tried "last known good configuration" from the F8 extended boot menu
 

nyiss

New Member
#3
Hi Terry,

Yep, I have tried doing the last known good config but it got me back to the same point.
I have tried a system restore too but I get a message saying to specify which installation to restore, but I cant get back to where I choose the instaltion because the disc now boots straight to recovery essentials and if I click exit it just hangs. Am I missing something really obvious here?
 

mqudsi

Mostly Harmless
Staff member
#4
Have you run chkdsk /f ?
 

nyiss

New Member
#5
I have indeed guru but It returns with
"windows cannot lock current file, windows cannot run disk checking on this volume because it's write protected"

Would it solve your time and mine to do a clean install?

EDIT: Ah sorry I forgot to dismount it after doing something else, running it now

EDIT: finished now with "windows has checked the file system and found no problems. Failed to transfer logged message to the event log with status 50."

EDIT: I got back to the system restore option Terry but there was no restore points found
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
#7
Sorry for getting back to you late, I had to leave the issue for a while to concentrate on something else.

Good news is there is nothing on the laptop that needs to be recovered its fine to loose it all.
now for the rest of it... I tried what you suggested to no luck. I went ahead with a clean install of windows 7, it lags and takes a really long time to complete and when it does it boots to the installation disc instead of the hard drive and loops. So I tried removing the disc in the 10 second warning before the reboot and I get asked to insert the disk and do a repair.

"An error occurred while attempting to read the boot configuration data"

file: \boot\BCD

status: 0xc000000e
 

Terry60

Knows where his towel is.
Staff member
#8
On the reboot(s) don't reply to the "press any key...." message.
That message is highly misleading.
It really means "I have already booted the CD, this is the CD speaking, would you like me to begin the Setup Installation program. If so press any key, otherwise I will continue to the HDD"
The first time, you must press a key and it will begin the install.
On subsequent boots, you ignore the message, it proceeds to try booting the HDD, recognizes that the installation is incomplete and enters the next phase of the install.
If you ignore the message on a fully installed OS, it will recognize a complete OS and just do a normal Windows start.
If you reply to the "press....." message on anything but the first boot of an install, it will start all over again from the very beginning ad infinitum.
 
#9
ahhh thankyou Terry, saved me a whole lot of time there!

Ok so its now finished the clean install and is running Win 7 64bit, its running incredibly slow at the moment though which wasn't an issue before the install. Im hoping its just a driver related problem though so once they are all installed I will go from there.
 
#10
update: unfortunatley the drivers havent made much of a difference its still running very slow. The thing that is throwing me is that the boot up takes ages and then the first time opening everything is very slow but once they have been opened once the same process is very quick, i think I may of overlooked something here but if anybody could point to what it might be i would be very grateful
 

Terry60

Knows where his towel is.
Staff member
#11
Run msconfig and check the startup tab.
Untick all the unnecessary bloat which insists on starting itself at boot.
You can safely get rid of the Quicktime and Java update monitors and probably quite a lot of other stuff too.
Just keep ticked the stuff you actually want to load at boot time.
It's all startable when you want it and will kick in when you first come to use it, but doesn't need to be taking time during boot and occupying resources every second of the day just on the 0.1% offchance that you might want it. These 3rd party vendors have an over-inflated view of their own importance, and an almighty cheek to think that it's alright to make the unilateral decision to run their bloat on your PC in an attempt to make themselves look good by responding a couple of seconds faster on the three occasions a year when you actually use them.
Rant over.
 

Terry60

Knows where his towel is.
Staff member
#13
There must be something in there !
What about your AV, your graphics card controller, the W7 sidebar ??
Have you successfully completed your driver updates ?
Is everything in Device Manager free of yellow exclamation marks ?
 

mqudsi

Mostly Harmless
Staff member
#14
Have a look at Startup Control Panel:
Mike Lin's Home Page

It'll show you all the various these programs can start from. Be sure to run it as an admin as it was written back in the Windows 2000 days.
 
#15
Back to this laptop again -.-

Yep I tried and tried but nothing shows, I can't figure out why this is. All drivers are installed and up to date with no warning signs. thankyou both very much for still helping me with this. I think that the issue is more than just start up programs unfortunatley. I wanted to test something so ran vista on it with the same thing happening and before the install completes I am getting the 0x00000e error message again. So now im running PC cleanup and reimage repair back on windows 7 to see how that goes.
 
#16
Just incase anyone else was having this issue I thought I would come back and let you know how it all ended....badly. After weeks of pulling my hair out it turns out that not only was the hard drive was giving up but the motherboard had been damaged after coke was spilled on it which I wasnt originaly told -.-
Thankyou both so much for all your time and suggestions it was a huge help to me!
 

Terry60

Knows where his towel is.
Staff member
#17
Ah ! if only it had been Pepsi. We might have been able to fix that. (not)
 
#18
hi, help any body
Only windows xp loading after installation of windows xp in my pc in which windows 7 exists . I have opened the boot.ini file , but shows windows xp information only.
can any body help me.?
 

Terry60

Knows where his towel is.
Staff member
#19