Windows 7 Fedora 12 Dual Drive/Boot

#1
I have a thinkpad with Windows 7 on the hard drive and I have an ultrabay hard drive with a SSD containing fedora 12. I want to be able to swap out the SSD for a CD. I have EasyBCD verion 2 beta installed. The system dual boots from grub on the SSD and using the grub menu I can select windows or Fedora. If I select windows then I go to the bcd menu if i select linux I am straight to fedora. When I put in my ultrabay CD drive the system will not boot and hangs with a blinking curser. I have Windows drive first in my boot order Apparently it will only boot from the SSD I have tried several settings and I can't change it . Any suggestions?
 

Terry60

Knows where his towel is.
Staff member
#2
You are booting from grub on the SSD ? then choosing W7, getting to the BCD and then selecting Linux ?
Why are you not choosing Linux directly from grub ?
Was W7 pre-installed or did you install it ?
If the latter, did the W7 boot files install on the W7 partition ? (i.e. which partition is marked "system" in Disk Management).
If W7 is not "system", then you can use "BCD install/Repair" "Change boot drive" to copy the W7 boot files to the HDD, then boot with the HDD first in the BIOS sequence.
If you are not sure what to do, post Disk Management and "view settings" (debug mode) information as described at the end of the sticky thread.
 
Last edited:
#3
Windows 7 Fedora 12 more info

Windows 7 was installed first then I installed fedora to the SSD from a live disk I had it setup then installed Easy bcd. I go straight to linux from grub with no problem I only see BCD after grub when I select windows. Nothing in my setup involving changing the order helps. A diagnostic dump follows:

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
extendedinput           Yes
default                 {36c17d38-cf4a-11de-815e-dc9cef5b2026}
resumeobject            {36c17d37-cf4a-11de-815e-dc9cef5b2026}
displayorder            {36c17d38-cf4a-11de-815e-dc9cef5b2026}
                        {36c17d3b-cf4a-11de-815e-dc9cef5b2026}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 30
customactions           0x10000ba000001
                        0x54000001
custom:54000001         {572bcd55-ffa7-11d9-aae0-0007e994107d}

Windows Boot Loader
-------------------
identifier              {36c17d38-cf4a-11de-815e-dc9cef5b2026}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence        {36c17d39-cf4a-11de-815e-dc9cef5b2026}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {36c17d37-cf4a-11de-815e-dc9cef5b2026}
nx                      OptIn

Real-mode Boot Sector
---------------------
identifier              {36c17d3b-cf4a-11de-815e-dc9cef5b2026}
device                  partition=C:
path                    \NST\nst_grub.mbr
description             NeoSmart Linux
 

JustinW

Super Moderator
Staff member
#4
So the problem is not being able to boot when the disc drive is attached regardless of the boot order? If thats the case, how did you manage to install Fedora 12 on the SSD? You may need to update your BIOS, though on some systems thats just the way things are. I've got a Dell for example that well always attempt to boot from the disc drive first when a bootable disc is present regardless of the boot order. You may just haft to leave the disc drive disconnected when you're not using it.
 

Terry60

Knows where his towel is.
Staff member
#5
Disk Management screenshot ?
 
#6
I think the problem is I moved my Boot Sector! I installed Fedora from a flash drive since my CD drive was unavailablle when installing it said something like: Are you sure you want to boot from a non system drive ? (Or something like that) If I remove the SSD Drive I can not boot - which is the problem because I can't use the CD. I checked again and I selected windows from the Fedora GRub and then entered the EasyBBCD screen I selected Neolinux which I assumed would take me back to linux and it said "can not boot from hard drive" - then something in German.

There are options about restoring boot sector but they talk about Vista. I think I need to undo what ever moved the boot sector when installing Fedora Grub and get it back to Windows 7 so easybcd can take control
Not sure what disk management screen is?
 

Terry60

Knows where his towel is.
Staff member
#7
Control Panel / Admin Tools / Computer Management / Disk Management
(or right click "Computer", select "manage")
 

Terry60

Knows where his towel is.
Staff member
#9
That shows that W7 is all together with its boot files in the same partitition, so it shouldn't need anything else to boot.
Does W7 boot OK when you remove the SSD, but don't connect the optical drive.
 
#10
Dual boot

I tried it with no cd and with the cd in the ultrabay and it hangs with a blinking cursoe and won't boot. I can boot from a CD and I booted the windows 7 installation CD and choose the option to fix the start up and it said everything was ok. I looked back at the setup menu and couldn't see anything. I posted something on the Thinkpad forurm to se if they had any suggestions. I have no ideas
 

Terry60

Knows where his towel is.
Staff member
#11
If the PC refuses to boot with the 2nd bay empty, and a perfectly good W7 on the HDD, then I'd guess there's something wrong with the way the BIOS is configured.
I'm not familiar with that model of thinkpad (I have a vintage one with dodgy RAM which stops it booting). Can you swap the HDD to the other bay instead of the SSD ?
 
#12
I reinstalled easyBCD and everything works great. I think I had the MBR on the wrong drive. Thanks for the help . Think I'll send in a donation good product