Windows 7/Fedora 12 problem

#1
Hi all,

I have two seperate installations of Win7 and Fedora 12 in two different disks. I can boot from both just fine if I change the boot order from BIOS. I tried to use EasyBCD (v2.0.0.92) to simplify the procedure by using the W7 boot manager but I can't seem to be able to make it work. I tried all possible combinations of Grub legacy and Grub 2 but I either end to a flashing cursor, a grub> prompt or a error 15 file not found. Both disks are 140gbs on a Intel P35 mobo and Quad cpu if it helps.

What I suppose it's happening is that it looks for the boot in the wrong drive, but I have no knowledge of how to fix it. Attaching a screenshot of one error (sorry for the quality).

Thanks :smile:

 

Attachments

mqudsi

Mostly Harmless
Staff member
#2
Have you tried using the "GRUB is not installed" checkbox?
 
#3
Yes I did, it ends to a grub> prompt or a blinking cursor.

Sorry, legacy grub plus box ticked: blinking cursor
Grub2: grub> prompt
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
oh! Fedora is also using grub2 these days?

Forgive me, it didn't click that this was Fedora and not Ubuntu.

Give me a couple of hours and I'll have a new build with Fedora GRUB 2 support.
 
#5
Thanks a lot for your help and the quick response, but before you waste your time for me, please double check in a different source if fedora 12 is grub2. I can't say for sure.
 

Terry60

Knows where his towel is.
Staff member
#6
From the release notes.

Fedora 9 originally included experimental support for Ext4 and Fedora 11 included Ext4 by default however GRUB in that version did not support Ext4 and hence required a separate boot partition formatted as Ext3 or Ext2. Fedora 12 now includes a updated version of GRUB with Ext4 support. Anaconda, the Fedora installer will permit this as well.
 

mqudsi

Mostly Harmless
Staff member
#7
Hmm, I think that's GRUB legacy w/ ext4 support; similar to how our own NeoGrub now supports ext4 even though it too is legacy GRUB.

From the Fedora wiki (updated w/ the release of Fedora 12): https://fedoraproject.org/wiki/Features/Grub2
The main benefit is moving to a newer upstream version that hopefully more people are working on. That said, it's not a small task, hence why we're not going to try to get it done in the super-short Fedora 12 timeframe.

There could also be new functionality, but that's currently less of the driver.
And from the discussion page on same link:

It would be great to know if this will land in Fedora 13 or be deferred.

And from the history section on that page:
(the start of a grub2 feature page, though certainly not for the fedora 12 timeframe)


So, it looks like you just have a misconfigured Fedora install. When installing Fedora, did you install GRUB? Did you install it to the bootsector?

These instructions are a bit out of date, but should explain the basic idea:
Fedora - NeoSmart Technologies Wiki