Windows 7 mbr missing/destroyed?

#1
I have scowered the forum for this specific problem, but it seems like people with similar problems had different variables, so hopefully someone can shed some light on my particular situation. I was dual booting XP and W7. I had C: xp and D:w7.

For some reason I thought the best way to get rid of XP was to just remove the parition with a partition manager. That's another issue, and I'm aware of why that was the complete wrong thing to do.

After the partition manager did it's thing and rebooted I was presented with "ERROR READING DISK INSERT SYSTEM DISK AND PRESS ENTER" or something to that effect. I tried running the w7 recovery console, and 3 hours later I was trying to manually repair the mbr. Everything seemed to go the way it was supposed to with the manual steps, but there was no progress with booting.

I decided to install w7 again on another partition just so I could boot into an OS and try to resolve the issue from the GUI side with some programs or something. It doesn't seem to be working so well. Right now in My Computer it shows that I have C: (new/current W7) D: (old W7) and E: (exact copy of D: ). All the files are there, but obviously no boot record for them. I realize that the parition manager did some pretty wacky stuff that I didn't intend on. When I go to the bootloader it doesn't show any other options. I tried adding them to the bootloader with EasyBCD, but doesn't seem to recognize them (at least not to my knowledge) and just sees them as U: on the bootloader. I tried using the tools in Diagnostics Center, but it hasn't seemed to work.

What I want to do is just recover my old install that's currently on D: then merge all the partitions on the disk (I'll do the merging part correctly this time).

Addendum:

In desperation, I tried one last time to use the W7 recover console. It found and recovered both W7 entries and put them on the bootloader. I'm not sure what happened exactly, but I think it had something to do with replacing the boot folder with Easy BCD.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
There's a bug in EasyBCD 1.7 (fixed in 2.0) where "adding" a Longhorn entry results in a "U" drive. The workaround in 1.7 is just to "change settings" and correct "u" to the right value.
Better still, use the latest EasyBCD.
 
#3
I think your original problem was because you deleted your XP partition (C), which must have been the "active" "system" partition which contained your boot files for both systems. Once you did that, the Windows MBR was unable to find any active partition on the disk, hence why it failed with the "ERROR READING DISK INSERT SYSTEM DISK AND PRESS ENTER" message.
Installing the new W7 fixed that problem however, but failed to pick up on the old W7, and add it to the boot menu.
Attempting to use EasybCD 1.7 resulted in it failing to point at the correct partition (hence U:/) the old W7 install was on. You could have fixed that problem through Change Settings like Terry said, or by using the latest beta build.

Anyway, it appears your problem is resolved already, but I figured you might like to understand what had actually happened, so it doesn't happen again in the future. :wink: