Windows 7/ OpenSuSe problems

#1
Hi everyone,
Today I had decided to install OpenSuse 11.2 and dual boot it with my existing Windows 7. All went well until I realised in Windows 7 that EasyBCD wasn't opening.

So I saw the pop-up Valid BCD Registry not detected. It wanted to correct the MBR issue. I clicked yes. Then it asked me to select the Boot Drive where 7 was installed. Only one option was available and that was the C:/ drive where Windows 7 is. So I clicked Yes. Then on the next dialog box too, I clicked Yes and then it gives me an error. Lots of them. Sometimes, wrong parameters, sometimes store import operation failed and such such. Can anyone help me here. With the way I see things, I think I need to do a reinstall of Windows 7 again. Can anyone provide assistance? Thanking You.
 

JustinW

Super Moderator
Staff member
#2
Right click Computer -> Manage -> Disk Management. Assign the small system reserved partition a drive letter and re-run EasyBCD.
 
#3
Right click Computer -> Manage -> Disk Management. Assign the small system reserved partition a drive letter and re-run EasyBCD.
Hi Kairozamorro,
It is still showing the same error that Store Import operation has failed and that a device attached to the system is not functioning. Any more suggestions to solve my problem?

Edit: Just looked at the partitions now and all I am seeing is a totally messed up system. The System Reserved partition has merged with the Linux Swap and ext4 partitions and thus causing huge problems. I think a reinstall is probably the best way to solve this but still any other way out of this.
 
Last edited:

JustinW

Super Moderator
Staff member
#4
Post a screenshot of disk management using the Go Advanced -> Paperclip icon in toolbar to upload a jpg attachment.
 
#6
Hi kairozamorro,
I downloaded the 2.0 Beta of EasyBCD and it worked well. Thanks for all your help but there is still one more problem.

I replaced the Vista bootloader to replace the GRUB loader. Unfortunately, the GRUB boot loader appears first and I see the 7 bootloader only when I select the Windows option in the GRUB installation. Anyway out for this? I am using the latest OpenSuSE 11.2. Thanking You in advance.

EDIT: This is also fixed. I used my Pendrive to use the Windows 7 Startup repair options and it has now replaced the GRUB bootloader. Phew! Gonna delete OpenSuSE now. Ubuntu was way way more easier than this. Thanks again for all the help.
 
Last edited: