Windows 7, PCLinuxOS, and EasyBCD

#1
Reposted from PCLinuxOS forums:


I have one hard drive.

It has a 100mb boot partition, a large Win 7 partition, and a Win 7 recovery partition.

I shrank the large Win7 partition to make room for Linux - I made a main Linux partition and a swap partition.

I've had success installing Linux Mint (and other distros that use Grub2). Grub2 has recognised Win7 just fine, and I was able to boot into everything I needed to.

When I installed PCLinuxOS, letting Grub1 be the main bootloader in the MBR of the hard drive, I couldn't boot into Windows.

Later, restoring the Windows MBR, I installed PCLinuxOS and put Grub1 on PCLOS' root partition. I installed EasyBCD in Windows for multi-boot.
I can get into Windows just fine. Whenever I try to boot into PLCOS, my computer just restarts.
I tried using LiLo, but it gave a kernel panic, saying it could not find the root partition.
I tried using EasyBCD's copy of Grub, and it said it couldn't find the boot files. It gave me options as to where to look in the directory, but none of them worked.

Looking at the PCLinuxOS magazine article which describes using EasyBCD to boot to PCLOS, I noticed that when you are adding or editing a boot entry, you specify the partition by drive number (hd0,1 or hd1,5 etc.). I am using EasyBCD 2.2, and it wants me to choose partitions by drive letter, e.g. C: or F:.

I don't have a second or external hard drive (can't afford one right now), or I would be using that.

Any thoughts?
Thank you.




 

Terry60

Knows where his towel is.
Staff member
#2
EasyBCD reflects whatever letter Windows has assigned to any partition whose file system it recognizes (i.e. what you see in Explorer).
Linux file systems are not known to Windows, so won't have a letter.
You select the target space, by selecting the location where you put the Linux bootloader from the dropdown list
EasyBCD > Add New Entry > Linux tab > Drive
Linux partitions won't have a letter. You should be able to identify the correct one by its size.