Windows 7, Ubuntu 9.10, Grub2, Grub4Dos

#1
I setup my machine with a Windows7 partition and a partition for Ubuntu 9.10. I used EasyBCD 2.0 Beta (build 76) to add an Ubuntu option to the boot menu selecting Grub2. When I try to boot into Ubuntu it dumps me into a Grub4Dos command prompt.

This is how I have my machine partitioned:

Windows Boot Loader
Windows 7 (C: )
Shared Drive (D: )
Ubuntu (Ext4)
Swap

Ubuntu and Swap were shown as pdc_cggabh5 and pdc_cggabh6.

I told the installer to install the bootloader (grub2) on drive #5 (pdc_cggabh5).

In grub4dos, these are the outputs of the following commands:

>root (hd0,0)
Filesystem type is ntfs, partition type 0x07
>root (hd0,1)
Filesystem type is ntfs, partition type 0x07
>root (hd0,2)
Filesystem type is ntfs, partition type 0x07
>root (hd0,3)
Error 17: Cannot mount selected partition
>root (hd0,4)
Filesystem type is ext2fs, partition type 0x83
>root (hd0,5)
Error 17: Cannot mount selected partition

I'm assuming that (hd0,4) is my ubuntu partition, however if I run:
>find --set-root /boot/grub/core.img

I get:
Error 15: File not found

I tried this:
>root(hd0,4)
Filesystem type is ext2fs, partition type 0x83
>kernel /boot/vmlinuz-2.6.31-14-generic
[Linux-bzImage, setup=0x3400, size=0x3bef40]
>initrd /boot/initrd.img-2.6.31-14-generic
[Linux-initrd @ 0x7f7b0000, 0x80fd20 bytes]
>boot

Then it loads a bunch of stuff and the end of the output says:
Begin: Running /scripts/init-premount ...
Done.
Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Done.
Begin Wiating for root file system... ...
Done.
Gave up waiting for root device. (etc...)
ALERT! does not exist. Dropping to a shell!

BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) _

At this point I have no idea what to do. I'm not convinced that the expected behavior of the entry that EasyBCD put in my Windows Bootloader is to be dropped into Grub4Dos.

Any advice?

Thanks in advance.

Addendum:

I failed to mention that I have a RAID0 hard drive configuration, and that both operating systems (Windows 7 and Ubuntu 9.10) are the 64bit versions.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
RAID 0 is currently un-supported in EasyBCD 2.0.

I hope to extend GRUB4Dos with RAID0 support at some point, but that's likely not going to happen until I have a solid week of free time to throw at this project.

Sorry, mate.
 
#3
EasyBCD is a great program, but it's not always the best solution IMHO, primarily due to the arcane restrictions that microsoft imposes on the boot loading of it's operating systems.

If you have a fairly simple setup (eg. windows 7 on one partition and another windows OP on another) this is a great solution. However if you already have a linux distro installed and are using GRUB as your boot loader it is far easier to simply edit your menu.lst file, remapping harddrives if necessary, and boot into windows 7 or vista directly from grub.


In my setup I have 3 hard drives. One drive is dedicated to windows 7 and the other has two partitions, one with windows XP and the other with Arch Linux. I first set my BIOS to boot into windows 7 and tried to use EasyBCD to boot into windows XP and Arch. Even with the default settings, for my imported boot.ini (which appeared to be set correctly) it would not boot. I think the problem is that my default bootloader on the non windows 7 drive redirects it to the grub bootloader.

In the end it was far easier to just go into linux and edit the grub bootloader, making the linux drive the first drive in the boot order. I used these instructions to modify my grub menu:
GRUB - ArchWiki

I think in general if you dual boot into linux you might find grub actually somewhat more flexible for dual booting than vista's or windows 7 bootloader.