Windows 7 & Ubuntu dual boot failure

#1
I have windows 7 installed first and ubuntu installed after, exactly as EasyBCD documentation instructs. The computer during boot shows the two operating systems but when you choose the Neosmart Linux it says Windowsfailed to start. A recent software change....Insert your Windows installation disc... It never goes to Linux although it can run Windows 7. It seems to me thta Linux loader has not perfeclty installed. Is it so? What is the solution to that problem?

Thank you very much!
 
#3
I wonder if the fact Ubuntu 9.10 is using Grub 2 and has changed the partition reference from 0 to 1, as in windows, for the first partition is relevant.
 

Terry60

Knows where his towel is.
Staff member
#4
Select grub2 from the dropdown when you create the new Linux entry. Easy2 will find and configure it automatically.
 
#5
Thank you very much for your reply and help. My problem has not been solved. I have used EasyBCD2/82.
1) I added Grub(Legacy) & Partition 4 (Linux) without ticking the GRUB isn't installed to MBR. The result is that during boot and selection of Linux, it gives black screen and stucks.
2) I added the same things but with ticking the GRUB. The result is:
Booting /boot/grub/menu.lst
Booting /grub/menu.lst
Booting /boot/grub.conf
find--set--root--ignore-floppies /boot/grub.conf
Error 15: File not found
Press any key to continue... and then enters to GRUB4DOS etc.

3) I added the Grub2 choice and the result was:
Starting main() ... (hd 0,5)
[Multiboot-kludge,loadaddr-0x100000,text-and-data=0x6211,bss=0x0,entry=0x10027c]

Sorry for this mess but I am a first year student, I must learn Linux but I propably have but luck!

Thank you very much again.
 
#6
Ok, I just tried this with an independent hard drive install of Ubuntu and and separate hard drive for Win 7. I used EasyBCD from Win 7 to set up a dual boot with Grub 2.

When I selected the Ubuntu boot menu option, I originally got a message as below.

Try (hd0,0) NTFS5 No ang0

A blinking cursor was after the end of the message and nothing happened until I hit enter. Then it went into the bootloader for Ubuntu on the other drive.

If my information is correct, since Ubuntu is on the first partition on the second drive, maybe it should now say (hd0,1) since there is no longer a 0 for a partition number.....

Please understand, I do not have a problem, just trying to supply info.
 

mqudsi

Mostly Harmless
Staff member
#7
I don't understand, how can there no longer be a partition 0?
 
#8
I don't understand, how can there no longer be a partition 0?
If I am reading it correctly, Linux has used partition 0 for the first partition in something like (hd0,0), but may have changed. I might be confusing the 0 in (hd0,0) and sda0.

You probably already know this but I am just seeing it, so it seems new to me. I got the following from this site:
https://wiki.ubuntu.com/Grub2

NOTE: The new partition naming convention. Devices start counting from 0 as done previously. sda is designated as "hd0", sdb is "hd1", etc. However the first partition is now designated as sda1. Counting partitions does not start with "0". The fifth partition on sda is sda5).
I just installed Ubuntu on the same hard drive with Win 7 as the OP seems to have done and the instructions in the tutorial worked fine.

Addendum:

I suppose I should add, Computer Guru, have you done any testing using Ubuntu 9.10 on a separate, independent install and Windows 7 using EasyBCD to set up the boot?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#9
Ah ok, Get what you mean.

Doesn't matter to EasyBCD though, because it still uses GRUB 1.0 to find and call GRUB 2.0...

I've tested a clean Windows 7/Ubuntu 9.10 dual-boot back a couple of months back, no problems to report....
 
#10
Dear all, I am coming again to the dual boot problem (windows 7 and Ubuntu 9.10 in the same hard disc). The Linux system is installed in partition 4. I use easyBCD2/82 with Grub and no ticking the box. Everything has been done as the tutorial. When I choose the Linux during booting the system stucks and the display is blank.

Please, any idea how to settle it down?
 

Terry60

Knows where his towel is.
Staff member
#11
Ubuntu 9.10 does not use grub. It uses grub2. That's what you must choose from the dropdown.
 
#12
When on the same drive, I had no problem following the tutorial. Picked Grub (Legacy) then the partition and it booted fine.

You are not pointing the loader to the swap file, are you? Remove the entry and try it again.

In the tutorial it talks about putting Grub on the Linux partition. Do you remember doing that?
 
#13
Jellin, I just installed and set up Ubuntu on a Win 7 drive again. I will post my steps, which as far as I can tell are the same as the tutorial.

Boot to Install CD
Pick install
Specify Partitions manually
Free space-add primary
added 46 G primary partition
EXT4 (this needs updating in the tutorial)
Free space - add logical
added 9 G swap partition

Name and passwords page--normal stuff

Ready to Install page.--
Bottom right is advanced button, which you click
Check Install boot loader (default)
select /dev/sda3 (My Linux install partition)
OK

Install went normally. Rebooted back into Win 7. Used EasyBCD to set up dual boot

Pick Linux/BSD tab
Grub (Legacy)
Partition 3 (once again, my Linux install partition)
Add Entry and Close.

Reboot and select NeoSmart Linux.

Got a Grub loading message, then
Grub menu w/Win 7 added to bottom.

Selected Linux and boot went fine.

I am guessing you did not load Grub on the Linux partition so when you select it, there is no boot.

Waiting eagerly for your response...... :smile:

Computer Guru, I checked the Linux Menu entry for Win 7 and it shows:
set root=(hd0,1) Win 7 is on the first partition of the only hard drive.