Windows 7 update failed and laptop won't boot. Startup repair is failing.

#1
I installed the latest round of Windows updates for my Win7 x64 install and it never completed (ran for about 24 hours) so I powered off the machine. Upon restarting, it said:

Code:
"Windows failed to start. A recent hardware or software change might be the cause" and has instructions for using system repair, then at the bottom:

File: \Boot\BCD
Status: Oxc000000f
Info: An error occurred while attempting to read the boot configuration data
So I booted off a Windows recovery disk and figured Startup Repair would fix it. Alas, after it says "Windows found problems with your computer's startup options" and asks me if I want to repair, I click "repair and restart" and it says "Failed to save startup options".

Code:
The "repair details" are:
Name: {bootmgr}
Identifier: {...}

The following options will be added:
Name: Windows Recovery Environment (recovered)
Path: Recovery\...\Winre.wim
Windows Device: Partition=D:
I've tried running Startup Repair from the manual options screen and it says it cannot repair automatically. I have two partitions, the 100MB windows System partition, which Recovery Console mounts as C:\ and my main windows partition, which it mounts as D: and I can see all of my files on it.

Running "bootrec /repairbcd" gives me "Total identified Windows Installations: 0"

I'm not sure if there might be something fishy with the way it's detecting my partition table. I just have a single drive and a single installation of Win7 on it. When I run diskpart in recovery and do list vol I get:

Code:
Volume # Ltr Label  FS   Type      Size  Status Info
Volume 0 C   System NTFS Partition 100MB Healthy
Volume 1 D          NTFS Partition 119GB Healthy
It seems that it's detecting the 100MB recovery partition (or whatever that is) as C. I'm not sure if one of these is supposed to be active or how Windows updates would even screw that up, but something is weird because it won't detect my windows install.

This sucks! Help!
 
#3
I really appreciate the reply! I should have mentioned that I tried those instructions (all the way down to the nuclear option) but I get stuck on bootrec.exe /rebuildbcd which says that no Windows installation can be found. I believe on the nuclear option the command that fails is bcdedit.exe /set {bootmgr} device partition=C: which says device not found. I believe all of this has to do with the fact that it's not detecting my Windows installation. Is there any way to repair the partition so it detects Windows? I imagine something got corrupted during the Windows update and hence it can't detect it.
 

mqudsi

Mostly Harmless
Staff member
#4
Hey,

I've clarified the instructions - if one option fails, you can move on to the next. Just start with nuclear holocaust this time, and try from there.
 
#5
Ok, now I'm having two problems with the nuclear holocaust:
1) Which drive should I be running the rest of the commands on, my C drive or the 100MB boot partition (D drive in recovery console)?
2) Running these on my C drive, I get "The boot configuration data store could not be opened. The requested system device could not be found." for every command from bcdedit /import on.
 

Terry60

Knows where his towel is.
Staff member
#6
Whichever partition contains the boot files. Windows Disk Management calls it "system".
(if you have a 100Mb system reserved partition, that's likely to be it. That's what W7 creates that for.)
 
Last edited:
#7
Ok, thanks to both of you guys, but unfortunately I'm getting the same error messages using d: instead of c:. I imagine it's because it's not detecting the Windows installation because it must've gotten corrupted when the update failed. Any final suggestions before I wipe and start again from scratch?
 
#8
I managed to recover the SYSTEM partition from an old backup so now it will boot without the recovery disk. If I let it boot on its own it goes to the Recovery Environment and automatically tries startup repair but fails. If I press F8 at boot I get the menu of options but Safe Mode, Start Normally, etc just boot to Recovery Environment. Any suggestions from here?

Addendum:

More progress: I ran bcdedit /set {default} recoveryenabled No and now I'm getting:

"Windows failed to load because the system registry file is missing, or corrupt"

I think this might be the final nail in the coffin, but maybe someone knows a solution...
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#9
Use system restore from the recovery environment?