Windows 7 won't boot after power failure...

#1
I've done a lot of googling and I have been unable to find a solution to my problem. At 8:00 AM yesterday, I had a power failure. My desktop was suspended in sleep mode while the outage occurred and successfully booted up once after the power failure. I noticed there was no sound so I tried rebooting the computer a second time and then my computer booted straight to start up repair. It was unable to fix any problems and continues to boot to start up repair with the same result over and over. I have not installed any new hardware and am running out of ideas.

Here is what I have tried so far with no luck:
bootrec /fixmbr, bootrec /fixboot, bootrec /rebuildbcd
booting into safe mode
booting to last known good configuration
unplugging all usb devices at sttartup
setting bios to default settings, changing boot orders
memtest
chkdsk /r

I tried sfc /scannow and it keeps giving me an error message along the lines of "A repair is already scheduled, please reboot". I have tried running the command off the built in system recovery console and the one from the windows 7 dvd and they both give this message. Is there a way to disable or stop this pending scan its talking about?

I also ran bcdedit /set {default} recoveryenabled No which stopped startup repair from starting, but now I get an error message telling me "Windows failed to load because a critical system file is missing or corrupt" and it says the file is \Windows\system32\DRIVERS\nvstor64.sys.

Here is the message start up repair provides:
Problem Signature:
Problem Event Name: StartupRepairOffline
Problem Signature 01: 6.1.7100.00
Problem Signature 02: 6.1.7100.00
Problem Signature 03: unknown
Problem Signature 04: 21201254
Problem Signature 05: AutoFailover
Problem Signature 06: 21
Problem Signature 07: CorruptFile
OS Version: 6.1.7100.2.0.0.256.1
Local ID: 1033


I am running Windows 7 RC 7100 64 bit on a custom built pc (Intel e8400 3.0 GHz Core 2 Duo, Nvdia 8600 gt, asus Striker II mobo). I got the official release from microsoft. This is the first and only problem I have had with Windows 7
. I was planning on making my first backup this week as well so my timing couldn't have been worse. Any advice would be greatly appreciated.
 
#2
Hello bprr. Welcome to NST.
Unfortunately, it seems a reinstall may be your only option at this point...
You've already tried just about everything that comes to mind, and it didn't help.
You can rescue your data with a free .iso download of a Linux distro LiveCD, which you can burn to a CD with Imgburn, and then use the resulting CD to rescue your data with, to external storage.
 
#3
I have had a unique problem with Windows 7 Computers.. If you have unhooked one or more USB devices or moved them to even a new port you may get the same sort of problem as above. Try just pluging in the usb devices (scanners, external drives, even keyboards and mice) into their original ports.