windows 7 wont boot anymore, get \nst\autoneogrub0.mbr missing or corrupt

Hi there,
I installed Ubuntu 10.10 Maverick Meerkat onto my Asus Eeepc 1215n notebook.
I previously had Windows 7 installed, and still do, but it wont boot anymore due to the error stated below.

Firstly, I accidentally installed grub2 to partition /dev/sda6 (where ubuntu 10.10 was to be installed) misread the installation part and thought that i was choosing where to install linux :-/
So I then used EasyBCD to be able to boot into linux. I then found out about grub2 and installed that.
Both win7 and ubuntu were dual booting fine. Then I was intrigued by the windows vista (not actually having Vista loaded on my pc, but being able to boot into it?!), so clicked to load vista, and it came up with the "recover, backup, exit" options, so I exited. Next time I tried to open win7 I receive this error:
windows failed to start. A recent hardware or software change might be
the cause. To fix problem:

1. insert our windows installation disc and restart your computer
2. choose your language settings and click "next"
3. click "repair your computer"

if you do not have this disc, contact your system administrator or
computer manufacturer for assistance.

File: \NST\AutoNeoGrub0.mbr
Status: 0xc000000f
Info: The selected entry could not be loaded because the application
is missing or corrupt.
I'm not at home at the moment, so cant back up my whole c:\ drive, so I don't really want to use the recover option from the vista partition.

I've download the windows 7 recovery cd from
but as i dont have a cd drive, ive tried using both unetbootin and universalusbinstaller to load it onto a usb. But when i boot into the usb, it just shows "default" on a 10second countdown, that resets when it gets to 0 or when you press default.

Does anyone know how I can fix this?

PS I was using EasyBCD v2.0.2
Last edited:
You need to use EasyBCD to create a bootable USB on another Windows machine. Then copy the contents of the ISO you downloaded from our ISO to the USB, and use EasyBCD to add a WinPE entry pointing to the .WIM file on the USB.

You can then use this stick to boot into the recovery environment on the damaged pc.
thanks for the reply, but i get a couple of problems with that:
firstly, when i copy the contents of the iso over, i get asked if i want to replace the folder "boot" for the "boot" folder from the iso, and the same with the "bootmgr" file.
what should i do?
when i try and use WinPE it asks for the recovery disc, so ive used daemon tools to mount the iso and then it continues, but it does not boot because of the overwritten files.... what should i do?

I placed the contents of the iso on the usb then used the WinPE and pointed to the .wim on the mounted iso file, then removed the usb. I used it on the problem laptop, and the recovery cd loaded :smile:

It noticed there was an error, and automatically fixed it, leaving me with a recovered version of Windows 7
When i launch windows, it now boots :smile: but after the splash screen (where the 4colours come and the bar ticks along) it says
 autochk not found skipping autocheck

then it shows a BSOD! for half a second and reboots. It doesn't stay long enough to read what it says.
then i tried to load windows again and got an error something like this
 -resort?-repair - 0xc000000e
The boot selection failed because a required device is inaccesable

I then ran the recovery disk again and try to fix windows, but it said a fix could not be found, and offered to report to micrsoft. The diagnostics came through successful except
System boot log diagnostics
Boot manager generic failure 0xc000000e
then the last entry:
Root cause found:
A recent driver istalation or upgrade ma be preventing the system from starting
Repair actio: System files integrity check and repair
Result: failed, error code = 0x57

Any help or ideas would be appreciated, but if it is not your area of expertise, then don't worry.
Thanks for the help getting the restore CD and making it bootable :smile:
Last edited:
No problem.

Sounds like you don't have an active partition any more. I would use diskpart from the command line to set the C: bootable, then try the automated startup recovery wizard again.
Hi again, ive just had a look at my fdisk:

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       17054   136985231    7  HPFS/NTFS
/dev/sda2           17055       19013    15728640   1b  Hidden W95 FAT32
/dev/sda3           19014       30398    91449982    f  W95 Ext'd (LBA)
/dev/sda4           30399       30402       20664   ef  EFI (FAT-12/16/32)
/dev/sda5           19014       21805    22426708+  83  Linux
/dev/sda6           21806       29645    62973952   83  Linux
/dev/sda7           29646       30398     6048441   82  Linux swap / Solaris

as you can see, windows in /dev/sda1 is of type 7, which is bootable.

Ive been looking on the internet to solutions for "autochk program not found" and "000021a fatal system error" (that is what i get on the BSOD) and they all say the general solution is that the disk is changed to hidden, and you must change back to type 7 to make it bootable again.

any ideas? or do you know of any forums that may be able to help?
i used the \fixmbr \fixboot \rebuildbcd when i first got to the command prompt on the recovery cd.
it boots now, but then BSODs, so i dont think i need to do any of the bcd stuff.

I'm going to wait until i get home and then backup my C: drive and reinstall windows, hopefully it can reinstall without wiping the drive, but I guess i will have to see! thanks
I am facing the same issue except i am not able to boot into Ubuntu. I am having a DELL XPS14 dualbooting Win8 & Ubuntu 12.04 Precise Pangolin. Win8 boots fine.

I tried to use the Repair boot files utility in EasyBCD but did not help..

Any HELP??
Last edited by a moderator: