Windows 7 x86 Disk Management causes non-booter


I've got a problem with a recent clean installation of Windows 7 on my Asus Eee PC.
When I installed Win 7, I left the original restore partition in place (PE) and the 39MB one that is after that on the disk. Both located at the end of the disk.
The layout was:
100Mb Boot partition
141Gb Win7 (C)
7.8Gb PE (no letter)
39Mb unknown (no letter)

I tried to shrink the Win 7 partition using the Disk Management, which worked ok. When the shrinking was done, Win7 reported suddenly the PE partition as D: and asked to insert a disk in E:...
I removed the drive letters d: and e: from those partitions and wanted to add a partition in the free space that was left after shrinking.
The coloured bars above each partition had turned yellow/orange and the drive letters were gone, I decided first to reboot to see everything was ok since it seemed suspicious that windows suddenly added the drive-letters, which I had removed as soon as I installed the system.

The reboot resulted in a flashing cursor after passing through the BIOS.

I booted from the install CD (copied onto a USB drive) and opted to repair.
No luck there, no restore points and the Startup Repair seemed to think everything is ok. (No errors found)

Is there any hope in reviving the installation or is it going to be a re-install?

Addendum: It's FIXED!

I used the methods of Recovering the Vista Bootloader from the DVD.
Step 3 did fail, it found 0 windows installations. I went onto step 4 but couldn't find bcedit (of course, it was called bcdedit) and rebooted the machine.
I was about to attach my USB disk to my other PC to see were bcdedit was located, but to my surprise my Eee pc just booted windows when I turned to grab the usb-disk.

I have no clue why and how I fixed it, one of the miracles of the world of windows I'll never understand. Sometimes things do get fixed, even if it says not so. (0 windows installations found)

I thought it would be a good idea to share this, just in case someone else encounters the same.

Concerning the yellow/orange bar, that was supposed to be 'simple volumes', I don't have those on my regular pc. :?? I hope it didn't confuse anybody.
Last edited:


Mostly Harmless
Staff member
Congrats on getting that fixed, Dutchie.... and welcome to NST :smile: