Windows 8 + Ubuntu = so many problems.

#1
Okay first I hate secureboot. It's ****ing garbage.

Anyways, so I've done everything, tried everything. I had gotten Ubuntu booting, I installed my AMD graphics drivers, and had rebooted. For some reason. This happens


542671_10200666676247987_1161253326_n.jpg

It hangs here. I have no idea how to fix it, and I've googled and googled and found nothing but people having issues with OLD versions of easybcd. I'm using the latest version.


Note: my motherboard doesn't support booting legacy, only UEFI.

I do not have windows installed VIA EFI, it's installed on the MBR, not GPT. If I would have known this was going to be a pain in the ass I would have installed with GPT and used all the EFI crap, and just installed Ubuntu with the EFI partition and everything. But I didn't, and I really don't want to reinstall windows and ubuntu just to use ubuntu.

Please someone help me with this problem. I am irritated.

HDD: 1TB & 120GB SSD.

"System Reserved" on SSD
Windows 8 on SSD
/boot partition for GRUB on SSD
Ubuntu on SSD
/home on a partition on the 1TB
Then the 1TB also serves as the Data drive for Windows.


I've tried everything I could, asked people. I can't figure it out. Please help?