Windows Error pop-up using Mozilla Firefox

Ex_Brit

If you're going through hell, keep going
Staff member
#1
I've been using Firefox lately because McAfee refuses to fix their darned website to work properly in IE7.
But when I click any desktop shortcut this appears first, followed by the page.


Why?
 

mqudsi

Mostly Harmless
Staff member
#2
Sounds like Firefox isn't properly associated with the http://* protocol.

Try this:
Set IE back as the default browser, then re-associate Firefox again.
 

Ex_Brit

If you're going through hell, keep going
Staff member
#3
Done that twice already and it still happens. I'll go back to using IE7 anyway eventually.
 

Sarge

Active Member
#4
I've been using Firefox lately because McAfee refuses to fix their darned website to work properly in IE7.
But when I click any desktop shortcut this appears first, followed by the page.


Why?
Wait, wait, wait, let FireFox doctor take a look at it... Hmm...

When you click any desktop shortcut, do you mean like shortcut to anything else/any other application?
For example: Opening FireFox icon, and you get that, and it doesn't let you run FireFox?
 
Last edited:

Ex_Brit

If you're going through hell, keep going
Staff member
#5
No, only desktop shortcuts to my favourite websites. That pops up, but then the page opens in FF anyway.
This only happens if FF is the default browser.
 

mqudsi

Mostly Harmless
Staff member
#6
You should be able to manually specify it with the set program assocations wizard:
 

Attachments

Ex_Brit

If you're going through hell, keep going
Staff member
#7
It's strange that this happens only from desktop shortcuts, not from my Favorites or from an email hyperlink.
I can't see anything wrong here:



Either way, no change.
 
Last edited:

Sarge

Active Member
#8
Is this first time it is happening? Or it happened before?
Try making new shortcut and running it.
 

Ex_Brit

If you're going through hell, keep going
Staff member
#9
Makes no difference. The generic "e" icons even had the FF logo on them and still I got that.
 

Sarge

Active Member
#10
In that case, I will personally boot into Vista and test this.
 

Ex_Brit

If you're going through hell, keep going
Staff member
#11
I've been researching this and apparently it's been a problem off and on since the very earliest Firefox. I even just tried creating a desktop shortcut using Firefox...same error!! It's like Vista (or something) doesn't like Firefox. By the way everything is totally up to date including FF.
 

mqudsi

Mostly Harmless
Staff member
#12
OK, it's not exactly a "fix" but it's a workaround that will do.

Change the shortcut link:
Example:
Shortcut Properties -> Destination -> "http://neosmart.net/"
Change that to
Destination -> "firefox.exe http://neosmart.net/"

Addendum:

I've been researching this and apparently it's been a problem off and on since the very earliest Firefox. I even just tried creating a desktop shortcut using Firefox...same error!! It's like Vista (or something) doesn't like Firefox. By the way everything is totally up to date including FF.
Actually, it's Firefox that doesn't like Vista. They raised hell over this saying that Vista was blocking non-IE programs from being the default, I think it was even on Slashdot or something.... then it was admitted that it's just incorrect code on Firefox author's behalf (esp. since other browsers could become default no problem).

It's the same "bug" here: How to uninstall Internet Explorer 7 from Vista - The NeoSmart Forums
 
Last edited:

Ex_Brit

If you're going through hell, keep going
Staff member
#13
Last edited:

mqudsi

Mostly Harmless
Staff member
#14
You're right.

This worked for me:
Code:
"C:\Program Files\Mozilla Firefox\firefox.exe" http://neosmart.net/
Make sure you're making a new application shortcut, and not an internet shortcut.
 

Ex_Brit

If you're going through hell, keep going
Staff member
#15
Hey CG, you've got it! I did that just for those stupid McAfee forums and it works. Takes a while to open as I now have IE7 set as default but it works.
This is all because Chris Uhl the guy in charge of the forums doesn't appear to have done anything about my IE7 issue. I think he has other duties, no doubt more important.
By the way, there's no "application" option for a new shortcut....just right-click desktop, "New - Shortcut".
Thanks for all the help.
 

Sarge

Active Member
#16
I'm happy it worked :smile:
 

Ex_Brit

If you're going through hell, keep going
Staff member
#17
Thanks Sarge. I often wondered how to get certain shortcuts to open in different browsers.
 

mqudsi

Mostly Harmless
Staff member
#18
Yep, most browsers accept a URI as the first argument.
I've done it to some IE-specific links I have, "iexplore.exe %uri%"